summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-01-24 22:07:50 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-01-24 22:07:50 +0000
commit2394133dbfe2faba24af3e0c795c2cb5792b2268 (patch)
treeb728dabcfcd76244d51943e327186f8bb3db81e4 /media-video
parentstable for x86 (diff)
downloadgentoo-2-2394133dbfe2faba24af3e0c795c2cb5792b2268.tar.gz
gentoo-2-2394133dbfe2faba24af3e0c795c2cb5792b2268.tar.bz2
gentoo-2-2394133dbfe2faba24af3e0c795c2cb5792b2268.zip
added dv to IUSE, it was already used by the ebuild. fixes bug #79319
(Portage version: 2.0.51-r14)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mplayer/ChangeLog5
-rw-r--r--media-video/mplayer/mplayer-1.0_pre6.ebuild13
2 files changed, 14 insertions, 4 deletions
diff --git a/media-video/mplayer/ChangeLog b/media-video/mplayer/ChangeLog
index c53a42f9a481..5dc7d7d89e6b 100644
--- a/media-video/mplayer/ChangeLog
+++ b/media-video/mplayer/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-video/mplayer
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.260 2005/01/23 21:06:37 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/ChangeLog,v 1.261 2005/01/24 22:07:50 luckyduck Exp $
+
+ 24 Jan 2005; Jan Brinkmann <luckyduck@gentoo.org> mplayer-1.0_pre6.ebuild:
+ added dv to IUSE, it was already used by the ebuild. fixes bug #79319
23 Jan 2005; Jan Brinkmann <luckyduck@gentoo.org>
mplayer-1.0_pre5-r5.ebuild, mplayer-1.0_pre6.ebuild:
diff --git a/media-video/mplayer/mplayer-1.0_pre6.ebuild b/media-video/mplayer/mplayer-1.0_pre6.ebuild
index a8f532e6064a..ba06c5ea7786 100644
--- a/media-video/mplayer/mplayer-1.0_pre6.ebuild
+++ b/media-video/mplayer/mplayer-1.0_pre6.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0_pre6.ebuild,v 1.17 2005/01/23 21:06:38 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0_pre6.ebuild,v 1.18 2005/01/24 22:07:50 luckyduck Exp $
inherit eutils flag-o-matic kernel-mod
-IUSE="3dfx 3dnow 3dnowex aalib alsa altivec arts bidi debug divx4linux doc dts dvb cdparanoia directfb dvd dvdread edl encode esd fbcon gif ggi gtk i8x0 ipv6 jack joystick jpeg libcaca lirc live lzo mad matroska matrox mpeg mmx mmx2 mythtv nas nls nvidia oggvorbis opengl oss png real rtc samba sdl sse svga tga theora truetype v4l v4l2 X xanim xinerama xmms xv xvid xvmc"
+IUSE="3dfx 3dnow 3dnowex aalib alsa altivec arts bidi debug divx4linux doc dts
+dvb cdparanoia directfb dvd dv dvdread edl encode esd fbcon gif ggi gtk i8x0 ipv6 jack joystick jpeg libcaca lirc live lzo mad matroska matrox mpeg mmx mmx2 mythtv nas nls nvidia oggvorbis opengl oss png real rtc samba sdl sse svga tga theora truetype v4l v4l2 X xanim xinerama xmms xv xvid xvmc"
BLUV=1.4
SVGV=1.9.17
@@ -220,7 +221,13 @@ src_compile() {
myconf="${myconf} --disable-dvdread --disable-mpdvdkit"
fi
myconf="${myconf} $(use_enable edl)"
- myconf="${myconf} $(use_enable encode mencoder)"
+
+ if use encode ; then
+ myconf="${myconf} --enable-mencoder $(use_enable dv libdv)"
+ else
+ myconf="${myconf} --disable-mencoder --disable-libdv"
+ fi
+
myconf="${myconf} $(use_enable gtk gui)"
if use !gtk && use !X && use !xv && use !xinerama; then