summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-12-25 03:52:55 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-12-25 03:52:55 +0000
commit1ff68d76a6b1ece6543f8da15265532c78a574fe (patch)
treebde65c1194cd72897ef5a035232c57bd8e6b2b1b /media-video/xine-ui
parentVersion bump. (diff)
downloadgentoo-2-1ff68d76a6b1ece6543f8da15265532c78a574fe.tar.gz
gentoo-2-1ff68d76a6b1ece6543f8da15265532c78a574fe.tar.bz2
gentoo-2-1ff68d76a6b1ece6543f8da15265532c78a574fe.zip
Version bump.
Diffstat (limited to 'media-video/xine-ui')
-rw-r--r--media-video/xine-ui/ChangeLog7
-rw-r--r--media-video/xine-ui/files/digest-xine-ui-0.9.161
-rw-r--r--media-video/xine-ui/xine-ui-0.9.16.ebuild64
3 files changed, 71 insertions, 1 deletions
diff --git a/media-video/xine-ui/ChangeLog b/media-video/xine-ui/ChangeLog
index 99c570975d36..50b89e39bb11 100644
--- a/media-video/xine-ui/ChangeLog
+++ b/media-video/xine-ui/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/xine-ui
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.22 2002/12/17 22:37:46 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/ChangeLog,v 1.23 2002/12/25 03:52:55 agenkin Exp $
+
+*xine-ui-0.9.16 (24 Dec 2002)
+
+ 24 Dec 2002; Arcady Genkin <agenkin@gentoo.org> :
+ New version.
*xine-ui-0.9.15 (28 Nov 2002)
diff --git a/media-video/xine-ui/files/digest-xine-ui-0.9.16 b/media-video/xine-ui/files/digest-xine-ui-0.9.16
new file mode 100644
index 000000000000..d470ee6c36ce
--- /dev/null
+++ b/media-video/xine-ui/files/digest-xine-ui-0.9.16
@@ -0,0 +1 @@
+MD5 62e5c243b5bf838a6bb255c5a2eb52c0 xine-ui-0.9.16.tar.gz 2363452
diff --git a/media-video/xine-ui/xine-ui-0.9.16.ebuild b/media-video/xine-ui/xine-ui-0.9.16.ebuild
new file mode 100644
index 000000000000..c3bc000e8eb0
--- /dev/null
+++ b/media-video/xine-ui/xine-ui-0.9.16.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/xine-ui/xine-ui-0.9.16.ebuild,v 1.1 2002/12/25 03:52:55 agenkin Exp $
+
+DESCRIPTION="Skinned front end for Xine movie player."
+HOMEPAGE="http://xine.sourceforge.net/"
+LICENSE="GPL-2"
+
+DEPEND="media-libs/libpng
+ >=media-libs/xine-lib-1_alpha2
+ X? ( virtual/x11 )
+ aalib? ( media-libs/aalib )
+ gnome? ( gnome-base/ORBit )
+ directfb? ( media-libs/aalib
+ >=dev-libs/DirectFB-0.9.9 )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+IUSE="X aalib gnome nls directfb"
+
+SLOT="0"
+KEYWORDS="~x86"
+
+S=${WORKDIR}/${P}
+SRC_URI="mirror://sourceforge/xine/${P}.tar.gz"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ #patch -p1 < ${FILESDIR}/xine-ui-configure.patch || die "patch failed"
+
+ use directfb || ( \
+ sed -e "s:dfb::" src/Makefile.in \
+ > src/Makefile.in.hacked
+ mv src/Makefile.in.hacked src/Makefile.in
+ )
+
+ sed -e "s:LDFLAGS =:LDFLAGS = -L/lib:" src/xitk/Makefile.in \
+ > src/xitk/Makefile.in.hacked
+ mv src/xitk/Makefile.in.hacked src/xitk/Makefile.in
+
+}
+
+src_compile() {
+
+ # Most of these are not working currently, but are here for completeness
+ local myconf
+ use X || myconf="${myconf} --disable-x11 --disable-xv"
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ docdir=/usr/share/doc/${PF} \
+ docsdir=/usr/share/doc/${PF} \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README
+}