summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-05-19 15:01:46 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-05-19 15:01:46 +0000
commit013085a5314f727b8395d25525fd73c4af440e03 (patch)
treebc596d90fbb29ecbbd2576d7553d06aaea486f0c /media-video/vmaid/vmaid-2.2.0.ebuild
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-013085a5314f727b8395d25525fd73c4af440e03.tar.gz
gentoo-2-013085a5314f727b8395d25525fd73c4af440e03.tar.bz2
gentoo-2-013085a5314f727b8395d25525fd73c4af440e03.zip
Removed old version.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-video/vmaid/vmaid-2.2.0.ebuild')
-rw-r--r--media-video/vmaid/vmaid-2.2.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-video/vmaid/vmaid-2.2.0.ebuild b/media-video/vmaid/vmaid-2.2.0.ebuild
new file mode 100644
index 000000000000..f8b4ca1b9668
--- /dev/null
+++ b/media-video/vmaid/vmaid-2.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/vmaid/vmaid-2.2.0.ebuild,v 1.1 2009/05/19 15:01:46 matsuu Exp $
+
+DESCRIPTION="Video maid is the AVI file editor"
+HOMEPAGE="http://vmaid.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/vmaid/33098/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa ao mime win32codecs"
+
+RDEPEND=">=x11-libs/gtk+-2
+ ao? ( media-libs/libao )
+ !ao? ( alsa? ( >=media-libs/alsa-lib-0.9 ) )
+ mime? ( x11-misc/shared-mime-info )
+ win32codecs? ( media-libs/win32codecs )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/pkgconfig
+ app-text/scrollkeeper"
+
+src_compile() {
+ local myconf
+
+ if use ao ; then
+ myconf="${myconf} --with-ao=yes"
+ elif use alsa ; then
+ myconf="${myconf} --with-alsa=yes"
+ fi
+
+ econf \
+ $(use_enable mime) \
+ $(use_with win32codecs w32) \
+ ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS CONTRIBUTORS ChangeLog NEWS README
+ dohtml -r doc/{en,ja}
+}