summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-05-19 10:14:31 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-05-19 10:14:31 +0000
commitc455eb603b3772457ce5f35378da714569251d24 (patch)
treee5bac804cd14899a9de20c99a51f75b1bb944194 /media-video/vlc
parentversion bump (diff)
downloadgentoo-2-c455eb603b3772457ce5f35378da714569251d24.tar.gz
gentoo-2-c455eb603b3772457ce5f35378da714569251d24.tar.bz2
gentoo-2-c455eb603b3772457ce5f35378da714569251d24.zip
added USE dependent ALSA support
Diffstat (limited to 'media-video/vlc')
-rw-r--r--media-video/vlc/ChangeLog9
-rw-r--r--media-video/vlc/files/digest-vlc-0.3.01
-rw-r--r--media-video/vlc/files/digest-vlc-0.3.1-r11
-rw-r--r--media-video/vlc/vlc-0.3.1-r1.ebuild114
4 files changed, 123 insertions, 2 deletions
diff --git a/media-video/vlc/ChangeLog b/media-video/vlc/ChangeLog
index dda7f9763fb9..a996b68e005d 100644
--- a/media-video/vlc/ChangeLog
+++ b/media-video/vlc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/vlc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.2 2002/05/07 16:06:54 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/ChangeLog,v 1.3 2002/05/19 10:14:31 seemant Exp $
+
+*vlc-0.3.1-r1 (19 May 2002)
+
+ 19 May 2002; Seemant Kulleen <seemant@gentoo.org> vlc-0.3.1-r1.ebuild
+ files/digest-vlc-0.3.1-r1 :
+
+ Added USE dependent ALSA support, since gentoo now defaults to alsa-0.9
*vlc-0.3.1 (07 May 2002)
diff --git a/media-video/vlc/files/digest-vlc-0.3.0 b/media-video/vlc/files/digest-vlc-0.3.0
deleted file mode 100644
index b459da90a108..000000000000
--- a/media-video/vlc/files/digest-vlc-0.3.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 766c603baf97ffe3ce51f8fccf554c6a vlc-0.3.0.tar.gz 1160618
diff --git a/media-video/vlc/files/digest-vlc-0.3.1-r1 b/media-video/vlc/files/digest-vlc-0.3.1-r1
new file mode 100644
index 000000000000..b2b7ad689e53
--- /dev/null
+++ b/media-video/vlc/files/digest-vlc-0.3.1-r1
@@ -0,0 +1 @@
+MD5 bd679a84b0b29e7e87b43f4f901af5d1 vlc-0.3.1.tar.gz 1172172
diff --git a/media-video/vlc/vlc-0.3.1-r1.ebuild b/media-video/vlc/vlc-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..973c29233f03
--- /dev/null
+++ b/media-video/vlc/vlc-0.3.1-r1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Nathaniel Hirsch <nh2@njit.edu> Achim Gottinge <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-0.3.1-r1.ebuild,v 1.1 2002/05/19 10:14:31 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="VideoLAN Client - DVD/video player"
+SRC_URI="http://www.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.gz"
+HOMEPAGE="http://www.videolan.org"
+
+DEPEND="X? ( virtual/x11 )
+ qt? ( =x11-libs/qt-2.3* )
+ dvd? ( media-libs/libdvdread
+ media-libs/libdvdcss )
+ >=media-libs/libsdl-1.1.8-r1
+ esd? ( >=media-sound/esound-0.2.22 )
+ ggi? ( >=media-libs/libggi-2.0_beta3 )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ kde? ( kde-base/kdelibs )
+ arts? ( kde-base/kdelibs )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )
+ ncurses? ( sys-libs/ncurses )
+ oggvorbis? ( >=media-libs/libvorbis )
+ alsa? ( >=media-libs/alsa-lib-0.9 )"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile(){
+
+ use X \
+ && myconf="${myconf} --enable-x11 --enable-xvideo" \
+ || myconf="${myconf} --disable-x11 --disable-x11"
+
+ use qt \
+ && myconf="${myconf} --enable-qt" \
+ || myconf="${myconf} --disable-qt"
+
+ use dvd \
+ && myconf="${myconf} \
+ --enable-dvd \
+ --enable-dvdread \
+ --enable-vcd" \
+ || myconf="${myconf} --disable-dvd --disable-dvdread --disable-vcd"
+
+ use esd \
+ && myconf="${myconf} --enable-esd" \
+ || myconf="${myconf} --disable-esd"
+
+ use ggi \
+ && myconf="${myconf} --enable-ggi" \
+ || myconf="${myconf} --disable-ggi"
+
+ use gtk \
+ && myconf="${myconf} --enable-gtk" \
+ || myconf="${myconf} --disable-gtk"
+
+ use kde \
+ && myconf="${myconf} --enable-kde" \
+ || myconf="${myconf} --disable-kde"
+
+ use nls \
+ || myconf="${myconf} --disable-nls"
+
+ use 3dfx \
+ && myconf="${myconf} --enable-glide" \
+ || myconf="${myconf} --disable-glide"
+
+ use arts \
+ && myconf="${myconf} --enable-arts" \
+ || myconf="${myconf} --disable-arts"
+
+ use gnome \
+ && myconf="${myconf} --enable-gnome" \
+ || myconf="${myconf} --disable-gnome"
+
+ use ncurses \
+ && myconf="${myconf} --enable-ncurses" \
+ || myconf="${myconf} --disable-ncurses"
+
+ use directfb \
+ && myconf="${myconf} --enable-fb" \
+ || myconf="${myconf} --disable-fb"
+
+ use oggvorbis \
+ && myconf="${myconf} --enable-vorbis" \
+ || myconf="${myconf} --disable-vorbis"
+
+ use alsa \
+ && myconf="${myconf} --enable-alsa" \
+ || myconf="${myconf} --disable-alsa"
+
+ # vlc uses its own ultraoptimizaed CXXFLAGS
+ # and forcing custom ones generally fails building
+ export CXXFLAGS=""
+ export CFLAGS=""
+
+ ./configure \
+ --prefix=/usr \
+ --with-sdl \
+ --disable-alsa \
+ --disable-a52 \
+ --enable-release \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install() {
+
+ dodir /usr/{bin,lib}
+ make DESTDIR=${D} install || die
+
+}
+