summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-02-21 17:25:34 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-02-21 17:25:34 +0000
commitf2649dbb1bc5a61dc4be81bb0b3cfd8c0c82d71e (patch)
treec38b2c425ca0aa2bc703cd40fdad8e97e60f5d36 /media-video/vlc/vlc-2.1.9999.ebuild
parentppc64 stable wrt bug #492122 (diff)
downloadgentoo-2-f2649dbb1bc5a61dc4be81bb0b3cfd8c0c82d71e.tar.gz
gentoo-2-f2649dbb1bc5a61dc4be81bb0b3cfd8c0c82d71e.tar.bz2
gentoo-2-f2649dbb1bc5a61dc4be81bb0b3cfd8c0c82d71e.zip
Backport the 9999 fixes that still apply to the 2.1.9999 branch, preparing for the 2.1.3 version bump.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'media-video/vlc/vlc-2.1.9999.ebuild')
-rw-r--r--media-video/vlc/vlc-2.1.9999.ebuild29
1 files changed, 23 insertions, 6 deletions
diff --git a/media-video/vlc/vlc-2.1.9999.ebuild b/media-video/vlc/vlc-2.1.9999.ebuild
index 95a5387a839b..5002731b86b6 100644
--- a/media-video/vlc/vlc-2.1.9999.ebuild
+++ b/media-video/vlc/vlc-2.1.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-2.1.9999.ebuild,v 1.14 2014/01/30 16:40:36 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-2.1.9999.ebuild,v 1.15 2014/02/21 17:25:34 tomwij Exp $
EAPI="5"
@@ -43,7 +43,7 @@ fi
IUSE="a52 aalib alsa altivec atmo +audioqueue avahi +avcodec
+avformat bidi bluray cdda cddb chromaprint dbus dc1394 debug dirac
directfb directx dts dvb +dvbpsi dvd dxva2 elibc_glibc egl +encode faad fdk
- fluidsynth +ffmpeg flac fontconfig +gcrypt gme gnome gnutls
+ fluidsynth +ffmpeg flac fontconfig +gcrypt gles1 gles2 gme gnome gnutls
growl httpd ieee1394 ios-vout jack kate kde libass libcaca libnotify
libsamplerate libtiger linsys libtar lirc live lua +macosx
+macosx-audio +macosx-dialog-provider +macosx-eyetv +macosx-quartztext
@@ -52,7 +52,7 @@ IUSE="a52 aalib alsa altivec atmo +audioqueue avahi +avcodec
png +postproc projectm pulseaudio +qt4 qt5 rdp rtsp run-as-root samba
schroedinger sdl sdl-image sftp shout sid skins speex sse svg +swscale
taglib theora tremor truetype twolame udev upnp vaapi v4l vcdx vdpau
- vlm vorbis wma-fixed +X x264 +xcb xml xv zvbi"
+ vlm vnc vorbis wma-fixed +X x264 +xcb xml xv zvbi"
RDEPEND="
!<media-video/ffmpeg-1.2:0
@@ -85,6 +85,8 @@ RDEPEND="
fluidsynth? ( >=media-sound/fluidsynth-1.1.2:0 )
fontconfig? ( media-libs/fontconfig:1.0 )
gcrypt? ( >=dev-libs/libgcrypt-1.2.0:0 )
+ gles1? ( virtual/opengles:0 )
+ gles2? ( virtual/opengles:0 )
gme? ( media-libs/game-music-emu:0 )
gnome? ( gnome-base/gnome-vfs:2 dev-libs/glib:2 )
gnutls? ( >=net-libs/gnutls-3.0.20:0 )
@@ -144,6 +146,7 @@ RDEPEND="
vaapi? ( x11-libs/libva:0 virtual/ffmpeg[vaapi] )
vcdx? ( >=dev-libs/libcdio-0.78.2:0 >=media-video/vcdimager-0.7.22:0 )
vdpau? ( >=x11-libs/libvdpau-0.6:0 !<media-video/libav-9.11 )
+ vnc? ( >=net-libs/libvncserver-0.9.9:0 )
vorbis? ( media-libs/libvorbis:0 )
X? ( x11-libs/libX11:0 )
x264? ( >=media-libs/x264-0.0.20090923:0= )
@@ -237,7 +240,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-2.1.0-newer-rdp.patch
epatch "${FILESDIR}"/${PN}-2.1.0-libva-1.2.1-compat.patch
- # Fix up broken audio; first is a fixed reversed bisected commit, latter two are backported.
+ # Fix up broken audio when skipping using a fixed reversed bisected commit.
epatch "${FILESDIR}"/${PN}-2.1.0-TomWij-bisected-PA-broken-underflow.patch
# Disable avcodec checks when avcodec is not used.
@@ -316,6 +319,8 @@ src_configure() {
$(use_enable fluidsynth) \
$(use_enable fontconfig) \
$(use_enable gcrypt libgcrypt) \
+ $(use_enable gles1) \
+ $(use_enable gles2) \
$(use_enable gme) \
$(use_enable gnome gnomevfs) \
$(use_enable gnutls) \
@@ -323,6 +328,7 @@ src_configure() {
$(use_enable httpd) \
$(use_enable ieee1394 dv1394) \
$(use_enable ios-vout) \
+ $(use_enable ios-vout ios-vout2) \
$(use_enable jack) \
$(use_enable kate) \
$(use_with kde kde-solid) \
@@ -353,6 +359,7 @@ src_configure() {
$(use_enable neon) \
$(use_enable ogg) $(use_enable ogg mux_ogg) \
$(use_enable omxil) \
+ $(use_enable omxil omxil-vout) \
$(use_enable opencv) \
$(use_enable opengl glx) \
$(use_enable opus) \
@@ -389,6 +396,7 @@ src_configure() {
$(use_enable vcdx) \
$(use_enable vdpau) \
$(use_enable vlm) \
+ $(use_enable vnc libvnc) \
$(use_enable vorbis) \
$(use_enable wma-fixed) \
$(use_with X x) \
@@ -397,19 +405,28 @@ src_configure() {
$(use_enable xml libxml2) \
$(use_enable xv xvideo) \
$(use_enable zvbi) $(use_enable !zvbi telx) \
+ --disable-coverage \
+ --disable-cprof \
--disable-crystalhd \
--disable-decklink \
--disable-goom \
+ --disable-ios-audio \
--disable-kai \
--disable-kva \
+ --disable-maintainer-mode \
+ --disable-merge-ffmpeg \
+ --disable-opensles \
--disable-oss \
--disable-quicksync \
+ --disable-quicktime \
+ --disable-rpi-omxil \
--disable-shine \
--disable-sndio \
--disable-vda \
- --disable-vsxu
+ --disable-vsxu \
+ --disable-wasapi
- # ^ We don't have these disables libraries in the Portage tree yet.
+ # ^ We don't have these disabled libraries in the Portage tree yet.
}
src_test() {