summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-11-16 17:28:14 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-11-16 17:28:14 +0000
commit51388741db05bf31223dbb6fe69560c4a9523e2f (patch)
tree6a16f8c20c3237d6af3ab197c1d66d6cef9de42a /media-video/videocut
parentMarked stable on AMD64 based on arch testing by Agostino "ago" Sarubbo & Elij... (diff)
downloadgentoo-2-51388741db05bf31223dbb6fe69560c4a9523e2f.tar.gz
gentoo-2-51388741db05bf31223dbb6fe69560c4a9523e2f.tar.bz2
gentoo-2-51388741db05bf31223dbb6fe69560c4a9523e2f.zip
non-maintainer commit: add missing dependency on x11-libs/qt-svg:4, fix building on hardened/with gcc-4.6 wrt #380439, drop redundant src_configure(), use qt4-r2.eclass
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'media-video/videocut')
-rw-r--r--media-video/videocut/ChangeLog10
-rw-r--r--media-video/videocut/files/01-fix-hardened-ftbfs.diff16
-rw-r--r--media-video/videocut/videocut-0.2.0.ebuild15
3 files changed, 32 insertions, 9 deletions
diff --git a/media-video/videocut/ChangeLog b/media-video/videocut/ChangeLog
index e83520ca1c13..e5931afeb201 100644
--- a/media-video/videocut/ChangeLog
+++ b/media-video/videocut/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/videocut
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/videocut/ChangeLog,v 1.1 2009/11/05 13:34:48 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/videocut/ChangeLog,v 1.2 2011/11/16 17:28:14 xarthisius Exp $
+
+ 16 Nov 2011; Kacper Kowalik <xarthisius@gentoo.org>
+ +files/01-fix-hardened-ftbfs.diff, videocut-0.2.0.ebuild:
+ non-maintainer commit: add missing dependency on x11-libs/qt-svg:4, fix
+ building on hardened/with gcc-4.6 wrt #380439, drop redundant
+ src_configure(), use qt4-r2
*videocut-0.2.0 (05 Nov 2009)
diff --git a/media-video/videocut/files/01-fix-hardened-ftbfs.diff b/media-video/videocut/files/01-fix-hardened-ftbfs.diff
new file mode 100644
index 000000000000..47fe7f97842c
--- /dev/null
+++ b/media-video/videocut/files/01-fix-hardened-ftbfs.diff
@@ -0,0 +1,16 @@
+# Fix FTBFS with enabled hardened flags and gcc-4.6 failure
+# https://bugs.gentoo.org/show_bug.cgi?id=380439
+
+--- a/src/TPreviewPanel/TPreviewPanel.cpp
++++ b/src/TPreviewPanel/TPreviewPanel.cpp
+@@ -167,7 +167,9 @@
+
+ void TPreviewPanel::adjustItems()
+ {
+- backgroundRect->setSize(&QRectF(0, 0, 1, 1));
++ QRectF myRect(0, 0, 1, 1);
++ backgroundRect->setSize(&myRect);
++
+ logo->setSize(QRect(0, 0, 1, 1));
+
+ // adjust meta text
diff --git a/media-video/videocut/videocut-0.2.0.ebuild b/media-video/videocut/videocut-0.2.0.ebuild
index e4705f41b8e8..56b12a149f74 100644
--- a/media-video/videocut/videocut-0.2.0.ebuild
+++ b/media-video/videocut/videocut-0.2.0.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/videocut/videocut-0.2.0.ebuild,v 1.1 2009/11/05 13:34:48 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/videocut/videocut-0.2.0.ebuild,v 1.2 2011/11/16 17:28:14 xarthisius Exp $
EAPI=2
-inherit eutils qt4
+
+inherit eutils qt4-r2
DESCRIPTION="A program to create compositions from video files"
HOMEPAGE="http://code.google.com/p/videocut/"
-SRC_URI="http://videocut.googlecode.com/files/${PN}_${PV}.tar.gz"
+SRC_URI="http://${PN}.googlecode.com/files/${PN}_${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -15,13 +16,13 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="x11-libs/qt-gui:4
+ x11-libs/qt-svg:4
media-libs/xine-lib"
+RDEPEND="${DEPEND}"
S=${WORKDIR}/${P}.orig
-src_configure() {
- eqmake4
-}
+PATCHES=( "${FILESDIR}"/01-fix-hardened-ftbfs.diff )
src_compile() {
emake || die