summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-12-20 08:57:19 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-12-20 08:57:19 +0000
commit67be53d6321f03f01f2726138272a565877fbce2 (patch)
tree71be01864f747d4985e4d3f138d6baab9e72cc62 /media-video/tovid
parentFix check_pgsql build, #251697 (diff)
downloadgentoo-2-67be53d6321f03f01f2726138272a565877fbce2.tar.gz
gentoo-2-67be53d6321f03f01f2726138272a565877fbce2.tar.bz2
gentoo-2-67be53d6321f03f01f2726138272a565877fbce2.zip
Backported patch from tovid subversion to support new sox wrt #251706, thanks to Salah Coronya.
(Portage version: 2.1.6.1/cvs/Linux 2.6.27.7 i686, RepoMan options: --force)
Diffstat (limited to 'media-video/tovid')
-rw-r--r--media-video/tovid/ChangeLog10
-rw-r--r--media-video/tovid/files/tovid-0.31-sox.patch61
-rw-r--r--media-video/tovid/tovid-0.31-r1.ebuild98
3 files changed, 168 insertions, 1 deletions
diff --git a/media-video/tovid/ChangeLog b/media-video/tovid/ChangeLog
index 511bb747ec01..47c7919c1552 100644
--- a/media-video/tovid/ChangeLog
+++ b/media-video/tovid/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-video/tovid
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/tovid/ChangeLog,v 1.16 2008/12/17 22:32:00 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/tovid/ChangeLog,v 1.17 2008/12/20 08:57:19 ssuominen Exp $
+
+*tovid-0.31-r1 (20 Dec 2008)
+
+ 20 Dec 2008; <ssuominen@gentoo.org> +files/tovid-0.31-sox.patch,
+ +tovid-0.31-r1.ebuild:
+ Backported patch from tovid subversion to support new sox wrt #251706,
+ thanks to Salah Coronya. Because we have this version of sox in stable,
+ and the fix is trivial push it straight to stable for amd64/x86.
17 Dec 2008; Markus Meier <maekke@gentoo.org> tovid-0.31.ebuild:
amd64 stable, bug #250804
diff --git a/media-video/tovid/files/tovid-0.31-sox.patch b/media-video/tovid/files/tovid-0.31-sox.patch
new file mode 100644
index 000000000000..866a9a25ad88
--- /dev/null
+++ b/media-video/tovid/files/tovid-0.31-sox.patch
@@ -0,0 +1,61 @@
+diff -ur tovid-0.31.old/src/todisc tovid-0.31/src/todisc
+--- tovid-0.31.old/src/todisc 2008-12-20 00:39:06.000000000 -0600
++++ tovid-0.31/src/todisc 2008-12-20 00:51:58.000000000 -0600
+@@ -1189,6 +1189,14 @@
+ # $VMGM_ONLY && $SKIP_VMGM && mv "$BASEDIR/dummy.mpg" "$BASEDIR/VMGM.mpg"
+ }
+
++get_sox_arg()
++{
++ sox_version=$(sox --version)
++ sox_version=${sox_version##*v}
++ test_version $sox_version 13.0.0 && echo '-2' || echo '-w'
++}
++
++
+ ##############################################################################
+ # End of functions #
+ ##############################################################################
+@@ -5240,9 +5248,10 @@
+ fi
+ BG_AUDIO_LENGTH="-t $MENU_ATIME"
+ # create audio background for the main menu
++sample_size=$(get_sox_arg)
+ if [[ -z "$BG_AUDIO" || "$BG_AUDIO" = "none" ]]; then # no audio: use silence
+- cat /dev/zero 2>/dev/null | nice -n 0 sox -t raw -c 2 -r 48000 -w \
+- -s - $WORK_DIR/intro.wav trim 0 $MENU_ATIME
++ cat /dev/zero 2>/dev/null | nice -n 0 sox -t raw -c 2 -r 48000 \
++ $sample_size -s - $WORK_DIR/intro.wav trim 0 $MENU_ATIME
+ # Make sure file exists
+ elif test ! -s "$BG_AUDIO"; then
+ runtime_error "Cannot find background audio file: $BG_AUDIO"
+diff -ur tovid-0.31.old/src/tovid-init.in tovid-0.31/src/tovid-init.in
+--- tovid-0.31.old/src/tovid-init.in 2007-08-18 15:21:37.000000000 -0500
++++ tovid-0.31/src/tovid-init.in 2008-12-20 00:51:24.000000000 -0600
+@@ -376,6 +376,26 @@
+ }
+
+ # ******************************************************************************
++# takes 2 args: (1) version (2) the version testing against
++# return true if version is >= to the test version (same or newer)
++# ******************************************************************************
++test_version()
++{
++ OIFS=$IFS
++ IFS='.'
++ local version test_version
++ version=${1//,/.} # allow comma separated version string too
++ version=($version)
++ test_version=($2)
++ IFS=$OIFS
++ for i in ${!test_version[@]}; do
++ [[ -z ${version[i]} ]] && version[i]=0
++ (( ${version[i]} < ${test_version[i]} )) && return 1
++ done
++ return 0
++}
++
++# ******************************************************************************
+ # ******************************************************************************
+ #
+ #
diff --git a/media-video/tovid/tovid-0.31-r1.ebuild b/media-video/tovid/tovid-0.31-r1.ebuild
new file mode 100644
index 000000000000..10c0c365d69e
--- /dev/null
+++ b/media-video/tovid/tovid-0.31-r1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/tovid/tovid-0.31-r1.ebuild,v 1.1 2008/12/20 08:57:19 ssuominen Exp $
+
+inherit eutils python
+
+DESCRIPTION="Video conversion and DVD authoring tools"
+HOMEPAGE="http://tovid.wikia.com/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+IUSE="tk wxwindows"
+DEPEND="media-video/mplayer
+ app-text/txt2tags"
+RDEPEND="media-video/mjpegtools
+ media-video/ffmpeg
+ media-video/transcode
+ media-sound/normalize
+ media-gfx/imagemagick
+ media-sound/sox
+ media-video/dvdauthor
+ media-video/vcdimager
+ media-video/lsdvd
+ virtual/cdrtools
+ dev-python/pycairo
+ wxwindows? ( =dev-python/wxpython-2.6* )
+ app-cdr/dvd+rw-tools
+ app-cdr/cdrdao
+ dev-python/imaging
+ sys-devel/bc"
+KEYWORDS="amd64 x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+pkg_setup() {
+ if use tk && ( ! built_with_use dev-lang/python tk ); then
+ eerror "Please emerge python with useflag 'tk' enabled."
+ die "Fix USE flags and re-emerge"
+ elif ! use tk; then
+ ewarn "If you want to use 'todiscgui', then emerge"
+ ewarn "dev-lang/python and this package with the 'tk' use flag"
+ fi
+ if ! built_with_use media-video/mplayer encode; then
+ eerror "Please emerge media-video/mplayer with useflag 'encode'."
+ die "Fix USE flags and re-emerge"
+ fi
+ if ! use wxwindows; then
+ ewarn "You have choosen to disable all tovidgui interface."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.30-configure.patch \
+ "${FILESDIR}"/${P}-todisc.patch \
+ "${FILESDIR}"/${P}-sox.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install died"
+ dodoc AUTHORS ChangeLog NEWS README
+
+ python_version
+ # remove wxgtk components
+ if ! use wxwindows; then
+ rm -f "${D}/usr/bin/tovidgui"
+ rm -rf "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/libtovid/gui"
+ fi
+
+ # remove tk components
+ if ! use tk; then
+ rm -f "${D}/usr/bin/todiscgui"
+ rm -rf "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/libtovid/metagui"
+ fi
+}
+
+pkg_postinst() {
+ elog ""
+ elog "List of suite components:"
+ elog " idvid: Identifies video format, resolution, and length"
+ elog " makemenu: Creates (S)VCD/DVD menus"
+ elog " makeslides: Creates mpeg still slides for (S)VCD"
+ elog " makexml: Creates XML specification for an (S)VCD or DVD navigation hierarchy"
+ elog " makedvd: Creates the DVD structure and/or iso image"
+ elog " postproc: Adjusts A/V sync and does shrinking of encoded video"
+ elog " tovid: Converts video to (S)VCD or DVD mpeg format"
+ if use wxwindows; then
+ elog " tovidgui: The tovid GUI"
+ fi
+ elog " pytovid: The new (experimental) python based tovid script"
+ elog " todisc: Create a DVD with animated menus"
+ if use tk; then
+ elog " todiscgui: Experimental gui for todisc"
+ fi
+ elog ""
+ elog "Please check out the tovid documentation on the web:"
+ elog " http://tovid.wikia.com/"
+ elog ""
+}