summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-05-12 08:43:22 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-05-12 08:43:22 +0000
commit6639e3644ebf206c45898aa1046cc4a15ad3ba32 (patch)
tree03f03f933842af576f5d88c3e56c65330a1a3a9a /media-video/tovid
parentAdd imlib and pam useflags, see bug #220425. (diff)
downloadgentoo-2-6639e3644ebf206c45898aa1046cc4a15ad3ba32.tar.gz
gentoo-2-6639e3644ebf206c45898aa1046cc4a15ad3ba32.tar.bz2
gentoo-2-6639e3644ebf206c45898aa1046cc4a15ad3ba32.zip
version bump, thanks to everyone involved in bug #190442
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'media-video/tovid')
-rw-r--r--media-video/tovid/ChangeLog10
-rw-r--r--media-video/tovid/files/tovid-0.31-todisc.patch12
-rw-r--r--media-video/tovid/tovid-0.31.ebuild98
3 files changed, 118 insertions, 2 deletions
diff --git a/media-video/tovid/ChangeLog b/media-video/tovid/ChangeLog
index 92b2e40b8e95..d691d820bca9 100644
--- a/media-video/tovid/ChangeLog
+++ b/media-video/tovid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/tovid
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/tovid/ChangeLog,v 1.13 2007/10/02 03:41:41 dirtyepic Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/tovid/ChangeLog,v 1.14 2008/05/12 08:43:21 aballier Exp $
+
+*tovid-0.31 (12 May 2008)
+
+ 12 May 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/tovid-0.31-todisc.patch, +tovid-0.31.ebuild:
+ version bump, thanks to everyone involved in bug #190442
02 Oct 2007; Ryan Hill <dirtyepic@gentoo.org> tovid-0.30-r2.ebuild:
Lock wxpython to 2.6.
diff --git a/media-video/tovid/files/tovid-0.31-todisc.patch b/media-video/tovid/files/tovid-0.31-todisc.patch
new file mode 100644
index 000000000000..c248c72df372
--- /dev/null
+++ b/media-video/tovid/files/tovid-0.31-todisc.patch
@@ -0,0 +1,12 @@
+--- src/todisc 2007-08-19 21:27:36.000000000 -0400
++++ src/todisc.new 2007-10-19 22:43:33.000000000 -0400
+@@ -3736,8 +3736,7 @@
+ # if static menu and no background audio, ignore MENU_AUDIOLENGTH
+ $STATIC && [[ -z "$BG_AUDIO" ]] && ! $SWITCHED && unset MENU_AUDIOLENGTH
+ # Check input files for compliance; offer to tovid-encode non-compliant files
+-$SWITCHED && MN=2 || MN=1
+-if [[ $MENU_NUM -eq $MN ]]; then
++if [[ $MENU_NUM = [1-2] ]]; then
+ check_compliance
+ $GROUPING && check_compliance group
+ fi
diff --git a/media-video/tovid/tovid-0.31.ebuild b/media-video/tovid/tovid-0.31.ebuild
new file mode 100644
index 000000000000..d20a9a06f9f8
--- /dev/null
+++ b/media-video/tovid/tovid-0.31.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/tovid/tovid-0.31.ebuild,v 1.1 2008/05/12 08:43:21 aballier Exp $
+
+inherit eutils python
+
+DESCRIPTION="Video conversion and DVD authoring tools"
+HOMEPAGE="http://tovid.wikia.com/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+IUSE="tk wxwindows"
+DEPEND="media-video/mplayer
+ app-text/txt2tags"
+RDEPEND="media-video/mjpegtools
+ media-video/ffmpeg
+ media-video/transcode
+ media-sound/normalize
+ media-gfx/imagemagick
+ media-sound/sox
+ media-video/dvdauthor
+ media-video/vcdimager
+ media-video/lsdvd
+ virtual/cdrtools
+ dev-python/pycairo
+ wxwindows? ( =dev-python/wxpython-2.6* )
+ app-cdr/dvd+rw-tools
+ app-cdr/cdrdao
+ dev-python/imaging
+ sys-devel/bc"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+pkg_setup() {
+ if use tk && ( ! built_with_use dev-lang/python tk ); then
+ eerror "Please emerge python with useflag 'tk' enabled."
+ die "Fix USE flags and re-emerge"
+ elif ! use tk; then
+ ewarn "If you want to use 'todiscgui', then emerge"
+ ewarn "dev-lang/python and this package with the 'tk' use flag"
+ fi
+ if ! built_with_use media-video/mplayer encode; then
+ eerror "Please emerge media-video/mplayer with useflag 'encode'."
+ die "Fix USE flags and re-emerge"
+ fi
+ if ! use wxwindows; then
+ ewarn "You have choosen to disable all tovidgui interface."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.30-configure.patch"
+ epatch "${FILESDIR}/${PN}-0.31-todisc.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install died"
+ dodoc AUTHORS ChangeLog NEWS README
+
+
+ python_version
+ # remove wxgtk components
+ if ! use wxwindows; then
+ rm -f "${D}/usr/bin/tovidgui"
+ rm -rf "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/libtovid/gui"
+ fi
+
+ # remove tk components
+ if ! use tk; then
+ rm -f "${D}/usr/bin/todiscgui"
+ rm -rf "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/libtovid/metagui"
+ fi
+}
+
+pkg_postinst() {
+ elog ""
+ elog "List of suite components:"
+ elog " idvid: Identifies video format, resolution, and length"
+ elog " makemenu: Creates (S)VCD/DVD menus"
+ elog " makeslides: Creates mpeg still slides for (S)VCD"
+ elog " makexml: Creates XML specification for an (S)VCD or DVD navigation hierarchy"
+ elog " makedvd: Creates the DVD structure and/or iso image"
+ elog " postproc: Adjusts A/V sync and does shrinking of encoded video"
+ elog " tovid: Converts video to (S)VCD or DVD mpeg format"
+ if use wxwindows; then
+ elog " tovidgui: The tovid GUI"
+ fi
+ elog " pytovid: The new (experimental) python based tovid script"
+ elog " todisc: Create a DVD with animated menus"
+ if use tk; then
+ elog " todiscgui: Experimental gui for todisc"
+ fi
+ elog ""
+ elog "Please check out the tovid documentation on the web:"
+ elog " http://tovid.wikia.com/"
+ elog ""
+}