summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-04-19 22:34:26 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-04-19 22:34:26 +0000
commit78ee5e6170437202fcf17d69a4b9df2c4317cfd7 (patch)
treeb90709d76073f6c38a9e60b9a7ec5603f40adf80 /media-video/mplayer/mplayer-1.0_pre3-r5.ebuild
parentold (diff)
downloadgentoo-2-78ee5e6170437202fcf17d69a4b9df2c4317cfd7.tar.gz
gentoo-2-78ee5e6170437202fcf17d69a4b9df2c4317cfd7.tar.bz2
gentoo-2-78ee5e6170437202fcf17d69a4b9df2c4317cfd7.zip
Removed broken gtk2 patch from all versions still in portage and closing bug #15786.
Diffstat (limited to 'media-video/mplayer/mplayer-1.0_pre3-r5.ebuild')
-rw-r--r--media-video/mplayer/mplayer-1.0_pre3-r5.ebuild15
1 files changed, 3 insertions, 12 deletions
diff --git a/media-video/mplayer/mplayer-1.0_pre3-r5.ebuild b/media-video/mplayer/mplayer-1.0_pre3-r5.ebuild
index bb950a606f71..15d7b79e667b 100644
--- a/media-video/mplayer/mplayer-1.0_pre3-r5.ebuild
+++ b/media-video/mplayer/mplayer-1.0_pre3-r5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0_pre3-r5.ebuild,v 1.6 2004/04/14 04:37:15 swtaylor Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mplayer/mplayer-1.0_pre3-r5.ebuild,v 1.7 2004/04/19 22:34:26 wolf31o2 Exp $
-IUSE="dga oss xmms jpeg 3dfx sse matrox sdl X svga ggi oggvorbis 3dnow aalib gnome xv opengl truetype dvd gtk gif esd fbcon encode alsa directfb arts dvb gtk2 samba lirc matroska debug joystick theora ipv6 v4l v4l2"
+IUSE="dga oss xmms jpeg 3dfx sse matrox sdl X svga ggi oggvorbis 3dnow aalib gnome xv opengl truetype dvd gtk gif esd fbcon encode alsa directfb arts dvb samba lirc matroska debug joystick theora ipv6 v4l v4l2"
inherit eutils flag-o-matic
@@ -30,11 +30,8 @@ RDEPEND="ppc? ( >=media-libs/xvid-0.9.0 )
>=media-libs/win32codecs-0.60 )
gtk? ( media-libs/libpng
virtual/x11
- !gtk2? ( =x11-libs/gtk+-1.2*
+ =x11-libs/gtk+-1.2*
=dev-libs/glib-1.2* )
- gtk2? ( >=x11-libs/gtk+-2.0.6
- >=dev-libs/glib-2.0.6 )
- )
jpeg? ( media-libs/jpeg )
gif? ( media-libs/giflib
media-libs/libungif )
@@ -99,9 +96,6 @@ src_unpack() {
# security problem, bug #46246
cd ${S}/libmpdemux; epatch ${FILESDIR}/vuln02-fix.diff
- # Use gtk-2.x
- cd ${S}; epatch ${FILESDIR}/${PN}-1.0-gtk2.patch
-
# Fix head/tail call for new coreutils
cd ${S}; epatch ${FILESDIR}/${PN}-0.90-coreutils-fixup.patch
@@ -173,9 +167,6 @@ src_compile() {
&& myconf="${myconf} --enable-gui --enable-x11 \
--enable-xv --enable-vm --enable-png"
- ( use gtk && use gtk2 ) \
- && myconf="${myconf} --enable-gtk2"
-
use encode \
&& myconf="${myconf} --enable-mencoder --enable-tv" \
|| myconf="${myconf} --disable-mencoder"