summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2006-10-21 20:44:37 +0000
committerAlexis Ballier <aballier@gentoo.org>2006-10-21 20:44:37 +0000
commitecb1e129d39a3712e78dd8ce895fc79ca3fb7aeb (patch)
treef1d2859666c86c4c26218fb1ce4f959dbf0a076e /media-video/motion
parentVersion bump. Resolves bug #120982. This ebuild uses generation 2 and add sup... (diff)
downloadgentoo-2-ecb1e129d39a3712e78dd8ce895fc79ca3fb7aeb.tar.gz
gentoo-2-ecb1e129d39a3712e78dd8ce895fc79ca3fb7aeb.tar.bz2
gentoo-2-ecb1e129d39a3712e78dd8ce895fc79ca3fb7aeb.zip
Adding a patch to compile with ffmpeg 0.4.9, bug #149400
(Portage version: 2.1.2_pre3-r6)
Diffstat (limited to 'media-video/motion')
-rw-r--r--media-video/motion/ChangeLog6
-rw-r--r--media-video/motion/files/motion-3.2.4-ffmpeg-compat.patch11
-rw-r--r--media-video/motion/motion-3.2.4.ebuild3
3 files changed, 18 insertions, 2 deletions
diff --git a/media-video/motion/ChangeLog b/media-video/motion/ChangeLog
index 0816909d59d0..9278d8c51fff 100644
--- a/media-video/motion/ChangeLog
+++ b/media-video/motion/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/motion
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/motion/ChangeLog,v 1.7 2006/09/04 12:44:24 malc Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/motion/ChangeLog,v 1.8 2006/10/21 20:44:37 aballier Exp $
+
+ 21 Oct 2006; Alexis Ballier <aballier@gentoo.org>
+ +files/motion-3.2.4-ffmpeg-compat.patch, motion-3.2.4.ebuild:
+ Adding a patch to compile with ffmpeg 0.4.9, bug #149400
04 Sep 2006; <malc@gentoo.org> motion-3.2.4.ebuild:
Stable on amd64 - thanks to angelos(AT) for bug #146258
diff --git a/media-video/motion/files/motion-3.2.4-ffmpeg-compat.patch b/media-video/motion/files/motion-3.2.4-ffmpeg-compat.patch
new file mode 100644
index 000000000000..e3bf11f304f3
--- /dev/null
+++ b/media-video/motion/files/motion-3.2.4-ffmpeg-compat.patch
@@ -0,0 +1,11 @@
+--- motion-3.2.4/Makefile.in.old 2006-10-21 22:27:48.000000000 +0200
++++ motion-3.2.4/Makefile.in 2006-10-21 22:28:56.000000000 +0200
+@@ -31,7 +31,7 @@
+ # install. #
+ ################################################################################
+ CFLAGS = @CFLAGS@ -Wall -DVERSION=\"$(VERSION)\" -D_REENTRANT \
+- -Dsysconfdir=\"$(sysconfdir)\"
++ -DFFMPEG_AVWRITEFRAME_NEWAPI -Dsysconfdir=\"$(sysconfdir)\"
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+ VIDEO_OBJ = @VIDEO@
diff --git a/media-video/motion/motion-3.2.4.ebuild b/media-video/motion/motion-3.2.4.ebuild
index c7defc7291b9..76bc843c19e4 100644
--- a/media-video/motion/motion-3.2.4.ebuild
+++ b/media-video/motion/motion-3.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/motion/motion-3.2.4.ebuild,v 1.2 2006/09/04 12:44:24 malc Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/motion/motion-3.2.4.ebuild,v 1.3 2006/10/21 20:44:37 aballier Exp $
inherit eutils
@@ -19,6 +19,7 @@ DEPEND="virtual/libc
postgres? ( dev-db/postgresql )"
src_compile() {
+ epatch "${FILESDIR}/${P}-ffmpeg-compat.patch"
econf \
$(use_with v4l) \
$(use_with mysql) \