summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-10-09 09:40:37 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-10-09 09:40:37 +0000
commit64113a895776e5cf018b4114c9e99032c9602e5c (patch)
tree612076c37dd476a07a1fe549d084fc17eac13116 /media-video/motion
parentRespect LDFLAGS wrt #285541, thanks to Davide Pesavento for reporting. (diff)
downloadgentoo-2-64113a895776e5cf018b4114c9e99032c9602e5c.tar.gz
gentoo-2-64113a895776e5cf018b4114c9e99032c9602e5c.tar.bz2
gentoo-2-64113a895776e5cf018b4114c9e99032c9602e5c.zip
Version bump wrt #287506, thanks to Markus for reporting.
(Portage version: 2.2_rc44/cvs/Linux x86_64)
Diffstat (limited to 'media-video/motion')
-rw-r--r--media-video/motion/ChangeLog10
-rw-r--r--media-video/motion/motion-3.2.11.1.ebuild63
2 files changed, 71 insertions, 2 deletions
diff --git a/media-video/motion/ChangeLog b/media-video/motion/ChangeLog
index eaa4a6ca1ddb..286ef6f21d98 100644
--- a/media-video/motion/ChangeLog
+++ b/media-video/motion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/motion
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/motion/ChangeLog,v 1.25 2008/12/19 17:07:40 pva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/motion/ChangeLog,v 1.26 2009/10/09 09:40:37 ssuominen Exp $
+
+*motion-3.2.11.1 (09 Oct 2009)
+
+ 09 Oct 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +motion-3.2.11.1.ebuild:
+ Version bump wrt #287506, thanks to Markus for reporting.
19 Dec 2008; Peter Volkov <pva@gentoo.org> motion-3.2.11.ebuild:
Removed || die after enewuser, bug #237299.
diff --git a/media-video/motion/motion-3.2.11.1.ebuild b/media-video/motion/motion-3.2.11.1.ebuild
new file mode 100644
index 000000000000..907dab26ec1d
--- /dev/null
+++ b/media-video/motion/motion-3.2.11.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/motion/motion-3.2.11.1.ebuild,v 1.1 2009/10/09 09:40:37 ssuominen Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Motion is a video motion detector with tracking-support for webcams."
+HOMEPAGE="http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="ffmpeg mysql postgres v4l"
+
+RDEPEND="sys-libs/zlib
+ media-libs/jpeg
+ ffmpeg? ( media-video/ffmpeg )
+ mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-server )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ enewuser motion -1 -1 -1 video
+}
+
+src_configure() {
+ econf \
+ $(use_with v4l) \
+ $(use_with ffmpeg) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ --without-optimizecpu
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ newinitd "${FILESDIR}"/motion.init-r1 motion
+ newconfd "${FILESDIR}"/motion.confd motion
+
+ # Create correct dir for motion.pid
+ dodir /var/run/motion
+ fowners motion:video /var/run/motion
+ fperms 750 /var/run/motion
+ keepdir /var/run/motion
+
+ # Rename configuration file.
+ mv "${D}"/etc/motion-dist.conf "${D}"/etc/motion.conf
+
+ # Remove dummy documentation and install it using ebuild functions.
+ rm -rf "${D}"/usr/share/doc/${P}
+ dodoc CHANGELOG CODE_STANDARD CREDITS FAQ README README.FreeBSD *.conf
+ dohtml *.html
+}
+
+pkg_postinst() {
+ elog "You need to setup /etc/motion.conf before running"
+ elog "motion for the first time. You can install motion"
+ elog "detection as a service, use:"
+ elog "rc-update add motion default"
+}