summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2006-10-21 21:11:45 +0000
committerAlexis Ballier <aballier@gentoo.org>2006-10-21 21:11:45 +0000
commit50f2bae9dbaa9508025781e3545baa87d0a8395a (patch)
treecf28532ea14db8570abd01ea5c6bc7f2dbe7d7b2 /media-video/motion
parentppc stable (diff)
downloadgentoo-2-50f2bae9dbaa9508025781e3545baa87d0a8395a.tar.gz
gentoo-2-50f2bae9dbaa9508025781e3545baa87d0a8395a.tar.bz2
gentoo-2-50f2bae9dbaa9508025781e3545baa87d0a8395a.zip
Version bump, thanks to Nathan Sullivan & Gunnar Skjold, bug #144000
(Portage version: 2.1.2_pre3-r6)
Diffstat (limited to 'media-video/motion')
-rw-r--r--media-video/motion/ChangeLog7
-rw-r--r--media-video/motion/files/digest-motion-3.2.73
-rw-r--r--media-video/motion/motion-3.2.7.ebuild59
3 files changed, 68 insertions, 1 deletions
diff --git a/media-video/motion/ChangeLog b/media-video/motion/ChangeLog
index 9278d8c51fff..0349753d4585 100644
--- a/media-video/motion/ChangeLog
+++ b/media-video/motion/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/motion
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/motion/ChangeLog,v 1.8 2006/10/21 20:44:37 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/motion/ChangeLog,v 1.9 2006/10/21 21:11:45 aballier Exp $
+
+*motion-3.2.7 (21 Oct 2006)
+
+ 21 Oct 2006; Alexis Ballier <aballier@gentoo.org> +motion-3.2.7.ebuild:
+ Version bump, thanks to Nathan Sullivan & Gunnar Skjold, bug #144000
21 Oct 2006; Alexis Ballier <aballier@gentoo.org>
+files/motion-3.2.4-ffmpeg-compat.patch, motion-3.2.4.ebuild:
diff --git a/media-video/motion/files/digest-motion-3.2.7 b/media-video/motion/files/digest-motion-3.2.7
new file mode 100644
index 000000000000..633605424875
--- /dev/null
+++ b/media-video/motion/files/digest-motion-3.2.7
@@ -0,0 +1,3 @@
+MD5 b4af6e10532fcdec89060bc61a27fc3a motion-3.2.7.tar.gz 370830
+RMD160 aaab6b7b993bbf7cc0911b1ea127060a97b81aae motion-3.2.7.tar.gz 370830
+SHA256 9ae4e8145b367d9ff0ffd607da597aee3439d23939f3ee28268bc831f71252f2 motion-3.2.7.tar.gz 370830
diff --git a/media-video/motion/motion-3.2.7.ebuild b/media-video/motion/motion-3.2.7.ebuild
new file mode 100644
index 000000000000..2914fbabd720
--- /dev/null
+++ b/media-video/motion/motion-3.2.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/motion/motion-3.2.7.ebuild,v 1.1 2006/10/21 21:11:45 aballier Exp $
+
+inherit eutils
+
+DESCRIPTION="Motion is a video motion detector with tracking-support for webcams."
+HOMEPAGE="http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="ffmpeg mmx mysql postgres v4l"
+
+DEPEND="virtual/libc
+ sys-libs/zlib
+ media-libs/jpeg
+ ffmpeg? ( media-video/ffmpeg )
+ mmx? ( media-libs/jpeg-mmx )
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )"
+
+src_compile() {
+ econf \
+ $(use_with v4l) \
+ $(use_with mmx jpeg-mmx) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_with ffmpeg) \
+ || die "econfigure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+
+ # install init-script
+ dodir /etc/init.d
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/motion.init motion
+
+ # copy configuration file
+ cp ${D}/etc/motion-dist.conf ${D}/etc/motion.conf
+
+ # cleanup unused files
+ cd ${D}/usr/share/doc/${P}/examples/
+ rm motion.init-Debian motion.init-RH motion.init-FreeBSD.sh
+}
+
+pkg_postinst() {
+ ewarn "You need to setup /etc/motion.conf before running"
+ ewarn "motion for the first time."
+ einfo "Examples are available at /usr/share/doc/${P}/examples"
+ einfo
+ einfo "You can install motion detection as a service, use:"
+ einfo "rc-update add motion default"
+}