summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-11-05 10:26:55 +0000
committerMike Frysinger <vapier@gentoo.org>2006-11-05 10:26:55 +0000
commit44c12620904d35b1b7f808a20130aab784193e73 (patch)
tree35ab78364a88015f16e6f982ae20384afcc2252e /media-video/motion
parentremove jpeg-mmx reference and make ebuild suck less (diff)
downloadgentoo-2-44c12620904d35b1b7f808a20130aab784193e73.tar.gz
gentoo-2-44c12620904d35b1b7f808a20130aab784193e73.tar.bz2
gentoo-2-44c12620904d35b1b7f808a20130aab784193e73.zip
remove jpeg-mmx reference and make ebuild suck less
(Portage version: 2.1.2_rc1-r2)
Diffstat (limited to 'media-video/motion')
-rw-r--r--media-video/motion/motion-3.2.7.ebuild31
1 files changed, 13 insertions, 18 deletions
diff --git a/media-video/motion/motion-3.2.7.ebuild b/media-video/motion/motion-3.2.7.ebuild
index 2914fbabd720..738903d85344 100644
--- a/media-video/motion/motion-3.2.7.ebuild
+++ b/media-video/motion/motion-3.2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/motion/motion-3.2.7.ebuild,v 1.1 2006/10/21 21:11:45 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/motion/motion-3.2.7.ebuild,v 1.2 2006/11/05 10:26:55 vapier Exp $
inherit eutils
@@ -11,24 +11,21 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~x86"
-IUSE="ffmpeg mmx mysql postgres v4l"
+IUSE="ffmpeg mysql postgres v4l"
-DEPEND="virtual/libc
- sys-libs/zlib
- media-libs/jpeg
- ffmpeg? ( media-video/ffmpeg )
- mmx? ( media-libs/jpeg-mmx )
- mysql? ( dev-db/mysql )
- postgres? ( dev-db/postgresql )"
+DEPEND="sys-libs/zlib
+ media-libs/jpeg
+ ffmpeg? ( media-video/ffmpeg )
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )"
src_compile() {
econf \
- $(use_with v4l) \
- $(use_with mmx jpeg-mmx) \
- $(use_with mysql) \
- $(use_with postgres pgsql) \
- $(use_with ffmpeg) \
- || die "econfigure failed"
+ $(use_with v4l) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_with ffmpeg) \
+ || die "econfigure failed"
emake || die "emake failed"
}
@@ -37,9 +34,7 @@ src_install() {
make DESTDIR="${D}" install || die "install failed"
# install init-script
- dodir /etc/init.d
- exeinto /etc/init.d
- newexe ${FILESDIR}/motion.init motion
+ newinitd ${FILESDIR}/motion.init motion || die
# copy configuration file
cp ${D}/etc/motion-dist.conf ${D}/etc/motion.conf