summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-05-30 18:44:04 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-05-30 18:44:04 +0000
commit2f013f79d8576602eec5bd6f68148ea093f4c7a1 (patch)
tree20e269a87f49af9c3b8116186d44e68b526e4918 /media-video/motion/motion-3.2.4.ebuild
parentnew version, has fix for as-needed included, fixes #131841 (diff)
downloadgentoo-2-2f013f79d8576602eec5bd6f68148ea093f4c7a1.tar.gz
gentoo-2-2f013f79d8576602eec5bd6f68148ea093f4c7a1.tar.bz2
gentoo-2-2f013f79d8576602eec5bd6f68148ea093f4c7a1.zip
New version, ebuild kindly provided by Marko Djukic <djukic@gmail.com> and Andreas Hinterland <ich@meister-rohrfix.de> in bug #107650
(Portage version: 2.1_rc2-r3)
Diffstat (limited to 'media-video/motion/motion-3.2.4.ebuild')
-rw-r--r--media-video/motion/motion-3.2.4.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-video/motion/motion-3.2.4.ebuild b/media-video/motion/motion-3.2.4.ebuild
new file mode 100644
index 000000000000..5c4e409bf399
--- /dev/null
+++ b/media-video/motion/motion-3.2.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/motion/motion-3.2.4.ebuild,v 1.1 2006/05/30 18:44:04 lu_zero Exp $
+
+inherit eutils
+
+DESCRIPTION="Motion is a video motion detector with tracking-support for webcams."
+HOMEPAGE="http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="ffmpeg mysql postgres v4l"
+DEPEND="virtual/libc
+ sys-libs/zlib
+ media-libs/jpeg
+ ffmpeg? ( media-video/ffmpeg )
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )"
+
+src_compile() {
+ econf \
+ $(use_with v4l) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_with ffmpeg) \
+ || die "econfigure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+
+ # install init-script
+ dodir /etc/init.d
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/motion.init motion
+
+ # copy configuration file
+ cp ${D}/etc/motion-dist.conf ${D}/etc/motion.conf
+
+ # cleanup unused files
+ cd ${D}/usr/share/doc/${P}/examples/
+ rm motion.init-Debian motion.init-RH motion.init-FreeBSD.sh
+}
+
+pkg_postinst() {
+ ewarn "You need to setup /etc/motion.conf before running"
+ ewarn "motion for the first time."
+ einfo "Examples are available at /usr/share/doc/${P}/examples"
+ einfo
+ einfo "You can install motion detection as a service, use:"
+ einfo "rc-update add motion default"
+}