summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-01-03 00:22:41 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-01-03 00:22:41 +0000
commit04ba4ff61ae064b3f8616efea8d58fc175dd2882 (patch)
treef6bb92552259088ac8fa9d5f8a15234a64aa1a48 /media-video/lives/lives-0.9.5.ebuild
parentNew release: 0.25. Pruning old ebuild. (diff)
downloadgentoo-2-04ba4ff61ae064b3f8616efea8d58fc175dd2882.tar.gz
gentoo-2-04ba4ff61ae064b3f8616efea8d58fc175dd2882.tar.bz2
gentoo-2-04ba4ff61ae064b3f8616efea8d58fc175dd2882.zip
New version
(Portage version: 2.1_pre2)
Diffstat (limited to 'media-video/lives/lives-0.9.5.ebuild')
-rw-r--r--media-video/lives/lives-0.9.5.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/media-video/lives/lives-0.9.5.ebuild b/media-video/lives/lives-0.9.5.ebuild
new file mode 100644
index 000000000000..a41f8dfcbd2b
--- /dev/null
+++ b/media-video/lives/lives-0.9.5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/lives/lives-0.9.5.ebuild,v 1.1 2006/01/03 00:22:41 lu_zero Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Linux Video Editing System"
+
+HOMEPAGE="http://www.xs4all.nl/~salsaman/lives"
+
+MY_PN=LiVES
+MY_PV="${PV/_/-}"
+MY_P="${MY_PN}-${MY_PV}"
+
+SRC_URI="http://www.xs4all.nl/%7Esalsaman/lives/current/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86 ~ppc ~amd64"
+
+IUSE="xmms matroska ogg theora libvisual jack sox"
+
+DEPEND=">=media-video/mplayer-0.90-r2
+ >=media-gfx/imagemagick-5.5.6
+ >=dev-lang/perl-5.8.0-r12
+ >=x11-libs/gtk+-2.2.1
+ media-libs/libsdl
+ >=media-video/ffmpeg-0.4.8
+ >=media-libs/jpeg-6b-r3
+ >=media-sound/sox-12.17.3-r3
+ xmms? ( >=media-sound/xmms-1.2.7-r20 )
+ virtual/cdrtools
+ theora? ( media-libs/libtheora )
+ >=dev-lang/python-2.3.4
+ matroska? ( media-video/mkvtoolnix
+ media-libs/libmatroska )
+ ogg? ( media-sound/ogmtools )
+ >=media-video/mjpegtools-1.6.2
+ libvisual? ( >=media-libs/libvisual-0.2.0 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ sox? ( media-sound/sox )"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ # hardcoding -03 is wrong!
+ sed -i -e "s:-O3::g" \
+ ${S}/{,src,lives-plugins,lives-plugins/plugins/playback/video,lives-plugins/weed-plugins}/Makefile*
+ grep -r O3 ${S}
+}
+
+src_compile() {
+ econf \
+ $(use_enable libvisual) \
+ $(use_enable jack) \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dodir /usr/share/lives/icons
+ emake DESTDIR=${D} install || die
+ dodoc AUTHORS CHANGELOG FEATURES GETTING.STARTED
+}