summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2008-06-07 12:54:13 +0000
committerTiziano Müller <dev-zero@gentoo.org>2008-06-07 12:54:13 +0000
commit8ece5c19f65cea2e290851986e4a408c76e4edc9 (patch)
tree939bf9ffb9fc579e668598367b7d94d703e1c4fa /media-video/griffith
parentkeyword ~x86-fbsd (diff)
downloadgentoo-2-8ece5c19f65cea2e290851986e4a408c76e4edc9.tar.gz
gentoo-2-8ece5c19f65cea2e290851986e4a408c76e4edc9.tar.bz2
gentoo-2-8ece5c19f65cea2e290851986e4a408c76e4edc9.zip
Version bump (bug #210993): Currently installs a copy of SQLAlchemy-0.3, this will be fixed in 0.10.
(Portage version: 2.1.5.4)
Diffstat (limited to 'media-video/griffith')
-rw-r--r--media-video/griffith/ChangeLog9
-rw-r--r--media-video/griffith/griffith-0.9.6.ebuild70
-rw-r--r--media-video/griffith/metadata.xml2
3 files changed, 79 insertions, 2 deletions
diff --git a/media-video/griffith/ChangeLog b/media-video/griffith/ChangeLog
index 3b27620dc486..0ec02cdf341e 100644
--- a/media-video/griffith/ChangeLog
+++ b/media-video/griffith/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/griffith
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.22 2008/05/29 17:28:55 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.23 2008/06/07 12:54:13 dev-zero Exp $
+
+*griffith-0.9.6 (07 Jun 2008)
+
+ 07 Jun 2008; Tiziano Müller <dev-zero@gentoo.org> metadata.xml,
+ +griffith-0.9.6.ebuild:
+ Version bump (bug #210993): Currently installs a copy of SQLAlchemy-0.3,
+ this will be fixed in 0.10.
29 May 2008; Ali Polatel <hawking@gentoo.org> griffith-0.9.5.ebuild:
python_mod_{cleanup,optimize} is ROOT aware.
diff --git a/media-video/griffith/griffith-0.9.6.ebuild b/media-video/griffith/griffith-0.9.6.ebuild
new file mode 100644
index 000000000000..21e7bb26425d
--- /dev/null
+++ b/media-video/griffith/griffith-0.9.6.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/griffith-0.9.6.ebuild,v 1.1 2008/06/07 12:54:13 dev-zero Exp $
+
+EAPI="1"
+
+inherit python
+
+ARTWORK_PV="0.9.4"
+
+DESCRIPTION="Movie collection manager"
+HOMEPAGE="http://griffith.berlios.de/"
+SRC_URI="mirror://berlios/griffith/${P/_/-}.tar.gz
+ mirror://berlios/griffith/${PN}-extra-artwork-${ARTWORK_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc spell"
+
+RDEPEND="dev-python/imaging
+ dev-python/pyxml
+ >=dev-python/pygtk-2.6.1
+ dev-python/pysqlite:2
+ >=dev-python/reportlab-1.19
+ spell? ( >=dev-python/gnome-python-extras-2.0 )"
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook2X )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's/docbook2x-man/docbook2man.pl/' \
+ -e 's#/pl/#/pl.UTF-8/#' \
+ docs/*/Makefile || die "sed failed"
+ sed -i \
+ -e 's/latin1/iso-8859-1/' \
+ docs/en/*.xml || die "sed failed"
+
+ sed -i \
+ -e 's/ISO-8859-1/UTF-8/' \
+ lib/gconsole.py || die "sed failed"
+
+ # Don't install bundled sqlalchemy
+ sed -i -e '/sqlalchemy/d' Makefile || die "sed failed"
+}
+
+src_compile() {
+ # Nothing to compile and default `emake` spews an error message
+ true
+}
+
+src_install() {
+ use doc || sed -i -e '/docs/d' Makefile
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO NEWS TRANSLATORS
+
+ cd "${WORKDIR}/${PN}-extra-artwork-${ARTWORK_PV}/"
+ emake DESTDIR="${D}" install || die "emake install artwork failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}/lib
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}/lib
+}
diff --git a/media-video/griffith/metadata.xml b/media-video/griffith/metadata.xml
index ec133c3bfa99..c5fb91aa72e5 100644
--- a/media-video/griffith/metadata.xml
+++ b/media-video/griffith/metadata.xml
@@ -3,6 +3,6 @@
<pkgmetadata>
<herd>video</herd>
<maintainer>
- <email>nelchael@gentoo.org</email>
+ <email>dev-zero@gentoo.org</email>
</maintainer>
</pkgmetadata>