summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2006-12-01 20:33:25 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2006-12-01 20:33:25 +0000
commit59658b6682dcdbcae891a51f267eca51afa81d2d (patch)
treeb890e2db6f98768cab9df1a881e71e3c094b5b6e /media-video/em8300-libraries
parentRemoving old virtual/x11 dependency. (diff)
downloadgentoo-2-59658b6682dcdbcae891a51f267eca51afa81d2d.tar.gz
gentoo-2-59658b6682dcdbcae891a51f267eca51afa81d2d.tar.bz2
gentoo-2-59658b6682dcdbcae891a51f267eca51afa81d2d.zip
Version bumped.
(Portage version: 2.1.2_rc2-r3)
Diffstat (limited to 'media-video/em8300-libraries')
-rw-r--r--media-video/em8300-libraries/ChangeLog8
-rw-r--r--media-video/em8300-libraries/em8300-libraries-0.16.0.ebuild67
-rw-r--r--media-video/em8300-libraries/files/digest-em8300-libraries-0.16.03
3 files changed, 77 insertions, 1 deletions
diff --git a/media-video/em8300-libraries/ChangeLog b/media-video/em8300-libraries/ChangeLog
index 57099c042417..98adadee51a6 100644
--- a/media-video/em8300-libraries/ChangeLog
+++ b/media-video/em8300-libraries/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/em8300-libraries
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-libraries/ChangeLog,v 1.27 2006/11/21 12:22:31 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-libraries/ChangeLog,v 1.28 2006/12/01 20:33:25 zzam Exp $
+
+*em8300-libraries-0.16.0 (01 Dec 2006)
+
+ 01 Dec 2006; Matthias Schwarzott <zzam@gentoo.org>
+ +em8300-libraries-0.16.0.ebuild:
+ Version bumped.
21 Nov 2006; Matthias Schwarzott <zzam@gentoo.org> metadata.xml:
Took over proxying maintainership from Flameeyes.
diff --git a/media-video/em8300-libraries/em8300-libraries-0.16.0.ebuild b/media-video/em8300-libraries/em8300-libraries-0.16.0.ebuild
new file mode 100644
index 000000000000..3e5f27ebc456
--- /dev/null
+++ b/media-video/em8300-libraries/em8300-libraries-0.16.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-libraries/em8300-libraries-0.16.0.ebuild,v 1.1 2006/12/01 20:33:25 zzam Exp $
+
+WANT_AUTOMAKE=1.9
+WANT_AUTOCONF=2.5
+
+inherit flag-o-matic autotools
+
+MY_P="${P/-libraries/}"
+
+DESCRIPTION="em8300 (RealMagic Hollywood+/Creative DXR3) video decoder card libraries"
+HOMEPAGE="http://dxr3.sourceforge.net"
+SRC_URI="mirror://sourceforge.net/dxr3/${MY_P}.tar.gz"
+
+RDEPEND="~media-video/em8300-modules-${PV}
+ gtk? ( >=x11-libs/gtk+-2.0 )"
+
+DEPEND="dev-util/pkgconfig
+ gtk? ( >=x11-libs/gtk+-2.0 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ # Separate kernel modules.
+ sed -i -e 's:modules/\ ::g' Makefile.am
+
+ # Fix Makefile bug.
+ sed -i -e "s:test -z \"\$(firmwaredir)\":test -z\"\$(DESTDIR)(firmwaredir)\":g" Makefile.am
+
+ eautomake
+}
+
+src_compile () {
+ use amd64 && append-flags -fPIC
+
+ econf \
+ $(use_enable gtk gtktest) || die "econf failed."
+
+ emake || die "emake failed."
+}
+
+src_install () {
+ dodir /lib/firmware
+ emake DESTDIR="${D}" em8300incdir=/usr/include/linux install || die "emake
+ install failed."
+
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ elog "The em8300 libraries and modules have now been installed,"
+ elog "you will probably want to add /usr/bin/em8300setup to your"
+ elog "/etc/conf.d/local.start so that your em8300 card is "
+ elog "properly initialized on boot."
+ elog
+ elog "If you still need a microcode other than the one included"
+ elog "with the package, you can simply use em8300setup <microcode.ux>"
+}
diff --git a/media-video/em8300-libraries/files/digest-em8300-libraries-0.16.0 b/media-video/em8300-libraries/files/digest-em8300-libraries-0.16.0
new file mode 100644
index 000000000000..93f9cf9b578a
--- /dev/null
+++ b/media-video/em8300-libraries/files/digest-em8300-libraries-0.16.0
@@ -0,0 +1,3 @@
+MD5 9e9b769b99927079b4fd6ec423d95049 em8300-0.16.0.tar.gz 338100
+RMD160 1732b036740f806c3aeec5d616debdb8478609a4 em8300-0.16.0.tar.gz 338100
+SHA256 9a0eb004b80362c57f94ec49cbcb131bcba23ad63207464cb9196060a893f1a5 em8300-0.16.0.tar.gz 338100