summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2006-09-15 20:34:08 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2006-09-15 20:34:08 +0000
commitb0a0848ea54ec4b4c6994fb4fabb93de8becfffd (patch)
tree379fba3595f819f4cebb2baeb14d834289949004 /media-video/effectv/effectv-0.3.11.ebuild
parentChange hard-coded /opt to GAMES_PREFIX_OPT. (diff)
downloadgentoo-2-b0a0848ea54ec4b4c6994fb4fabb93de8becfffd.tar.gz
gentoo-2-b0a0848ea54ec4b4c6994fb4fabb93de8becfffd.tar.bz2
gentoo-2-b0a0848ea54ec4b4c6994fb4fabb93de8becfffd.zip
Version bumped, thanks to Francisco Javier <ffelix@sshinf.com> for reporting, Bug #146749.
(Portage version: 2.1.1)
Diffstat (limited to 'media-video/effectv/effectv-0.3.11.ebuild')
-rw-r--r--media-video/effectv/effectv-0.3.11.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-video/effectv/effectv-0.3.11.ebuild b/media-video/effectv/effectv-0.3.11.ebuild
new file mode 100644
index 000000000000..913f7bdf7c29
--- /dev/null
+++ b/media-video/effectv/effectv-0.3.11.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/effectv/effectv-0.3.11.ebuild,v 1.1 2006/09/15 20:34:08 zzam Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="EffecTV is a real-time video effect-processor"
+HOMEPAGE="http://effectv.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="mmx"
+DEPEND="x86? ( dev-lang/nasm )
+ media-libs/libsdl"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}/${PN}-0.3.10-makefile.patch"
+ epatch "${FILESDIR}/${PN}-0.3.10-trunc-name-collision.patch"
+ epatch "${FILESDIR}/${P}-timedist.patch"
+}
+
+src_compile() {
+ local mmx
+ local nasm
+
+ use mmx && mmx="yes" || mmx="no"
+ [[ $(tc-arch) == "x86" ]] && nasm="yes" || nasm="no"
+
+ emake CC="$(tc-getCC)" PREFIX="/usr" CFLAGS.opt="${CFLAGS}" \
+ USE_MMX=${mmx} USE_NASM=${nasm} ARCH= || die "emake failed"
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe ${PN}
+ doman *.1
+ dodoc CREWS ChangeLog FAQ NEWS README TODO
+}
+