summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-08-31 04:49:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-08-31 04:49:27 +0000
commit644581608a07633f31c36dbdd1e82d332e6b503f (patch)
treeae37e386b780ad323ae464f08aa8983a480fccb0 /media-video/effectv/effectv-0.3.11.ebuild
parentfix bug #221449 and tidy ebuild (diff)
downloadgentoo-2-644581608a07633f31c36dbdd1e82d332e6b503f.tar.gz
gentoo-2-644581608a07633f31c36dbdd1e82d332e6b503f.tar.bz2
gentoo-2-644581608a07633f31c36dbdd1e82d332e6b503f.zip
fix bug #221447 and the executable stacks QA; tidy ebuild
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-video/effectv/effectv-0.3.11.ebuild')
-rw-r--r--media-video/effectv/effectv-0.3.11.ebuild24
1 files changed, 15 insertions, 9 deletions
diff --git a/media-video/effectv/effectv-0.3.11.ebuild b/media-video/effectv/effectv-0.3.11.ebuild
index 43b6644c245d..62ff86c326ae 100644
--- a/media-video/effectv/effectv-0.3.11.ebuild
+++ b/media-video/effectv/effectv-0.3.11.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/effectv/effectv-0.3.11.ebuild,v 1.3 2007/11/27 12:00:34 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/effectv/effectv-0.3.11.ebuild,v 1.4 2008/08/31 04:49:27 mr_bones_ Exp $
inherit eutils toolchain-funcs
@@ -11,15 +11,22 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
IUSE="mmx"
-DEPEND="x86? ( dev-lang/nasm )
- media-libs/libsdl"
+
+RDEPEND="media-libs/libsdl"
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${PN}-0.3.10-makefile.patch"
- epatch "${FILESDIR}/${PN}-0.3.10-trunc-name-collision.patch"
- epatch "${FILESDIR}/${P}-timedist.patch"
+ epatch \
+ "${FILESDIR}/${PN}-0.3.10-makefile.patch" \
+ "${FILESDIR}/${PN}-0.3.10-trunc-name-collision.patch" \
+ "${FILESDIR}/${P}-timedist.patch"
+ echo "
+%ifidn __OUTPUT_FORMAT__,elf
+section .note.GNU-stack noalloc noexec nowrite progbits
+%endif" >> effects/blurzoomcore.nas
}
src_compile() {
@@ -34,8 +41,7 @@ src_compile() {
}
src_install() {
- exeinto /usr/bin
- doexe ${PN}
+ dobin ${PN} || die "dobin failed"
doman *.1
dodoc CREWS ChangeLog FAQ NEWS README TODO
}