summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-09-04 02:03:41 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-09-04 02:03:41 +0000
commit0f2861aa0dc28eabcfa1603acecdd6b96af0826e (patch)
tree86159b217edd5f725f231c55dde6b38ca21a4ceb /media-video/dvdstyler/dvdstyler-1.4.ebuild
parentRevision bump for the previous change. (diff)
downloadgentoo-2-0f2861aa0dc28eabcfa1603acecdd6b96af0826e.tar.gz
gentoo-2-0f2861aa0dc28eabcfa1603acecdd6b96af0826e.tar.bz2
gentoo-2-0f2861aa0dc28eabcfa1603acecdd6b96af0826e.zip
QA clean - removed obscelete build commands, corrected versioing, removed INSTALL and README from installation. Inspired by flameeyes
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-video/dvdstyler/dvdstyler-1.4.ebuild')
-rw-r--r--media-video/dvdstyler/dvdstyler-1.4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-video/dvdstyler/dvdstyler-1.4.ebuild b/media-video/dvdstyler/dvdstyler-1.4.ebuild
new file mode 100644
index 000000000000..323c1bc77ab0
--- /dev/null
+++ b/media-video/dvdstyler/dvdstyler-1.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/dvdstyler-1.4.ebuild,v 1.1 2005/09/04 02:03:41 dragonheart Exp $
+
+inherit eutils
+
+MY_P=DVDStyler-${PV}
+
+DESCRIPTION="DVD filesystem Builder"
+HOMEPAGE="http://dvdstyler.sourceforge.net"
+SRC_URI="mirror://sourceforge/dvdstyler/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gnome"
+
+RDEPEND="app-cdr/dvd+rw-tools
+ dev-libs/expat
+ dev-libs/glib
+ media-libs/tiff
+ media-libs/libpng
+ media-libs/jpeg
+ media-libs/netpbm
+ >=media-video/dvdauthor-0.6.10
+ media-video/mpgtx
+ >=media-video/mjpegtools-1.6.2
+ sys-libs/zlib
+ x11-libs/gtk+
+ =x11-libs/wxGTK-2.4*
+ virtual/cdrtools
+ virtual/libc
+ virtual/x11
+ gnome? ( >=gnome-base/libgnomeui-2.0 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ make DESTDIR=${D} install || die "failed to install"
+ rm ${D}usr/share/doc/${PN}/COPYING ${D}usr/share/doc/${PN}/INSTALL
+ mv ${D}usr/share/doc/${PN} ${D}usr/share/doc/${PF}
+
+ make_desktop_entry dvdstyler DVDStyler dvdstyler.png Application
+}