summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-01-07 14:23:14 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-01-07 14:23:14 +0000
commitb53e5fd83231d2b5d7f470759c96a6da5e6ca48c (patch)
tree1275893cf05c8252b18cb7d14c0fcc5c6fc6f0d8 /media-video/devede
parentBump for #297448 (diff)
downloadgentoo-2-b53e5fd83231d2b5d7f470759c96a6da5e6ca48c.tar.gz
gentoo-2-b53e5fd83231d2b5d7f470759c96a6da5e6ca48c.tar.bz2
gentoo-2-b53e5fd83231d2b5d7f470759c96a6da5e6ca48c.zip
Bump for #299355
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'media-video/devede')
-rw-r--r--media-video/devede/ChangeLog9
-rw-r--r--media-video/devede/devede-3.15.2.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/media-video/devede/ChangeLog b/media-video/devede/ChangeLog
index 8fe7085b35b3..10450e1f548b 100644
--- a/media-video/devede/ChangeLog
+++ b/media-video/devede/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/devede
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/devede/ChangeLog,v 1.24 2009/09/01 08:11:12 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/devede/ChangeLog,v 1.25 2010/01/07 14:23:14 patrick Exp $
+
+*devede-3.15.2 (07 Jan 2010)
+
+ 07 Jan 2010; Patrick Lauer <patrick@gentoo.org> +devede-3.15.2.ebuild:
+ Bump for #299355
*devede-3.14.0 (01 Sep 2009)
diff --git a/media-video/devede/devede-3.15.2.ebuild b/media-video/devede/devede-3.15.2.ebuild
new file mode 100644
index 000000000000..9e2afa8cd430
--- /dev/null
+++ b/media-video/devede/devede-3.15.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/devede/devede-3.15.2.ebuild,v 1.1 2010/01/07 14:23:14 patrick Exp $
+
+NEED_PYTHON=2.4
+
+inherit multilib python
+
+DESCRIPTION="Program to create video CDs and DVDs, suitable to be played in home DVD players."
+HOMEPAGE="http://www.rastersoft.com/programas/devede.html"
+SRC_URI="http://www.rastersoft.com/descargas/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="psyco"
+
+RDEPEND=">=x11-libs/gtk+-2.16
+ dev-python/pygtk
+ >=media-video/mplayer-1.0_rc1
+ media-video/dvdauthor
+ media-video/vcdimager
+ psyco? ( dev-python/psyco )
+ virtual/cdrtools"
+DEPEND=""
+
+S=${WORKDIR}/${P%*b}
+
+src_install() {
+ ./install.sh prefix="/usr" libdir="/usr/$(get_libdir)" \
+ pkgdocdir="/usr/share/doc/${PF}" DESTDIR="${D}" \
+ || die "install.sh failed."
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+ elog "To create DIVX/MPEG4 files, be sure that MPlayer is compiled with LAME support."
+ elog "In this case you want to check for both the encode and mp3 USE flags."
+ elog "To change the font used to render the subtitles, choose a TrueType font you like"
+ elog "and copy it in \$HOME/.spumux directory, renaming it to devedesans.ttf."
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+}