summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-26 21:34:39 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-26 21:34:39 +0000
commitfc01f088ba9f0c37fa52509e85f8706289fffab5 (patch)
tree39f6ff47f593e058618df22e42a1a543c8f33b60 /media-video/codeine
parentStable on ppc64 (diff)
downloadgentoo-2-fc01f088ba9f0c37fa52509e85f8706289fffab5.tar.gz
gentoo-2-fc01f088ba9f0c37fa52509e85f8706289fffab5.tar.bz2
gentoo-2-fc01f088ba9f0c37fa52509e85f8706289fffab5.zip
Add patch to respect CC settings, and make scons support -jX and -s MAKEOPTS, basically allowing using parallel building _and_ distcc on codeine.
(Portage version: 2.1_rc2-r3)
Diffstat (limited to 'media-video/codeine')
-rw-r--r--media-video/codeine/ChangeLog8
-rw-r--r--media-video/codeine/codeine-1.0.1.3.ebuild23
-rw-r--r--media-video/codeine/files/codeine-1.0.1.3-respect-cc.patch25
3 files changed, 50 insertions, 6 deletions
diff --git a/media-video/codeine/ChangeLog b/media-video/codeine/ChangeLog
index c648d4d746af..c93acd24e1f8 100644
--- a/media-video/codeine/ChangeLog
+++ b/media-video/codeine/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/codeine
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/codeine/ChangeLog,v 1.12 2006/05/12 13:36:07 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/codeine/ChangeLog,v 1.13 2006/05/26 21:34:39 flameeyes Exp $
+
+ 26 May 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/codeine-1.0.1.3-respect-cc.patch, codeine-1.0.1.3.ebuild:
+ Add patch to respect CC settings, and make scons support -jX and -s
+ MAKEOPTS, basically allowing using parallel building _and_ distcc on
+ codeine.
*codeine-1.0.1.3 (12 May 2006)
diff --git a/media-video/codeine/codeine-1.0.1.3.ebuild b/media-video/codeine/codeine-1.0.1.3.ebuild
index 5eed5b2c9a8f..5fe2c3099321 100644
--- a/media-video/codeine/codeine-1.0.1.3.ebuild
+++ b/media-video/codeine/codeine-1.0.1.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/codeine/codeine-1.0.1.3.ebuild,v 1.1 2006/05/12 13:36:07 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/codeine/codeine-1.0.1.3.ebuild,v 1.2 2006/05/26 21:34:39 flameeyes Exp $
-inherit kde multilib versionator
+inherit kde multilib versionator toolchain-funcs
S="${WORKDIR}/${PN}-$(get_version_component_range 1-3)"
@@ -22,14 +22,27 @@ DEPEND="${RDEPEND}
need-kde 3.3
-src_compile(){
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-respect-cc.patch"
+}
+
+src_compile() {
local myconf="prefix=/usr"
# Fix multilib issue.
myconf="${myconf} libdir=/usr/$(get_libdir)
qtlibs=${QTDIR}/$(get_libdir)"
- scons configure ${myconf} || die
- scons || die
+ local sconsopts=$(echo "${MAKEOPTS}" | sed -e "s/.*\(-j[0-9]\+\).*/\1/")
+ [[ ${MAKEOPTS/-s/} != ${MAKEOPTS} ]] && sconsopts="${sconsopts} -s"
+
+ tc-export CC CXX
+
+ scons configure ${myconf} \
+ || die "scons configure failed, if you report this please attach ${S}/configure.log"
+ scons ${sconsopts} || die "scons make failed"
}
src_install() {
diff --git a/media-video/codeine/files/codeine-1.0.1.3-respect-cc.patch b/media-video/codeine/files/codeine-1.0.1.3-respect-cc.patch
new file mode 100644
index 000000000000..2b680af424fe
--- /dev/null
+++ b/media-video/codeine/files/codeine-1.0.1.3-respect-cc.patch
@@ -0,0 +1,25 @@
+Index: codeine-1.0.1/SConstruct
+===================================================================
+--- codeine-1.0.1.orig/SConstruct
++++ codeine-1.0.1/SConstruct
+@@ -3,8 +3,10 @@
+ ###########################################
+ ## Common section, for loading the tools
+
++import os
++
+ ## Load the builders in config
+-env = Environment(TARGS=COMMAND_LINE_TARGETS, ARGS=ARGUMENTS, tools=['default', 'generic', 'kde', 'codeine'], toolpath=['./scons/'])
++env = Environment(TARGS=COMMAND_LINE_TARGETS, ARGS=ARGUMENTS, tools=['default', 'generic', 'kde', 'codeine'], toolpath=['./scons/'], CC=os.environ['CC'], CXX=os.environ['CXX'])
+
+
+ ## the configuration should be done by now, quit
+@@ -35,7 +37,7 @@ This has several advantages for both dev
+ import os
+ env.AppendUnique( ENV = os.environ )
+ ## If you do not want to copy the whole environment, you can use this instead (HOME is necessary for uic):
+-#env.AppendUnique( ENV = {'PATH' : os.environ['PATH'], 'HOME' : os.environ['HOME']} )
++env.Append( ENV = {'PATH' : os.environ['PATH'], 'HOME' : os.environ['HOME']} )
+
+ ## The target make dist requires the python module shutil which is in 2.3
+ env.EnsurePythonVersion(2, 3)