summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-03-25 22:54:52 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-03-25 22:54:52 +0000
commitc82e334f9e5bdce1533835a0c42fef4b6c86b414 (patch)
tree8d8fb8c8e1987f44fdbc114cc30f059c92c508af /media-video/cinepaint
parentversion bump to 3.0.17, mainly to address security bug 214576 (CVE-2008-1488)... (diff)
downloadgentoo-2-c82e334f9e5bdce1533835a0c42fef4b6c86b414.tar.gz
gentoo-2-c82e334f9e5bdce1533835a0c42fef4b6c86b414.tar.bz2
gentoo-2-c82e334f9e5bdce1533835a0c42fef4b6c86b414.zip
Add a check for fltk built with opengl useflag, bug #190814
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-video/cinepaint')
-rw-r--r--media-video/cinepaint/ChangeLog5
-rw-r--r--media-video/cinepaint/cinepaint-0.22.1.ebuild9
2 files changed, 12 insertions, 2 deletions
diff --git a/media-video/cinepaint/ChangeLog b/media-video/cinepaint/ChangeLog
index c67707e37819..fb57f15c9c09 100644
--- a/media-video/cinepaint/ChangeLog
+++ b/media-video/cinepaint/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-video/cinepaint
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cinepaint/ChangeLog,v 1.19 2008/03/25 22:12:48 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinepaint/ChangeLog,v 1.20 2008/03/25 22:54:52 aballier Exp $
+
+ 25 Mar 2008; Alexis Ballier <aballier@gentoo.org> cinepaint-0.22.1.ebuild:
+ Add a check for fltk built with opengl useflag, bug #190814
*cinepaint-0.22.1 (25 Mar 2008)
diff --git a/media-video/cinepaint/cinepaint-0.22.1.ebuild b/media-video/cinepaint/cinepaint-0.22.1.ebuild
index ab0a9da63825..d6bdff5f9bfb 100644
--- a/media-video/cinepaint/cinepaint-0.22.1.ebuild
+++ b/media-video/cinepaint/cinepaint-0.22.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/cinepaint/cinepaint-0.22.1.ebuild,v 1.1 2008/03/25 22:12:48 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/cinepaint/cinepaint-0.22.1.ebuild,v 1.2 2008/03/25 22:54:52 aballier Exp $
inherit eutils versionator flag-o-matic
@@ -30,6 +30,13 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
x11-proto/xineramaproto"
+pkg_setup() {
+ if ! built_with_use x11-libs/fltk opengl ; then
+ eerror "${PN} requires x11-libs/fltk to be built with opengl"
+ die "Please install x11-libs/fltk with opengl useflag enabled"
+ fi
+}
+
src_compile(){
econf $(use_enable gimpprint print) --enable-gtk2 || die "econf failed"
emake || die "emake failed"