summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Stine <battousai@gentoo.org>2004-09-30 22:17:01 +0000
committerBryan Stine <battousai@gentoo.org>2004-09-30 22:17:01 +0000
commitcc6df399653dd4ea0146911929f2ac13351e0d22 (patch)
treef8e7ac9d8625a49f5ea657abd975d9e3408e0746 /media-video/ati-gatos
parent~amd64 (Manifest recommit) (diff)
downloadgentoo-2-cc6df399653dd4ea0146911929f2ac13351e0d22.tar.gz
gentoo-2-cc6df399653dd4ea0146911929f2ac13351e0d22.tar.bz2
gentoo-2-cc6df399653dd4ea0146911929f2ac13351e0d22.zip
Bump ati-gatos to upstream ati.4.4.0.
Diffstat (limited to 'media-video/ati-gatos')
-rw-r--r--media-video/ati-gatos/ChangeLog8
-rw-r--r--media-video/ati-gatos/ati-gatos-4.4.0.ebuild82
-rw-r--r--media-video/ati-gatos/files/ati-gatos-4.4.0-new-xorg.patch263
-rw-r--r--media-video/ati-gatos/files/digest-ati-gatos-4.4.01
4 files changed, 353 insertions, 1 deletions
diff --git a/media-video/ati-gatos/ChangeLog b/media-video/ati-gatos/ChangeLog
index 9f585795f7d8..953a3ceb46c5 100644
--- a/media-video/ati-gatos/ChangeLog
+++ b/media-video/ati-gatos/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/ati-gatos
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ati-gatos/ChangeLog,v 1.16 2004/06/25 00:36:23 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ati-gatos/ChangeLog,v 1.17 2004/09/30 22:17:01 battousai Exp $
+
+*ati-gatos-4.4.0 (30 Sep 2004)
+
+ 30 Sep 2004; Bryan Stine <battousai@gentoo.org>; +ati-gatos-4.4.0.ebuild:
+ Version bump to xorg-ready ati.4.4.0. This ebuild also includes a patch to
+ apply when using xorg-x11 6.8.0.
11 Jun 2004; Donnie Berkholz <spyderous@gentoo.org>; ati-gatos-4.3.0.ebuild:
xfree -r6 became -r7.
diff --git a/media-video/ati-gatos/ati-gatos-4.4.0.ebuild b/media-video/ati-gatos/ati-gatos-4.4.0.ebuild
new file mode 100644
index 000000000000..bc2a7142d752
--- /dev/null
+++ b/media-video/ati-gatos/ati-gatos-4.4.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ati-gatos/ati-gatos-4.4.0.ebuild,v 1.1 2004/09/30 22:17:01 battousai Exp $
+
+inherit eutils
+
+IUSE=""
+
+SNAPSHOT=20040930
+MYP=${P}-${SNAPSHOT}
+
+DESCRIPTION="ATI Multimedia-capable drivers for XFree86"
+SRC_URI="mirror://gentoo/${MYP}.tar.bz2"
+HOMEPAGE="http://gatos.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="${DEPEND}
+ >=x11-base/xorg-x11-6.7.0-r1"
+
+pkg_setup() {
+ if [ ! "`grep sdk /var/db/pkg/x11-base/xorg-x11-[0-9]*/USE`" ]
+ then
+ ewarn "This package requires that xorg-x11 was merged with the sdk USE flag enabled."
+ die "Please merge xorg-x11 with the sdk USE flag enabled."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ if has_version '>=x11-base/xorg-x11-6.7.99*'
+ then
+ einfo "Patching ati-gatos for use with >=x11-base/xorg-x11-6.7.99"
+ epatch ${FILESDIR}/${P}-new-xorg.patch
+ fi
+
+ # Build makefiles against XFree SDK
+ imake -I/usr/X11R6/lib/Server/config/cf -DUseInstalled -DXF86DriverSDK
+
+ # Makefile fixes
+ fix_makefile
+}
+
+src_compile() {
+ cd ${S}
+
+ emake DESTDIR=${D} || die "Problem compiling GATOS drivers."
+}
+
+src_install() {
+ emake DESTDIR=${D} install
+}
+
+pkg_postinst() {
+ einfo "To have XFree86 make use of the new GATOS modules, you should add the following"
+ einfo "line to /etc/X11/XF86Config, in the files section and above any other"
+ einfo "ModulePath directives:"
+ einfo
+ einfo " ModulePath \"/usr/X11R6/lib/modules-extra/gatos\""
+ einfo
+ einfo "Please note that you may need to uncomment or add another ModulePath line with"
+ einfo "the default module path in it. If XFree86 does not start after adding the line"
+ einfo "above, add this one under it:"
+ einfo
+ einfo " ModulePath \"/usr/X11R6/lib/modules\""
+}
+
+fix_makefile() {
+ cp Makefile Makefile.orig
+
+ # Add the XFree86 SDK include directories that gatos will use
+ sed -i -e "s:\ *INCLUDES = \(.\+\):INCLUDES = \\1 -I/usr/X11R6/lib/Server/include -I/usr/X11R6/lib/Server/include/extensions:" Makefile
+
+ # Clean up the ugly sandbox violations
+ sed -i -e "s:\(\ \+\)MODULEDIR = .*:\\1MODULEDIR = \\\$(USRLIBDIR)/modules-extra/gatos:" Makefile
+ sed -i -e "s:\(\ \+\)BUILDLIBDIR = .*:\\1BUILDLIBDIR = \\\$(DESTDIR)\\\$(TOP)/exports/lib:" Makefile
+ sed -i -e "s:\$(RM) \$(BUILDMODULEDIR):\$(RM) \$(DESTDIR)\$(BUILDMODULEDIR):g" Makefile
+}
diff --git a/media-video/ati-gatos/files/ati-gatos-4.4.0-new-xorg.patch b/media-video/ati-gatos/files/ati-gatos-4.4.0-new-xorg.patch
new file mode 100644
index 000000000000..fa4cf3ce1e6e
--- /dev/null
+++ b/media-video/ati-gatos/files/ati-gatos-4.4.0-new-xorg.patch
@@ -0,0 +1,263 @@
+diff -urN ati-gatos-4.4.0.orig/r128.h ati-gatos-4.4.0/r128.h
+--- ati-gatos-4.4.0.orig/r128.h 2004-08-20 20:41:46.361881992 -0400
++++ ati-gatos-4.4.0/r128.h 2004-08-20 20:42:19.289876176 -0400
+@@ -289,19 +289,19 @@
+ Bool directRenderingEnabled;
+ DRIInfoPtr pDRIInfo;
+ int drmFD;
+- drmContext drmCtx;
++ drm_context_t drmCtx;
+ int numVisualConfigs;
+ __GLXvisualConfig *pVisualConfigs;
+ R128ConfigPrivPtr pVisualConfigsPriv;
+
+- drmHandle fbHandle;
++ drm_handle_t fbHandle;
+
+ drmSize registerSize;
+- drmHandle registerHandle;
++ drm_handle_t registerHandle;
+
+ Bool IsPCI; /* Current card is a PCI card */
+ drmSize pciSize;
+- drmHandle pciMemHandle;
++ drm_handle_t pciMemHandle;
+ unsigned char *PCI; /* Map */
+
+ Bool allowPageFlip; /* Enable 3d page flipping */
+@@ -309,7 +309,7 @@
+ int drmMinor;
+
+ drmSize agpSize;
+- drmHandle agpMemHandle; /* Handle from drmAgpAlloc */
++ drm_handle_t agpMemHandle; /* Handle from drmAgpAlloc */
+ unsigned long agpOffset;
+ unsigned char *AGP; /* Map */
+ int agpMode;
+@@ -322,20 +322,20 @@
+
+ /* CCE ring buffer data */
+ unsigned long ringStart; /* Offset into AGP space */
+- drmHandle ringHandle; /* Handle from drmAddMap */
++ drm_handle_t ringHandle; /* Handle from drmAddMap */
+ drmSize ringMapSize; /* Size of map */
+ int ringSize; /* Size of ring (in MB) */
+ unsigned char *ring; /* Map */
+ int ringSizeLog2QW;
+
+ unsigned long ringReadOffset; /* Offset into AGP space */
+- drmHandle ringReadPtrHandle; /* Handle from drmAddMap */
++ drm_handle_t ringReadPtrHandle; /* Handle from drmAddMap */
+ drmSize ringReadMapSize; /* Size of map */
+ unsigned char *ringReadPtr; /* Map */
+
+ /* CCE vertex/indirect buffer data */
+ unsigned long bufStart; /* Offset into AGP space */
+- drmHandle bufHandle; /* Handle from drmAddMap */
++ drm_handle_t bufHandle; /* Handle from drmAddMap */
+ drmSize bufMapSize; /* Size of map */
+ int bufSize; /* Size of buffers (in MB) */
+ unsigned char *buf; /* Map */
+@@ -344,7 +344,7 @@
+
+ /* CCE AGP Texture data */
+ unsigned long agpTexStart; /* Offset into AGP space */
+- drmHandle agpTexHandle; /* Handle from drmAddMap */
++ drm_handle_t agpTexHandle; /* Handle from drmAddMap */
+ drmSize agpTexMapSize; /* Size of map */
+ int agpTexSize; /* Size of AGP tex space (in MB) */
+ unsigned char *agpTex; /* Map */
+diff -urN ati-gatos-4.4.0.orig/r128_dri.c ati-gatos-4.4.0/r128_dri.c
+--- ati-gatos-4.4.0.orig/r128_dri.c 2004-08-20 20:41:46.363881688 -0400
++++ ati-gatos-4.4.0/r128_dri.c 2004-08-20 20:42:19.313872528 -0400
+@@ -277,7 +277,7 @@
+
+ /* Create the Rage 128-specific context information */
+ static Bool R128CreateContext(ScreenPtr pScreen, VisualPtr visual,
+- drmContext hwContext, void *pVisualConfigPriv,
++ drm_context_t hwContext, void *pVisualConfigPriv,
+ DRIContextType contextStore)
+ {
+ ScrnInfoPtr pScrn = xf86Screens[pScreen->myNum];
+@@ -288,7 +288,7 @@
+ }
+
+ /* Destroy the Rage 128-specific context information */
+-static void R128DestroyContext(ScreenPtr pScreen, drmContext hwContext,
++static void R128DestroyContext(ScreenPtr pScreen, drm_context_t hwContext,
+ DRIContextType contextStore)
+ {
+ /* Nothing yet */
+diff -urN ati-gatos-4.4.0.orig/r128_dri.h ati-gatos-4.4.0/r128_dri.h
+--- ati-gatos-4.4.0.orig/r128_dri.h 2004-08-20 20:41:46.363881688 -0400
++++ ati-gatos-4.4.0/r128_dri.h 2004-08-20 20:42:19.314872376 -0400
+@@ -88,11 +88,11 @@
+ int log2TexGran;
+
+ /* MMIO register data */
+- drmHandle registerHandle;
++ drm_handle_t registerHandle;
+ drmSize registerSize;
+
+ /* CCE AGP Texture data */
+- drmHandle agpTexHandle;
++ drm_handle_t agpTexHandle;
+ drmSize agpTexMapSize;
+ int log2AGPTexGran;
+ int agpTexOffset;
+diff -urN ati-gatos-4.4.0.orig/r128_sarea.h ati-gatos-4.4.0/r128_sarea.h
+--- ati-gatos-4.4.0.orig/r128_sarea.h 2004-08-20 20:41:46.364881536 -0400
++++ ati-gatos-4.4.0/r128_sarea.h 2004-08-20 20:42:19.349867056 -0400
+@@ -167,7 +167,7 @@
+ #ifdef XF86DRI
+ /* The current cliprects, or a subset thereof.
+ */
+- XF86DRIClipRectRec boxes[R128_NR_SAREA_CLIPRECTS];
++ drm_clip_rect_t boxes[R128_NR_SAREA_CLIPRECTS];
+ unsigned int nbox;
+ #endif
+
+diff -urN ati-gatos-4.4.0.orig/radeon.h ati-gatos-4.4.0/radeon.h
+--- ati-gatos-4.4.0.orig/radeon.h 2004-08-20 20:41:46.365881384 -0400
++++ ati-gatos-4.4.0/radeon.h 2004-08-20 20:42:19.370863864 -0400
+@@ -412,14 +412,14 @@
+ __GLXvisualConfig *pVisualConfigs;
+ RADEONConfigPrivPtr pVisualConfigsPriv;
+
+- drmHandle fbHandle;
++ drm_handle_t fbHandle;
+
+ drmSize registerSize;
+- drmHandle registerHandle;
++ drm_handle_t registerHandle;
+
+ Bool IsPCI; /* Current card is a PCI card */
+ drmSize pciSize;
+- drmHandle pciMemHandle;
++ drm_handle_t pciMemHandle;
+ unsigned char *PCI; /* Map */
+
+ Bool depthMoves; /* Enable depth moves -- slow! */
+@@ -428,7 +428,7 @@
+ int drmMinor;
+
+ drmSize gartSize;
+- drmHandle agpMemHandle; /* Handle from drmAgpAlloc */
++ drm_handle_t agpMemHandle; /* Handle from drmAgpAlloc */
+ unsigned long gartOffset;
+ unsigned char *AGP; /* Map */
+ int agpMode;
+@@ -445,20 +445,20 @@
+
+ /* CP ring buffer data */
+ unsigned long ringStart; /* Offset into GART space */
+- drmHandle ringHandle; /* Handle from drmAddMap */
++ drm_handle_t ringHandle; /* Handle from drmAddMap */
+ drmSize ringMapSize; /* Size of map */
+ int ringSize; /* Size of ring (in MB) */
+ unsigned char *ring; /* Map */
+ int ringSizeLog2QW;
+
+ unsigned long ringReadOffset; /* Offset into GART space */
+- drmHandle ringReadPtrHandle; /* Handle from drmAddMap */
++ drm_handle_t ringReadPtrHandle; /* Handle from drmAddMap */
+ drmSize ringReadMapSize; /* Size of map */
+ unsigned char *ringReadPtr; /* Map */
+
+ /* CP vertex/indirect buffer data */
+ unsigned long bufStart; /* Offset into GART space */
+- drmHandle bufHandle; /* Handle from drmAddMap */
++ drm_handle_t bufHandle; /* Handle from drmAddMap */
+ drmSize bufMapSize; /* Size of map */
+ int bufSize; /* Size of buffers (in MB) */
+ unsigned char *buf; /* Map */
+@@ -467,7 +467,7 @@
+
+ /* CP GART Texture data */
+ unsigned long gartTexStart; /* Offset into GART space */
+- drmHandle gartTexHandle; /* Handle from drmAddMap */
++ drm_handle_t gartTexHandle; /* Handle from drmAddMap */
+ drmSize gartTexMapSize; /* Size of map */
+ int gartTexSize; /* Size of GART tex space (in MB) */
+ unsigned char *gartTex; /* Map */
+diff -urN ati-gatos-4.4.0.orig/radeon_common.h ati-gatos-4.4.0/radeon_common.h
+--- ati-gatos-4.4.0.orig/radeon_common.h 2004-08-20 20:41:46.366881232 -0400
++++ ati-gatos-4.4.0/radeon_common.h 2004-08-20 20:42:19.384861736 -0400
+@@ -276,7 +276,7 @@
+ int bufsz;
+ char *buf;
+ int nbox;
+- drmClipRect *boxes;
++ drm_clip_rect_t *boxes;
+ } drmRadeonCmdBuffer;
+
+ /* New style per-packet identifiers for use in cmd_buffer ioctl with
+diff -urN ati-gatos-4.4.0.orig/radeon_dri.c ati-gatos-4.4.0/radeon_dri.c
+--- ati-gatos-4.4.0.orig/radeon_dri.c 2004-08-20 20:41:46.367881080 -0400
++++ ati-gatos-4.4.0/radeon_dri.c 2004-08-20 20:42:19.400859304 -0400
+@@ -284,7 +284,7 @@
+
+ /* Create the Radeon-specific context information */
+ static Bool RADEONCreateContext(ScreenPtr pScreen, VisualPtr visual,
+- drmContext hwContext, void *pVisualConfigPriv,
++ drm_context_t hwContext, void *pVisualConfigPriv,
+ DRIContextType contextStore)
+ {
+ #ifdef PER_CONTEXT_SAREA
+@@ -321,7 +321,7 @@
+ }
+
+ /* Destroy the Radeon-specific context information */
+-static void RADEONDestroyContext(ScreenPtr pScreen, drmContext hwContext,
++static void RADEONDestroyContext(ScreenPtr pScreen, drm_context_t hwContext,
+ DRIContextType contextStore)
+ {
+ #ifdef PER_CONTEXT_SAREA
+diff -urN ati-gatos-4.4.0.orig/radeon_dri.h ati-gatos-4.4.0/radeon_dri.h
+--- ati-gatos-4.4.0.orig/radeon_dri.h 2004-08-20 20:41:46.367881080 -0400
++++ ati-gatos-4.4.0/radeon_dri.h 2004-08-20 20:42:19.401859152 -0400
+@@ -85,15 +85,15 @@
+ int log2TexGran;
+
+ /* MMIO register data */
+- drmHandle registerHandle;
++ drm_handle_t registerHandle;
+ drmSize registerSize;
+
+ /* CP in-memory status information */
+- drmHandle statusHandle;
++ drm_handle_t statusHandle;
+ drmSize statusSize;
+
+ /* CP GART Texture data */
+- drmHandle gartTexHandle;
++ drm_handle_t gartTexHandle;
+ drmSize gartTexMapSize;
+ int log2GARTTexGran;
+ int gartTexOffset;
+diff -urN ati-gatos-4.4.0.orig/radeon_dripriv.h ati-gatos-4.4.0/radeon_dripriv.h
+--- ati-gatos-4.4.0.orig/radeon_dripriv.h 2004-08-20 20:41:46.367881080 -0400
++++ ati-gatos-4.4.0/radeon_dripriv.h 2004-08-20 20:42:19.402859000 -0400
+@@ -53,8 +53,8 @@
+
+ typedef struct {
+ #ifdef PER_CONTEXT_SAREA
+- drmContext ctx_id;
+- drmHandle sarea_handle;
++ drm_context_t ctx_id;
++ drm_handle_t sarea_handle;
+ #else
+ /* Nothing here yet */
+ int dummy;
+diff -urN ati-gatos-4.4.0.orig/radeon_sarea.h ati-gatos-4.4.0/radeon_sarea.h
+--- ati-gatos-4.4.0.orig/radeon_sarea.h 2004-08-20 20:41:46.370880624 -0400
++++ ati-gatos-4.4.0/radeon_sarea.h 2004-08-20 20:42:19.461850032 -0400
+@@ -201,7 +201,7 @@
+ unsigned int vc_format;
+
+ /* The current cliprects, or a subset thereof */
+- XF86DRIClipRectRec boxes[RADEON_NR_SAREA_CLIPRECTS];
++ drm_clip_rect_t boxes[RADEON_NR_SAREA_CLIPRECTS];
+ unsigned int nbox;
+
+ /* Counters for throttling of rendering clients */
diff --git a/media-video/ati-gatos/files/digest-ati-gatos-4.4.0 b/media-video/ati-gatos/files/digest-ati-gatos-4.4.0
new file mode 100644
index 000000000000..bd41990431ac
--- /dev/null
+++ b/media-video/ati-gatos/files/digest-ati-gatos-4.4.0
@@ -0,0 +1 @@
+MD5 d1262a89f9a7ac297b92982d46e17ec2 ati-gatos-4.4.0-20040930.tar.bz2 375492