summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2013-08-31 08:27:17 +0000
committerDavide Pesavento <pesa@gentoo.org>2013-08-31 08:27:17 +0000
commitee41b98c6809c4eda391554215f435df09f5e060 (patch)
tree49fa7fe9af6876b60f57d65cdb2e71d713969a5c /media-video/2mandvd
parentAdd ~arm keyword, wrt bug #476710 (diff)
downloadgentoo-2-ee41b98c6809c4eda391554215f435df09f5e060.tar.gz
gentoo-2-ee41b98c6809c4eda391554215f435df09f5e060.tar.bz2
gentoo-2-ee41b98c6809c4eda391554215f435df09f5e060.zip
Version bump.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 17A85C72)
Diffstat (limited to 'media-video/2mandvd')
-rw-r--r--media-video/2mandvd/2mandvd-1.8.5.ebuild65
-rw-r--r--media-video/2mandvd/ChangeLog9
-rw-r--r--media-video/2mandvd/files/2mandvd-1.8.5-libavformat54.patch27
-rw-r--r--media-video/2mandvd/files/2mandvd-fix-const-char-concatenation.patch14
4 files changed, 100 insertions, 15 deletions
diff --git a/media-video/2mandvd/2mandvd-1.8.5.ebuild b/media-video/2mandvd/2mandvd-1.8.5.ebuild
new file mode 100644
index 000000000000..09678f05c092
--- /dev/null
+++ b/media-video/2mandvd/2mandvd-1.8.5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/2mandvd-1.8.5.ebuild,v 1.1 2013/08/31 08:27:16 pesa Exp $
+
+EAPI=4
+LANGS="cs de en it ru"
+
+inherit qt4-r2
+
+MY_PN="2ManDVD"
+
+DESCRIPTION="The successor of ManDVD"
+HOMEPAGE="http://kde-apps.org/content/show.php?content=99450"
+SRC_URI="http://download.tuxfamily.org/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="media-libs/libsdl
+ virtual/ffmpeg
+ virtual/glu
+ virtual/opengl
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+"
+RDEPEND="${DEPEND}
+ || ( app-cdr/cdrkit app-cdr/cdrtools )
+ dev-lang/perl
+ media-fonts/dejavu
+ media-gfx/exif
+ media-libs/netpbm
+ media-sound/sox
+ media-video/dvdauthor
+ media-video/ffmpegthumbnailer
+ media-video/mjpegtools
+ media-video/mplayer[encode]
+"
+
+S=${WORKDIR}/${MY_PN}
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.7.3-libav.patch"
+ "${FILESDIR}/${PN}-1.8.5-libavformat54.patch"
+)
+
+src_prepare() {
+ # Clean backup files
+ find . -name "*~" -delete || die
+
+ # Delete useless chmod that violates the sandbox
+ sed -i -e '/chmod/d' ${MY_PN}.pro || die
+
+ # Fix desktop file
+ sed -i -e '/^Categories=/s/GNOME;AudioVideo;//' ${MY_PN}.desktop || die
+
+ qt4-r2_src_prepare
+}
+
+pkg_postinst() {
+ elog "You may wish to install media-video/xine-ui and/or build"
+ elog "media-sound/sox with USE=mad for improved media handling support."
+}
diff --git a/media-video/2mandvd/ChangeLog b/media-video/2mandvd/ChangeLog
index 0008d6f1512b..2ad897943ab1 100644
--- a/media-video/2mandvd/ChangeLog
+++ b/media-video/2mandvd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/2mandvd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/ChangeLog,v 1.31 2013/06/17 18:00:46 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/ChangeLog,v 1.32 2013/08/31 08:27:16 pesa Exp $
+
+*2mandvd-1.8.5 (31 Aug 2013)
+
+ 31 Aug 2013; Davide Pesavento <pesa@gentoo.org> +2mandvd-1.8.5.ebuild,
+ +files/2mandvd-1.8.5-libavformat54.patch,
+ -files/2mandvd-fix-const-char-concatenation.patch:
+ Version bump.
17 Jun 2013; Tomáš Chvátal <scarabeus@gentoo.org> -2mandvd-1.8.1.ebuild,
2mandvd-1.8.4.ebuild, files/2mandvd-1.8.4-libavformat54.patch:
diff --git a/media-video/2mandvd/files/2mandvd-1.8.5-libavformat54.patch b/media-video/2mandvd/files/2mandvd-1.8.5-libavformat54.patch
new file mode 100644
index 000000000000..89ecc4d23c60
--- /dev/null
+++ b/media-video/2mandvd/files/2mandvd-1.8.5-libavformat54.patch
@@ -0,0 +1,27 @@
+diff --git a/videowrapper.cpp b/videowrapper.cpp
+index 7ae4ad3..d50599b 100644
+--- a/videowrapper.cpp
++++ b/videowrapper.cpp
+@@ -38,7 +38,7 @@ void videowrapper::delete_videowrapper()
+ int videowrapper::load_video(QString filename)
+ {
+ // *** OUVERTURE DU FICHIER VIDEO ***
+- #ifdef avformat_open_input
++ #if LIBAVFORMAT_VERSION_INT > AV_VERSION_INT(53,5,0)
+ if (avformat_open_input(&pFormatCtx,filename.toAscii().data(),NULL,NULL)!=0)
+ {
+ #else
+@@ -91,13 +91,8 @@ int videowrapper::load_video(QString filename)
+
+ // *** OUVERTURE DU CODEC ***
+
+- #ifdef av_find_stream_info
+- if(avcodec_open(pCodecCtx, pCodec)<0)
+- {
+- #else
+ if (avcodec_open2(pCodecCtx, pCodec, NULL) < 0)
+ {
+- #endif
+ qDebug() << "CAN'T FIND VIDEO CODEC";
+ return 1;
+ }
diff --git a/media-video/2mandvd/files/2mandvd-fix-const-char-concatenation.patch b/media-video/2mandvd/files/2mandvd-fix-const-char-concatenation.patch
deleted file mode 100644
index 8d5177c0eaa7..000000000000
--- a/media-video/2mandvd/files/2mandvd-fix-const-char-concatenation.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -Naur 2ManDVD.orig/mainfrm.cpp 2ManDVD/mainfrm.cpp
---- 2ManDVD.orig/mainfrm.cpp 2011-05-07 22:29:20.049000080 -0300
-+++ 2ManDVD/mainfrm.cpp 2011-05-07 22:30:30.055000081 -0300
-@@ -1403,8 +1403,8 @@
- outext << "growisofs" << endl;
- outext << "mpeg2enc" << endl;
- outext << "jpegtopnm /dev/null" << endl;
-- outext << "cat " + "/usr/share/2mandvd/fake.pl" << endl;
-- outext << "rm -f " + homeDir.path() + "/.mdvdep.sh" << endl;
-+ outext << "cat " << "/usr/share/2mandvd/fake.pl" << endl;
-+ outext << "rm -f " << homeDir.path() << "/.mdvdep.sh" << endl;
- outext << "exit" << endl;
- wmyficext.close();
- QString programf = "bash";