summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2008-03-30 14:57:58 +0000
committerLars Weiler <pylon@gentoo.org>2008-03-30 14:57:58 +0000
commitbb9dd14880084803dace1cdc98ff1131a7a391f5 (patch)
treebcb84885fca458d37fff173e9e1f89ebf415dcd4 /media-tv
parentBuild breaks on newer libdvdnav, add blocker to depend (diff)
downloadgentoo-2-bb9dd14880084803dace1cdc98ff1131a7a391f5.tar.gz
gentoo-2-bb9dd14880084803dace1cdc98ff1131a7a391f5.tar.bz2
gentoo-2-bb9dd14880084803dace1cdc98ff1131a7a391f5.zip
Version bump; fixes tcl8.5-compatibility; bug #212682 and #173467.
Probably the tcl/tk-dependency must be fixed to 8.5, but that version is still masked. (Portage version: 2.1.4.4)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/nxtvepg/ChangeLog13
-rw-r--r--media-tv/nxtvepg/files/nxtvepg-daemon-install.patch33
-rw-r--r--media-tv/nxtvepg/files/nxtvepg-tcl8.5.patch14
-rw-r--r--media-tv/nxtvepg/files/nxtvepg-unicode.patch12
-rw-r--r--media-tv/nxtvepg/nxtvepg-2.7.6.ebuild40
-rw-r--r--media-tv/nxtvepg/nxtvepg-2.7.7.ebuild40
-rw-r--r--media-tv/nxtvepg/nxtvepg-2.8.0.ebuild51
7 files changed, 121 insertions, 82 deletions
diff --git a/media-tv/nxtvepg/ChangeLog b/media-tv/nxtvepg/ChangeLog
index ab6b691fb1f6..adecc768f48f 100644
--- a/media-tv/nxtvepg/ChangeLog
+++ b/media-tv/nxtvepg/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-tv/nxtvepg
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/nxtvepg/ChangeLog,v 1.16 2007/11/27 10:42:59 zzam Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/nxtvepg/ChangeLog,v 1.17 2008/03/30 14:57:58 pylon Exp $
+
+*nxtvepg-2.8.0 (30 Mar 2008)
+
+ 30 Mar 2008; Lars Weiler <pylon@gentoo.org> +files/nxtvepg-tcl8.5.patch,
+ +files/nxtvepg-daemon-install.patch, +files/nxtvepg-unicode.patch,
+ -nxtvepg-2.7.6.ebuild, -nxtvepg-2.7.7.ebuild, +nxtvepg-2.8.0.ebuild:
+ Version bump; fixes tcl8.5-compatibility; bug #212682 and #173467.
+ Probably the tcl/tk-dependency must be fixed to 8.5, but that version is
+ still masked.
27 Nov 2007; Matthias Schwarzott <zzam@gentoo.org> nxtvepg-2.7.5.ebuild:
Fixed quoting.
diff --git a/media-tv/nxtvepg/files/nxtvepg-daemon-install.patch b/media-tv/nxtvepg/files/nxtvepg-daemon-install.patch
new file mode 100644
index 000000000000..870926dec2e5
--- /dev/null
+++ b/media-tv/nxtvepg/files/nxtvepg-daemon-install.patch
@@ -0,0 +1,33 @@
+diff -Naur nxtvepg-2.8.0.orig/Makefile nxtvepg-2.8.0/Makefile
+--- nxtvepg-2.8.0.orig/Makefile 2008-03-30 16:19:54.000000000 +0200
++++ nxtvepg-2.8.0/Makefile 2008-03-30 16:21:00.000000000 +0200
+@@ -209,8 +209,8 @@
+ $(BUILD_DIR)/vbirec: $(VBIREC_OBJS)
+ $(CC) -o $@ $(VBIREC_OBJS) $(LDFLAGS) $(GUILIBS) $(ACQLIBS)
+
+-.PHONY: install
+-install: daemon Nxtvepg.ad nxtvepgd.1
++.PHONY: install-common
++install-common: daemon nxtvepgd.1
+ test -d $(bindir) || install -d $(bindir)
+ test -d $(mandir) || install -d $(mandir)
+ test -d $(resdir)/app-defaults || install -d $(resdir)/app-defaults
+@@ -218,10 +218,16 @@
+ test -d $(INST_DB_DIR) || install -d $(INST_DB_DIR)
+ chmod $(INST_DB_PERM) $(INST_DB_DIR)
+ endif
+- install -c -m 0755 $(BUILD_DIR)/nxtvepg $(bindir)
+- install -c -m 0755 $(BUILD_DIR)/nxtvepgd $(bindir)
+ install -c -m 0644 nxtvepg.1 $(mandir)
++
++.PHONY: install-daemon
++install-daemon: install-common
++ install -c -m 0755 $(BUILD_DIR)/nxtvepgd $(bindir)
+ install -c -m 0644 nxtvepgd.1 $(mandir)
++
++.PHONY: install
++install: install-common install-daemon Nxtvepg.ad
++ install -c -m 0755 $(BUILD_DIR)/nxtvepg $(bindir)
+ install -c -m 0644 Nxtvepg.ad $(resdir)/app-defaults/Nxtvepg
+
+ .SUFFIXES: .c .o .tcl
diff --git a/media-tv/nxtvepg/files/nxtvepg-tcl8.5.patch b/media-tv/nxtvepg/files/nxtvepg-tcl8.5.patch
new file mode 100644
index 000000000000..662fe75e4577
--- /dev/null
+++ b/media-tv/nxtvepg/files/nxtvepg-tcl8.5.patch
@@ -0,0 +1,14 @@
+diff -Naur nxtvepg-2.8.0.orig/Makefile nxtvepg-2.8.0/Makefile
+--- nxtvepg-2.8.0.orig/Makefile 2008-03-30 16:35:42.000000000 +0200
++++ nxtvepg-2.8.0/Makefile 2008-03-30 16:35:54.000000000 +0200
+@@ -58,8 +58,8 @@
+ YACC = /usr/bin/yacc
+
+ # select Tcl/Tk version (8.5 recommended due to modernized widget appearence)
+-TCL_VER := $(shell echo 'puts [package require Tcl]' | tclsh)
+-#TCL_VER = 8.5
++#TCL_VER := $(shell echo 'puts [package require Tcl]' | tclsh)
++TCL_VER = 8.5
+
+ ifeq ($(shell test -d /usr/include/tcl$(TCL_VER) && echo YES),YES)
+ INCS += -I/usr/include/tcl$(TCL_VER)
diff --git a/media-tv/nxtvepg/files/nxtvepg-unicode.patch b/media-tv/nxtvepg/files/nxtvepg-unicode.patch
new file mode 100644
index 000000000000..861da3789390
--- /dev/null
+++ b/media-tv/nxtvepg/files/nxtvepg-unicode.patch
@@ -0,0 +1,12 @@
+diff -Naur nxtvepg-2.8.0.orig/Makefile nxtvepg-2.8.0/Makefile
+--- nxtvepg-2.8.0.orig/Makefile 2008-03-30 16:36:52.000000000 +0200
++++ nxtvepg-2.8.0/Makefile 2008-03-30 16:36:58.000000000 +0200
+@@ -86,7 +86,7 @@
+ ACQLIBS += -lpthread
+
+ # use UTF-8 internally instead of Latin-1 (EXPERIMENTAL)
+-#DEFS += -DUSE_UTF8 -DXMLTV_OUTPUT_UTF8
++DEFS += -DUSE_UTF8 -DXMLTV_OUTPUT_UTF8
+
+ # enable support for importing XMLTV files
+ DEFS += -DUSE_XMLTV_IMPORT
diff --git a/media-tv/nxtvepg/nxtvepg-2.7.6.ebuild b/media-tv/nxtvepg/nxtvepg-2.7.6.ebuild
deleted file mode 100644
index 3e9e11846f7d..000000000000
--- a/media-tv/nxtvepg/nxtvepg-2.7.6.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/nxtvepg/nxtvepg-2.7.6.ebuild,v 1.3 2006/12/02 09:50:28 dev-zero Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="receive and browse free TV programme listings via bttv for tv networks in Europe"
-HOMEPAGE="http://nxtvepg.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-RDEPEND=">=dev-lang/tcl-8.0
- >=dev-lang/tk-8.0
- x11-libs/libX11
- x11-libs/libXmu"
-
-DEPEND="${RDEPEND}
- sys-apps/sed
- sys-kernel/linux-headers
- x11-proto/xproto"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/nxtvepg-db.patch"
-}
-
-src_compile() {
- emake -j1 CC=$(tc-getCC) prefix="/usr" || die "emake failed"
-}
-
-src_install() {
- emake ROOT="${D}" prefix="/usr" install || die "emake install failed"
- dodoc README CHANGES TODO
- dohtml manual*.html
-}
diff --git a/media-tv/nxtvepg/nxtvepg-2.7.7.ebuild b/media-tv/nxtvepg/nxtvepg-2.7.7.ebuild
deleted file mode 100644
index 7ea1b99be24b..000000000000
--- a/media-tv/nxtvepg/nxtvepg-2.7.7.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/nxtvepg/nxtvepg-2.7.7.ebuild,v 1.1 2007/07/07 19:01:51 pylon Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="receive and browse free TV programme listings via bttv for tv networks in Europe"
-HOMEPAGE="http://nxtvepg.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-RDEPEND=">=dev-lang/tcl-8.0
- >=dev-lang/tk-8.0
- x11-libs/libX11
- x11-libs/libXmu"
-
-DEPEND="${RDEPEND}
- sys-apps/sed
- sys-kernel/linux-headers
- x11-proto/xproto"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/nxtvepg-db.patch"
-}
-
-src_compile() {
- emake -j1 CC=$(tc-getCC) prefix="/usr" || die "emake failed"
-}
-
-src_install() {
- emake ROOT="${D}" prefix="/usr" install || die "emake install failed"
- dodoc README CHANGES TODO
- dohtml manual*.html
-}
diff --git a/media-tv/nxtvepg/nxtvepg-2.8.0.ebuild b/media-tv/nxtvepg/nxtvepg-2.8.0.ebuild
new file mode 100644
index 000000000000..2aa3436bd9c1
--- /dev/null
+++ b/media-tv/nxtvepg/nxtvepg-2.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/nxtvepg/nxtvepg-2.8.0.ebuild,v 1.1 2008/03/30 14:57:58 pylon Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="receive and browse free TV programme listings via bttv for tv networks in Europe"
+HOMEPAGE="http://nxtvepg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X unicode"
+
+RDEPEND="X? ( >=dev-lang/tcl-8
+ >=dev-lang/tk-8
+ x11-libs/libX11
+ x11-libs/libXmu )"
+
+DEPEND="${RDEPEND}
+ sys-apps/sed
+ sys-kernel/linux-headers
+ X? ( x11-proto/xproto )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/nxtvepg-db.patch" || die "db patch failed"
+ epatch "${FILESDIR}/nxtvepg-daemon-install.patch" || die "daemon patch failed"
+ epatch "${FILESDIR}/nxtvepg-tcl8.5.patch" || die "tcl-8.5 patch failed"
+ ( use unicode && epatch "${FILESDIR}/nxtvepg-unicode.patch" ) || die "unicode patch failed"
+}
+
+src_compile() {
+ if use X; then
+ emake -j1 CC=$(tc-getCC) prefix="/usr" || die "emake failed"
+ else
+ emake -j1 CC=$(tc-getCC) prefix="/usr" daemon || die "emake failed"
+ fi
+}
+
+src_install() {
+ if use X; then
+ emake ROOT="${D}" prefix="/usr" install || die "emake install failed"
+ else
+ emake ROOT="${D}" prefix="/usr" install-daemon || die "emake install failed"
+ fi
+ dodoc README CHANGES TODO
+ dohtml manual*.html
+}