summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2008-11-20 19:53:21 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2008-11-20 19:53:21 +0000
commit99ff3a11f2b302757baa28d7bbfc9b4f9ab0a0cd (patch)
tree8e44219ddf7b365c412319d3d774260c85ef4146 /media-tv
parentold (diff)
downloadgentoo-2-99ff3a11f2b302757baa28d7bbfc9b4f9ab0a0cd.tar.gz
gentoo-2-99ff3a11f2b302757baa28d7bbfc9b4f9ab0a0cd.tar.bz2
gentoo-2-99ff3a11f2b302757baa28d7bbfc9b4f9ab0a0cd.zip
Version bump (bug #246787). Thanks to Richard Li <richardpku at gmail dot com>.
(Portage version: 2.2_rc14/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/w_scan/ChangeLog10
-rw-r--r--media-tv/w_scan/files/w_scan-20081106-build-and-path-fixes.patch68
-rw-r--r--media-tv/w_scan/w_scan-20081106.ebuild29
3 files changed, 106 insertions, 1 deletions
diff --git a/media-tv/w_scan/ChangeLog b/media-tv/w_scan/ChangeLog
index 3bc55333eca2..802296a11459 100644
--- a/media-tv/w_scan/ChangeLog
+++ b/media-tv/w_scan/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-tv/w_scan
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/w_scan/ChangeLog,v 1.5 2008/04/02 14:38:55 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/w_scan/ChangeLog,v 1.6 2008/11/20 19:53:21 coldwind Exp $
+
+*w_scan-20081106 (20 Nov 2008)
+
+ 20 Nov 2008; Santiago M. Mola <coldwind@gentoo.org>
+ +files/w_scan-20081106-build-and-path-fixes.patch,
+ +w_scan-20081106.ebuild:
+ Version bump (bug #246787). Thanks to Richard Li <richardpku at gmail dot
+ com>.
*w_scan-20080105 (02 Apr 2008)
diff --git a/media-tv/w_scan/files/w_scan-20081106-build-and-path-fixes.patch b/media-tv/w_scan/files/w_scan-20081106-build-and-path-fixes.patch
new file mode 100644
index 000000000000..c23d12fa5fa8
--- /dev/null
+++ b/media-tv/w_scan/files/w_scan-20081106-build-and-path-fixes.patch
@@ -0,0 +1,68 @@
+* Honour CC, CFLAGS, LDFLAGS and DESTDIR.
+* Use absolute paths so it doesn't assume w_scan is ran from the build dir.
+--- w_scan-20081106.orig/Makefile 2008-11-06 08:49:01.000000000 -0600
++++ w_scan-20081106/Makefile 2008-11-07 18:24:20.812221779 -0600
+@@ -1,7 +1,7 @@
+
+-CC = gcc
+-CFLAGS = -MD -g -Wall -O2
+-LFLAGS = -g -Wall
++CC ?= gcc
++CFLAGS := -MD -g -Wall -O2 $(CFLAGS)
++LFLAGS := -g -Wall $(LDFLAGS)
+
+ OBJS = dump-vdr.o dump-xine.o dump-dvbscan.o dump-kaffeine.o scan.o section.o atsc_psip_section.o
+ SRCS = $(OBJS:.o=.c)
+@@ -10,6 +10,10 @@
+ VERSION = $(shell sed -n '/uint version/p' scan.c | sed -e 's/uint version = //' | sed -e 's/;//')
+ TMPDIR = w_scan-$(VERSION)
+
++BINDIR = /usr/bin
++SHAREDIR = /usr/share/w_scan
++DOCDIR = /usr/share/doc/w_scan
++
+ $(TARGET): $(OBJS)
+ $(CC) $(LFLAGS) -o $(TARGET) $(OBJS)
+ $(RM) *.o *.d
+@@ -17,13 +21,13 @@
+ $(CC) $(CFLAGS) --static -c $< -o $@
+
+ install:
+- install -m 755 $(TARGET) /usr/bin
+- install -m 755 w_scan_start.sh /usr/bin
+- mkdir -p /usr/share/w_scan
+- install pci.ids /usr/share/w_scan
+- install pci.classes /usr/share/w_scan
+- install usb.ids /usr/share/w_scan
+- install usb.classes /usr/share/w_scan
++ @mkdir -p $(DESTDIR)$(BINDIR) $(DESTDIR)$(SHAREDIR) $(DESTDIR)$(DOCDIR)
++ install -m 755 $(TARGET) $(DESTDIR)$(BINDIR)
++ install -m 755 w_scan_start.sh $(DESTDIR)$(BINDIR)
++ install pci.ids $(DESTDIR)$(SHAREDIR)
++ install pci.classes $(DESTDIR)$(SHAREDIR)
++ install usb.ids $(DESTDIR)$(SHAREDIR)
++ install usb.classes $(DESTDIR)$(SHAREDIR)
+
+ dist:
+ @-rm -rf $(TMPDIR)
+diff -ur w_scan-20081106.orig/w_scan_start.sh w_scan-20081106/w_scan_start.sh
+--- w_scan-20081106.orig/w_scan_start.sh 2008-11-06 09:01:07.000000000 -0600
++++ w_scan-20081106/w_scan_start.sh 2008-11-07 18:24:55.965058963 -0600
+@@ -34,7 +34,7 @@
+ #######################################################
+
+ umask 022
+-export PATH="$(pwd):/bin:/usr/bin:/sbin:/usr/sbin"
++export PATH="/usr/share/w_scan:/bin:/usr/bin:/sbin:/usr/sbin"
+ DATE="$(date +%Y)$(date +%m)$(date +%d)" # $DATE == "YYYYMMDD", i.e. 20060710
+ W_SCAN=$(which w_scan 2>/dev/null)
+ UDEVSTART=$(which udevstart)
+@@ -712,7 +712,7 @@
+ echo "Copying channels.conf skipped - okay."
+ echo "The channels.conf generated can be found at"
+ echo -n -e "\\033[1;34m"
+- echo "$(pwd)/channels.conf-$DATE"
++ echo "/usr/share/w_scan/channels.conf-$DATE"
+ echo ""
+ echo -e -n $NORMAL
+ else
diff --git a/media-tv/w_scan/w_scan-20081106.ebuild b/media-tv/w_scan/w_scan-20081106.ebuild
new file mode 100644
index 000000000000..108cdbc1d180
--- /dev/null
+++ b/media-tv/w_scan/w_scan-20081106.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/w_scan/w_scan-20081106.ebuild,v 1.1 2008/11/20 19:53:21 coldwind Exp $
+
+inherit eutils
+
+DESCRIPTION="Scan for DVB-C/DVB-T channels without prior knowledge of frequencies and modulations - can also create a file in vdr-format"
+HOMEPAGE="http://free.pages.at/wirbel4vdr/w_scan/index2.html"
+SRC_URI="http://wirbel.htpc-forum.de/w_scan/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-tv/linuxtv-dvb-headers"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-build-and-path-fixes.patch"
+ emake clean || die "emake clean failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc README
+}