summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2005-09-15 07:41:40 +0000
committerDoug Goldstein <cardoe@gentoo.org>2005-09-15 07:41:40 +0000
commit50e8939a9623fd586ac4b13554c806c90e3d1279 (patch)
tree9dfac5b3ee6037e800bbac975081bdcdb1d0e20d /media-tv
parentadded latest version for doxygen and bug #105041 (with ~sparc for added flavor) (diff)
downloadgentoo-2-50e8939a9623fd586ac4b13554c806c90e3d1279.tar.gz
gentoo-2-50e8939a9623fd586ac4b13554c806c90e3d1279.tar.bz2
gentoo-2-50e8939a9623fd586ac4b13554c806c90e3d1279.zip
Updated firmware to include 150/500 firmware. Switched to recommended 250/350 firmware. Include the ivtv's version of the tuner module along with several others and tell user to scrap the old ones
(Portage version: 2.0.52-r1)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/ivtv/ChangeLog10
-rw-r--r--media-tv/ivtv/files/digest-ivtv-0.3.83
-rw-r--r--media-tv/ivtv/ivtv-0.3.8.ebuild40
3 files changed, 41 insertions, 12 deletions
diff --git a/media-tv/ivtv/ChangeLog b/media-tv/ivtv/ChangeLog
index b5a3534f3954..b28aeac54783 100644
--- a/media-tv/ivtv/ChangeLog
+++ b/media-tv/ivtv/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-tv/ivtv
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.32 2005/09/15 06:34:40 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ChangeLog,v 1.33 2005/09/15 07:41:40 cardoe Exp $
+
+ 15 Sep 2005; Doug Goldstein <cardoe@gentoo.org> ivtv-0.3.8.ebuild:
+ Updated firmware to include 150/500 firmware. Switched to recommended
+ 250/350 firmware
+
+ 15 Sep 2005; Doug Goldstein <cardoe@gentoo.org> ivtv-0.3.8.ebuild:
+ We need to include the ivtv tuner module over the in-kernel module since
+ there's changes. Several other modules too
15 Sep 2005; Doug Goldstein <cardoe@gentoo.org> ivtv-0.3.8.ebuild:
Detect more modules that need to go to make everything happy
diff --git a/media-tv/ivtv/files/digest-ivtv-0.3.8 b/media-tv/ivtv/files/digest-ivtv-0.3.8
index 58023b1f8721..09ddcb6f4a6b 100644
--- a/media-tv/ivtv/files/digest-ivtv-0.3.8
+++ b/media-tv/ivtv/files/digest-ivtv-0.3.8
@@ -1,2 +1,3 @@
MD5 6b03f5253f70cb9e4e32c3de835708f3 ivtv-0.3.8.tar.gz 484009
-MD5 173c5ce2c0f16da42a5316ef7cee6834 pvr_1.18.21.22168_inf.zip 676578
+MD5 dff9c5cd9b50140c6bc3180f264557c7 pvr48wdm_1.8.22037.exe 2685760
+MD5 d425127e482adbf79c02f44c1409c507 mce_cd_v27a.zip 5433921
diff --git a/media-tv/ivtv/ivtv-0.3.8.ebuild b/media-tv/ivtv/ivtv-0.3.8.ebuild
index 4e8e346a3b8c..2f3c58c5aca5 100644
--- a/media-tv/ivtv/ivtv-0.3.8.ebuild
+++ b/media-tv/ivtv/ivtv-0.3.8.ebuild
@@ -1,16 +1,20 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.3.8.ebuild,v 1.2 2005/09/15 06:34:40 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv/ivtv-0.3.8.ebuild,v 1.3 2005/09/15 07:41:40 cardoe Exp $
inherit eutils linux-mod
DESCRIPTION="ivtv driver for Hauppauge PVR PCI cards"
HOMEPAGE="http://www.ivtvdriver.org"
-FW_VER="pvr_1.18.21.22168_inf.zip"
+#FW_VER="pvr_1.18.21.22168_inf.zip" ftp://ftp.shspvr.com/download/wintv-pvr_250-350/inf/${FW_VER}
+FW_VER_150="mce_cd_v27a.zip"
+FW_VER="pvr48wdm_1.8.22037.exe"
+#Switched to recommended firmware by driver
SRC_URI="http://dl.ivtvdriver.org/${PN}/${P}.tar.gz
- ftp://ftp.shspvr.com/download/wintv-pvr_250-350/inf/${FW_VER}"
+ ftp://ftp.shspvr.com/download/wintv-pvr_250-350/win9x-2k-xp_mpeg_wdm_drv/${FW_VER}
+ http://hauppauge.lightpath.net/software/mce/${FW_VER_150}"
RESTRICT="nomirror"
SLOT="0"
@@ -22,7 +26,7 @@ S="${WORKDIR}/${P}"
BUILD_TARGETS="all"
BUILD_PARAMS="KDIR=${KERNEL_DIR}"
-CONFIG_CHECK="I2C_ALGOBIT VIDEO_DEV"
+CONFIG_CHECK="I2C_ALGOBIT VIDEO_DEV I2C_CHARDEV I2C"
DEPEND="app-arch/unzip"
@@ -33,12 +37,16 @@ pkg_setup() {
saa7115(extra:${S}/driver)
tveeprom(extra:${S}/driver)
saa7127(extra:${S}/driver)
- cx25840(extra:${S}/driver)"
+ cx25840(extra:${S}/driver)
+ tuner(extra:${S}/driver)
+ wm8775(extra:${S}/driver)
+ tda9887(extra:${S}/driver)"
linux_chkconfig_present FB && MODULE_NAMES="${MODULE_NAMES}"
}
src_unpack() {
unpack ${P}.tar.gz
+ unpack ${FW_VER_150}
sed -e "s:^VERS26=.*:VERS26=${KV_MAJOR}.${KV_MINOR}:g" \
-i ${S}/driver/Makefile || die "sed failed"
@@ -62,9 +70,13 @@ src_install() {
cd ${S}/utils
dodir /lib/modules
./ivtvfwextract.pl ${DISTDIR}/${FW_VER} \
- ${D}/lib/modules/ivtv-fw-enc.bin \
+ ${D}/lib/modules/ivtv-fw-enc-250-350.bin \
${D}/lib/modules/ivtv-fw-dec.bin
+ insinto /lib/modules
+ newins ${WORKDIR}/WinTV-PVR-150500MCE_2_0_30_23074_WHQL/HcwFalcn.rom HcwFalcn.rom
+ newins ${WORKDIR}/WinTV-PVR-150500MCE_2_0_30_23074_WHQL/HcwMakoA.ROM HcwMakoA.ROM
+
cd ${S}
dodoc README doc/*
cd ${S}/utils
@@ -103,11 +115,8 @@ pkg_postinst() {
# einfo "To use vbi, you'll need a few other things, check README.vbi in the docs dir"
# echo
- einfo "The ptune* scripts have moved to media-tv/ivtv-ptune, emerge that to use those scripts"
- echo
-
# Similar checks are performed by the make install in the drivers directory.
- BADMODS="msp3400 tda9887 tuner tveeprom saa7115 saa7127"
+ BADMODS="msp3400 tda9887 tuner tveeprom saa7115 saa7127 cx25840 wm8775"
for MODNAME in ${BADMODS}; do
if [ -f "${ROOT}/lib/modules/${KV_FULL}/kernel/drivers/media/video/${MODNAME}.ko" ] ; then
@@ -117,4 +126,15 @@ pkg_postinst() {
echo
fi
done
+
+ echo
+ ewarn
+ ewarn
+ ewarn "PVR-250/350 users need to run the following command to setup the firmware:"
+ ewarn "ln -sf /lib/modules/ivtv-fw-enc-250-350.bin /lib/modules/ivtv-fw-enc.bin"
+ ewarn
+ ewarn "PVR-150/500 users need to run the following command to setup the firmware:"
+ ewarn "ln -sf /lib/modules/HcwFalcn.rom /lib/modules/ivtv/fw-enc.bin"
+ ewarn
+ echo
}