summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2009-11-11 20:09:39 +0000
committerDoug Goldstein <cardoe@gentoo.org>2009-11-11 20:09:39 +0000
commit5d84eacaec8ee7944d340b07dafc6fb744e7f0ce (patch)
tree673a57237ab5a69d091079f55ce639fc46f8f73d /media-tv/mythtv
parentStable for ppc. (diff)
downloadgentoo-2-5d84eacaec8ee7944d340b07dafc6fb744e7f0ce.tar.gz
gentoo-2-5d84eacaec8ee7944d340b07dafc6fb744e7f0ce.tar.bz2
gentoo-2-5d84eacaec8ee7944d340b07dafc6fb744e7f0ce.zip
unset CFLAGS and CXXFLAGS for bug #279944
(Portage version: 2.1.7.4/cvs/Linux x86_64)
Diffstat (limited to 'media-tv/mythtv')
-rw-r--r--media-tv/mythtv/ChangeLog5
-rw-r--r--media-tv/mythtv/mythtv-0.22_p22778.ebuild12
2 files changed, 10 insertions, 7 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index 511d5f3202d7..4af483f1627d 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-tv/mythtv
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.292 2009/11/10 15:25:48 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.293 2009/11/11 20:09:39 cardoe Exp $
+
+ 11 Nov 2009; Doug Goldstein <cardoe@gentoo.org> mythtv-0.22_p22778.ebuild:
+ unset CFLAGS and CXXFLAGS for bug #279944
10 Nov 2009; Doug Goldstein <cardoe@gentoo.org> mythtv-0.22_p22778.ebuild:
fix bug #292481
diff --git a/media-tv/mythtv/mythtv-0.22_p22778.ebuild b/media-tv/mythtv/mythtv-0.22_p22778.ebuild
index c0994e861fcb..1ed531a89cc9 100644
--- a/media-tv/mythtv/mythtv-0.22_p22778.ebuild
+++ b/media-tv/mythtv/mythtv-0.22_p22778.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.22_p22778.ebuild,v 1.3 2009/11/10 15:25:48 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.22_p22778.ebuild,v 1.4 2009/11/11 20:09:39 cardoe Exp $
EAPI=2
inherit flag-o-matic multilib eutils qt4 mythtv toolchain-funcs python
@@ -148,9 +148,9 @@ src_configure() {
## CFLAG cleaning so it compiles
MARCH=$(get-flag "march")
MTUNE=$(get-flag "mtune")
- strip-flags
- filter-flags "-march=*" "-mtune=*" "-mcpu=*"
- filter-flags "-O" "-O?"
+ #strip-flags
+ #filter-flags "-march=*" "-mtune=*" "-mcpu=*"
+ #filter-flags "-O" "-O?"
if [[ -n "${MARCH}" ]]; then
myconf="${myconf} --cpu=${MARCH}"
@@ -164,8 +164,8 @@ src_configure() {
hasq ccache ${FEATURES} || myconf="${myconf} --disable-ccache"
# let MythTV come up with our CFLAGS. Upstream will support this
- #CFLAGS=""
- #CXXFLAGS=""
+ unset CFLAGS
+ unset CXXFLAGS
einfo "Running ./configure ${myconf}"
sh ./configure ${myconf} || die "configure died"
}