summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-13 15:20:12 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-13 15:20:12 +0000
commit86ef90ca2dde3bb6e7f1949e4016ef7022aff04a (patch)
treeb24fe2361d80f3272445388787790e4944afdd32 /media-tv/livestation/livestation-3.2.0.ebuild
parentold (diff)
downloadgentoo-2-86ef90ca2dde3bb6e7f1949e4016ef7022aff04a.tar.gz
gentoo-2-86ef90ca2dde3bb6e7f1949e4016ef7022aff04a.tar.bz2
gentoo-2-86ef90ca2dde3bb6e7f1949e4016ef7022aff04a.zip
Version bump.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'media-tv/livestation/livestation-3.2.0.ebuild')
-rw-r--r--media-tv/livestation/livestation-3.2.0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/media-tv/livestation/livestation-3.2.0.ebuild b/media-tv/livestation/livestation-3.2.0.ebuild
new file mode 100644
index 000000000000..e6256cc9b9d4
--- /dev/null
+++ b/media-tv/livestation/livestation-3.2.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/livestation/livestation-3.2.0.ebuild,v 1.1 2011/03/13 15:20:11 ssuominen Exp $
+
+inherit eutils
+
+DESCRIPTION="Watch live, interactive TV and radio on the Livestation player"
+HOMEPAGE="http://www.livestation.com"
+SRC_URI="http://updates.${PN}.com/releases/${P/l/L}-i386.run"
+
+LICENSE="GPL-3 LGPL-3 Livestation-EULA"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+EMUL_VER=20110101
+
+RDEPEND="amd64? ( >=app-emulation/emul-linux-x86-baselibs-${EMUL_VER}
+ >=app-emulation/emul-linux-x86-xlibs-${EMUL_VER} )"
+DEPEND=""
+
+MY_PN=${PN/l/L}
+
+QA_TEXTRELS="opt/${MY_PN}/lib/*"
+QA_DT_HASH="opt/${MY_PN}/${MY_PN}.bin opt/${MY_PN}/lib/.* opt/${MY_PN}/plugins/imageformats/.*"
+QA_PRESTRIPPED="opt/${MY_PN}/${MY_PN}.bin opt/${MY_PN}/lib/.* opt/${MY_PN}/plugins/imageformats/.*"
+
+RESTRICT="mirror"
+PROPERTIES="interactive"
+
+S=${WORKDIR}/i386
+
+pkg_setup() {
+ check_license Livestation-EULA
+}
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ local dest=/opt/${MY_PN}
+
+ dodir ${dest}
+ cp -dpR *.{bin,conf} plugins "${D}"/${dest} || die
+ rm -f lib/{libcrypto.so.0.9.8,libssl.so.0.9.8,libXtst.so.6} || die
+ exeinto ${dest}/lib
+ doexe lib/* || die
+ dosym plugins/imageformats ${dest}/imageformats || die
+ dodoc README
+
+ newicon "${FILESDIR}"/${PN}_icon.svg ${PN}.svg
+ make_wrapper ${PN} ./${MY_PN}.bin ${dest} ${dest}/lib
+ make_desktop_entry ${PN} ${MY_PN} ${PN}
+}