summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2005-10-07 16:08:11 +0000
committerDoug Goldstein <cardoe@gentoo.org>2005-10-07 16:08:11 +0000
commitb618a73b46b04cb6af5fb3874abf6daa273bddef (patch)
treeef6836c8817054ff3efc37d65f7fd58ace052c9f /media-tv/ivtv/files
parentdont install INSTALL (diff)
downloadgentoo-2-b618a73b46b04cb6af5fb3874abf6daa273bddef.tar.gz
gentoo-2-b618a73b46b04cb6af5fb3874abf6daa273bddef.tar.bz2
gentoo-2-b618a73b46b04cb6af5fb3874abf6daa273bddef.zip
Updates to patches for PPC
(Portage version: 2.0.53_rc3)
Diffstat (limited to 'media-tv/ivtv/files')
-rw-r--r--media-tv/ivtv/files/ivtv-0.3.8-devname.patch38
-rw-r--r--media-tv/ivtv/files/ppc-odw.patch62
2 files changed, 26 insertions, 74 deletions
diff --git a/media-tv/ivtv/files/ivtv-0.3.8-devname.patch b/media-tv/ivtv/files/ivtv-0.3.8-devname.patch
index ea67dc3f6315..2493a1ba948e 100644
--- a/media-tv/ivtv/files/ivtv-0.3.8-devname.patch
+++ b/media-tv/ivtv/files/ivtv-0.3.8-devname.patch
@@ -1,26 +1,22 @@
-Index: driver/tda9887.c
-===================================================================
---- driver/tda9887.c (revision 2702)
-+++ driver/tda9887.c (working copy)
-@@ -856,7 +856,7 @@
+--- driver/tuner.c 2005-10-07 11:52:14.000000000 -0400
++++ driver/tuner.c.new 2005-10-07 11:53:30.000000000 -0400
+@@ -1832,7 +1832,7 @@
+ .command = tuner_command,
+ };
+ static struct i2c_client client_template = {
+- I2C_DEVNAME("(tuner unset)"),
++ .name = "(tuner unset)",
+ .flags = I2C_CLIENT_ALLOW_USE,
+ .driver = &driver,
+ };
+--- driver/tda9887.c 2005-10-07 11:52:14.000000000 -0400
++++ driver/tda9887.c.new 2005-10-07 11:52:58.000000000 -0400
+@@ -851,7 +851,7 @@
};
static struct i2c_client client_template =
{
-- I2C_DEVNAME("tda9887"),
-+ .name = "tda9887",
- .flags = I2C_CLIENT_ALLOW_USE,
+- I2C_DEVNAME("tda9887"),
++ .name = "tda9887",
+ .flags = I2C_CLIENT_ALLOW_USE,
.driver = &driver,
};
-Index: driver/tuner.c
-===================================================================
---- driver/tuner.c (revision 2702)
-+++ driver/tuner.c (working copy)
-@@ -1854,7 +1854,7 @@
- .command = tuner_command,
- };
- static struct i2c_client client_template = {
-- I2C_DEVNAME("(tuner unset)"),
-+ .name = "tuner unset",
- .flags = I2C_CLIENT_ALLOW_USE,
- .driver = &driver,
- };
diff --git a/media-tv/ivtv/files/ppc-odw.patch b/media-tv/ivtv/files/ppc-odw.patch
index 1bd528f67616..a423e99d2594 100644
--- a/media-tv/ivtv/files/ppc-odw.patch
+++ b/media-tv/ivtv/files/ppc-odw.patch
@@ -1,62 +1,18 @@
-diff -urN ivtv-0.3.7-orig/ChangeLog ivtv-0.3.7/ChangeLog
---- ivtv-0.3.7-orig/ChangeLog 2005-07-28 07:53:14.003679936 +0000
-+++ ivtv-0.3.7/ChangeLog 2005-07-28 07:57:25.672420472 +0000
-@@ -1,5 +1,9 @@
- IVTV changes:
-
-+#0.3.7 - PowerPC patches - Pieter Van den Abeele <pvdabeel@gentoo.org>
-+ - disables building of x86 asm utils
-+ - force disable DMA, force enable PIO
-+
- #0.3.7 - YUV decoder patches.
- - powerdown soundchip on cx25840 when not in use.
- - i2c index improvements for cx25840 module.
-diff -urN ivtv-0.3.7-orig/driver/ivtv-driver.h ivtv-0.3.7/driver/ivtv-driver.h
---- ivtv-0.3.7-orig/driver/ivtv-driver.h 2005-07-28 07:53:13.978683736 +0000
-+++ ivtv-0.3.7/driver/ivtv-driver.h 2005-07-28 07:53:42.342371800 +0000
-@@ -202,7 +202,7 @@
- /* ========================== START USER SETTABLE DMA VARIABLES =========== */
- /* ======================================================================== */
-
--#define DYNAMIC_MEMORY_ALLOC 1 /* Allocate memory each stream use */
-+#define DYNAMIC_MEMORY_ALLOC 0 /* Allocate memory each stream use */
-
- /* DMA Buffers Sizes */
- #define IVTV_DMA_ENC_BUF_SIZE 0x00008000
-@@ -230,9 +230,9 @@
- #define IVTV_DMA_SG_OSD_ENT (2883584/PAGE_SIZE) /* sg entities */
-
- /* Decoder DMA or PIO, 1=PIO, 0=DMA */
--#define IVTV_VBI_PIO 0
--#define IVTV_ENC_PIO 0
--#define IVTV_DEC_PIO 0
-+#define IVTV_VBI_PIO 1
-+#define IVTV_ENC_PIO 1
-+#define IVTV_DEC_PIO 1
- /* This sometimes times out, seems to kill
- encoding sometimes */
-
-diff -urN ivtv-0.3.7-orig/utils/Makefile ivtv-0.3.7/utils/Makefile
---- ivtv-0.3.7-orig/utils/Makefile 2005-07-28 07:53:14.552596488 +0000
-+++ ivtv-0.3.7/utils/Makefile 2005-07-28 07:55:39.443569712 +0000
-@@ -1,8 +1,8 @@
--INSTALLDIR = /usr/local/bin
-+INSTALLDIR = /usr/bin
+--- utils/Makefile 2005-09-11 05:22:17.000000000 -0400
++++ utils/Makefile.new 2005-10-07 11:59:38.000000000 -0400
+@@ -1,12 +1,12 @@
+ INSTALLDIR = /usr/local/bin
HEADERDIR = /usr/include/linux
--SANEEXES = ivtvctl ivtvfbctl ivtvplay cx25840ctl
--INSANEEXES = mpegindex radio vbi fwapi encoder wss vbi_passthrough test_ioctl
-+SANEEXES = ivtvctl cx25840ctl
-+INSANEEXES = radio vbi fwapi wss vbi_passthrough test_ioctl
+-SANEEXES = ivtvctl ivtvfbctl ivtvplay cx25840ctl ivtv-detect ivtv-radio
+-INSANEEXES = mpegindex encoder
++SANEEXES = ivtvctl cx25840ctl ivtv-detect ivtv-radio
++INSANEEXES =
EXES = $(SANEEXES) $(INSANEEXES)
INSTALL_HEADERS = ../driver/ivtv.h
-@@ -10,7 +10,7 @@
- LIB_ZVBI_SRC = /home/src/zvbi/zvbi-0.2.15/src/.libs
- INC_ZVBI_SRC = /home/src/zvbi/zvbi-0.2.15/src
-
-CFLAGS = -I../driver -D_GNU_SOURCE -O2 -Wall
+CFLAGS = -I../driver -D_GNU_SOURCE -O2 -Wall -fsigned-char
CXXFLAGS = $(CFLAGS)
- LDFLAGS = -lm
+ all: $(EXES)