summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-03-12 18:27:33 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-03-12 18:27:33 +0000
commitc904adde63ca2596aa110a9115d49b26e4e9c140 (patch)
treefabf45b8d17a61b0c27026152d6871f2c5c2fe92 /media-tv/freevo
parentVersion bump for bug fixes. See (diff)
downloadgentoo-2-c904adde63ca2596aa110a9115d49b26e4e9c140.tar.gz
gentoo-2-c904adde63ca2596aa110a9115d49b26e4e9c140.tar.bz2
gentoo-2-c904adde63ca2596aa110a9115d49b26e4e9c140.zip
fix program start when eselect points to python3
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'media-tv/freevo')
-rw-r--r--media-tv/freevo/ChangeLog6
-rw-r--r--media-tv/freevo/files/freevo-1.9.0-distutils-r1.patch20
-rw-r--r--media-tv/freevo/freevo-1.9.0-r1.ebuild12
3 files changed, 35 insertions, 3 deletions
diff --git a/media-tv/freevo/ChangeLog b/media-tv/freevo/ChangeLog
index d7c2899aa443..8574ab8dced0 100644
--- a/media-tv/freevo/ChangeLog
+++ b/media-tv/freevo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-tv/freevo
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/freevo/ChangeLog,v 1.83 2014/03/12 18:17:08 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/freevo/ChangeLog,v 1.84 2014/03/12 18:27:33 hasufell Exp $
+
+ 12 Mar 2014; Julian Ospald <hasufell@gentoo.org> freevo-1.9.0-r1.ebuild,
+ +files/freevo-1.9.0-distutils-r1.patch:
+ fix program start when eselect points to python3
*freevo-1.9.0-r1 (12 Mar 2014)
diff --git a/media-tv/freevo/files/freevo-1.9.0-distutils-r1.patch b/media-tv/freevo/files/freevo-1.9.0-distutils-r1.patch
new file mode 100644
index 000000000000..1494d2f2080b
--- /dev/null
+++ b/media-tv/freevo/files/freevo-1.9.0-distutils-r1.patch
@@ -0,0 +1,20 @@
+--- a/freevo-1.9.0/freevo
++++ b/freevo-1.9.0/freevo
+@@ -178,15 +178,8 @@
+ get the newest version of python [ with freevo installed ]
+ """
+ _debug_('version=%r' % (sys.version))
+- if sys.hexversion >= 0x02040000:
+- # python seems to be ok
+- search = ('python', 'python2')
+- elif sys.hexversion >= 0x02030000:
+- # try python2.4, else take python
+- search = ('python2.4', 'python')
+- else:
+- # python is too old, try to find python2.4 or python2
+- search = ('python2.4', 'python2')
++
++ search = ('@EPYTHON@', 'python')
+
+ for python in search:
+ for path in os.environ['PATH'].split(':'):
diff --git a/media-tv/freevo/freevo-1.9.0-r1.ebuild b/media-tv/freevo/freevo-1.9.0-r1.ebuild
index c2fbe7950a8e..b50c084eebb7 100644
--- a/media-tv/freevo/freevo-1.9.0-r1.ebuild
+++ b/media-tv/freevo/freevo-1.9.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/freevo/freevo-1.9.0-r1.ebuild,v 1.1 2014/03/12 18:17:09 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/freevo/freevo-1.9.0-r1.ebuild,v 1.2 2014/03/12 18:27:33 hasufell Exp $
EAPI=5
@@ -53,7 +53,7 @@ RDEPEND="dev-python/beautifulsoup:python-2[${PYTHON_USEDEP}]
xine? ( media-video/xine-ui )
vorbis? ( media-sound/vorbis-tools )"
-PATCHES=( "${FILESDIR}"/${P}-PIL.patch )
+PATCHES=( "${FILESDIR}"/${P}-{PIL,distutils-r1}.patch )
pkg_setup() {
if ! { use X || use directfb || use fbcon || use matrox ; } ; then
@@ -67,6 +67,14 @@ pkg_setup() {
python-single-r1_pkg_setup
}
+src_prepare() {
+ distutils-r1_src_prepare
+
+ sed -i \
+ -e "s/@EPYTHON@/${EPYTHON}/" \
+ freevo || die
+}
+
src_install() {
distutils-r1_src_install