summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2006-10-31 16:12:11 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2006-10-31 16:12:11 +0000
commitc4d1acaaebc03c11538c3fb7efc97160e855d6c0 (patch)
treee94f26c8a390103d272501980c271180cdf8d4b5 /media-sound
parenttweak the grep line so we only install .schemas files and not just everything... (diff)
downloadgentoo-2-c4d1acaaebc03c11538c3fb7efc97160e855d6c0.tar.gz
gentoo-2-c4d1acaaebc03c11538c3fb7efc97160e855d6c0.tar.bz2
gentoo-2-c4d1acaaebc03c11538c3fb7efc97160e855d6c0.zip
Version bumped. Fixed 147980.
(Portage version: 2.1.1-r1)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audacity/ChangeLog10
-rw-r--r--media-sound/audacity/audacity-1.3.0b.ebuild4
-rw-r--r--media-sound/audacity/audacity-1.3.2.ebuild76
-rw-r--r--media-sound/audacity/files/audacity-1.3.2-gentoo.patch54
-rw-r--r--media-sound/audacity/files/digest-audacity-1.3.23
5 files changed, 144 insertions, 3 deletions
diff --git a/media-sound/audacity/ChangeLog b/media-sound/audacity/ChangeLog
index 4188ae1abaa5..711bad477b77 100644
--- a/media-sound/audacity/ChangeLog
+++ b/media-sound/audacity/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/audacity
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.48 2006/09/06 14:33:04 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/ChangeLog,v 1.49 2006/10/31 16:12:11 matsuu Exp $
+
+*audacity-1.3.2 (31 Oct 2006)
+
+ 31 Oct 2006; MATSUU Takuto <matsuu@gentoo.org>
+ +files/audacity-1.3.2-gentoo.patch, audacity-1.3.0b.ebuild,
+ +audacity-1.3.2.ebuild:
+ Version bumped.
+ Fixed locales issue, bug #147980.
06 Sep 2006; Joseph Jezak <josejx@gentoo.org> audacity-1.3.0b.ebuild:
Marked ppc stable for bug #145033.
diff --git a/media-sound/audacity/audacity-1.3.0b.ebuild b/media-sound/audacity/audacity-1.3.0b.ebuild
index 96f9788f6b2a..99b6af290343 100644
--- a/media-sound/audacity/audacity-1.3.0b.ebuild
+++ b/media-sound/audacity/audacity-1.3.0b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.3.0b.ebuild,v 1.6 2006/09/06 14:33:04 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.3.0b.ebuild,v 1.7 2006/10/31 16:12:11 matsuu Exp $
inherit wxwidgets eutils
@@ -55,7 +55,7 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die
+ make DESTDIR="${D}" INSTALL_PATH="${D}" install || die
# Remove bad doc install
rm -rf ${D}/usr/share/doc
diff --git a/media-sound/audacity/audacity-1.3.2.ebuild b/media-sound/audacity/audacity-1.3.2.ebuild
new file mode 100644
index 000000000000..8d5f51fd04d0
--- /dev/null
+++ b/media-sound/audacity/audacity-1.3.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacity/audacity-1.3.2.ebuild,v 1.1 2006/10/31 16:12:11 matsuu Exp $
+
+inherit eutils
+
+IUSE="flac ladspa libsamplerate mp3 unicode vorbis"
+
+MY_P="${PN}-src-${PV}"
+DESCRIPTION="Free crossplatform audio editor"
+HOMEPAGE="http://audacity.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+RESTRICT="test"
+
+DEPEND=">=x11-libs/wxGTK-2.6
+ >=app-arch/zip-2.3
+ dev-libs/expat
+ vorbis? ( >=media-libs/libvorbis-1.0 )
+ mp3? ( >=media-libs/libmad-0.14.2b
+ media-libs/libid3tag )
+ flac? ( media-libs/flac )
+ >=media-libs/libsndfile-1.0.0
+ libsamplerate? ( >=media-libs/libsamplerate-0.1.2 )"
+RDEPEND="${DEPEND}
+ mp3? ( >=media-sound/lame-3.70 )"
+
+S="${WORKDIR}/${MY_P}-beta"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} --with-libsndfile=system"
+ myconf="${myconf} --with-libexpat=system"
+
+ if use libsamplerate ; then
+ myconf="${myconf} --with-libsamplerate=system --without-libresample"
+ else
+ myconf="${myconf} --without-libsamplerate" # --with-libresample=local
+ fi
+
+ econf \
+ $(use_enable unicode) \
+ $(use_with ladspa) \
+ $(use_with vorbis vorbis system) \
+ $(use_with mp3 libmad system) \
+ $(use_with mp3 id3tag system) \
+ $(use_with flac flac system) \
+ ${myconf} || die
+
+ # parallel borks
+ emake -j1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # Remove bad doc install
+ rm -rf "${D}"/usr/share/doc
+
+ # Install our docs
+ dodoc README.txt
+
+ insinto /usr/share/audacity/
+ newins images/AudacityLogo48x48.xpm audacity.xpm
+}
diff --git a/media-sound/audacity/files/audacity-1.3.2-gentoo.patch b/media-sound/audacity/files/audacity-1.3.2-gentoo.patch
new file mode 100644
index 000000000000..7ae4589fbc69
--- /dev/null
+++ b/media-sound/audacity/files/audacity-1.3.2-gentoo.patch
@@ -0,0 +1,54 @@
+diff -Naur audacity-src-1.3.2-beta.orig/configure audacity-src-1.3.2-beta/configure
+--- audacity-src-1.3.2-beta.orig/configure 2006-10-29 08:05:36.000000000 +0900
++++ audacity-src-1.3.2-beta/configure 2006-10-31 16:12:48.000000000 +0900
+@@ -7027,8 +7027,8 @@
+ fi
+
+
+-# Extract the first word of "wx-config", so it can be a program name with args.
+-set dummy wx-config; ac_word=$2
++# Extract the first word of "wx-config-2.6", so it can be a program name with args.
++set dummy wx-config-2.6; ac_word=$2
+ { echo "$as_me:$LINENO: checking for $ac_word" >&5
+ echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
+ if test "${ac_cv_path_WX_CONFIG+set}" = set; then
+@@ -7070,8 +7070,8 @@
+
+
+ if [ "$WX_CONFIG" = "no" ] ; then
+- { { echo "$as_me:$LINENO: error: \"Could not find wx-config: is wxWindows installed? is wx-config in your path?\"" >&5
+-echo "$as_me: error: \"Could not find wx-config: is wxWindows installed? is wx-config in your path?\"" >&2;}
++ { { echo "$as_me:$LINENO: error: \"Could not find wx-config-2.6: is wxWindows installed? is wx-config-2.6 in your path?\"" >&5
++echo "$as_me: error: \"Could not find wx-config-2.6: is wxWindows installed? is wx-config-2.6 in your path?\"" >&2;}
+ { (exit 1); exit 1; }; }
+ fi
+
+diff -Naur audacity-src-1.3.2-beta.orig/configure.in audacity-src-1.3.2-beta/configure.in
+--- audacity-src-1.3.2-beta.orig/configure.in 2006-10-29 08:06:01.000000000 +0900
++++ audacity-src-1.3.2-beta/configure.in 2006-10-31 16:12:21.000000000 +0900
+@@ -310,10 +310,10 @@
+
+ dnl --- check for required libraries ---
+
+-dnl wxWindows -- we assume that if wx-config is found, wxWindows is successfully installed.
+-AC_PATH_PROG(WX_CONFIG, wx-config, no, $PATH:/usr/local/bin )
++dnl wxWindows -- we assume that if wx-config-2.6 is found, wxWindows is successfully installed.
++AC_PATH_PROG(WX_CONFIG, wx-config-2.6, no, $PATH:/usr/local/bin )
+ if [[ "$WX_CONFIG" = "no" ]] ; then
+- AC_MSG_ERROR("Could not find wx-config: is wxWindows installed? is wx-config in your path?")
++ AC_MSG_ERROR("Could not find wx-config-2.6: is wxWindows installed? is wx-config-2.6 in your path?")
+ fi
+
+ dnl Check that the wx version is 2.6.x
+diff -Naur audacity-src-1.3.2-beta.orig/locale/Makefile.in audacity-src-1.3.2-beta/locale/Makefile.in
+--- audacity-src-1.3.2-beta.orig/locale/Makefile.in 2006-10-29 08:06:04.000000000 +0900
++++ audacity-src-1.3.2-beta/locale/Makefile.in 2006-11-01 00:06:00.000000000 +0900
+@@ -17,7 +17,7 @@
+ INSTALL=@INSTALL@
+ AUDACITY_NAME=@AUDACITY_NAME@
+ ifdef DESTDIR
+- INSTALL_PATH=$(top_srcdir)/$(DESTDIR)
++ INSTALL_PATH=$(DESTDIR)
+ else
+ INSTALL_PATH=
+ endif
diff --git a/media-sound/audacity/files/digest-audacity-1.3.2 b/media-sound/audacity/files/digest-audacity-1.3.2
new file mode 100644
index 000000000000..760a330b81a9
--- /dev/null
+++ b/media-sound/audacity/files/digest-audacity-1.3.2
@@ -0,0 +1,3 @@
+MD5 bf63673140254f1283dfd55b61ff2422 audacity-src-1.3.2.tar.gz 6683449
+RMD160 b61747103675881bdf32762deea7635a2827b0de audacity-src-1.3.2.tar.gz 6683449
+SHA256 aa37c00014ee79516fb5dce4c56e1038a7eaf5ad22a10743f0609ed186baf621 audacity-src-1.3.2.tar.gz 6683449