summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-12-20 03:38:42 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-12-20 03:38:42 +0000
commit9aecedf1428188a93d04b2e5dab3c348c2529c22 (patch)
treef41ab6194295900de0ef096f23b074846cf6140d /media-sound
parenthonour CC,CFLAGS,LDFLAGS, bug #240834, dont prestrip files, add a die to dobi... (diff)
downloadgentoo-2-9aecedf1428188a93d04b2e5dab3c348c2529c22.tar.gz
gentoo-2-9aecedf1428188a93d04b2e5dab3c348c2529c22.tar.bz2
gentoo-2-9aecedf1428188a93d04b2e5dab3c348c2529c22.zip
Honour CC and LDLFAGS; dont prestrip files, bug #239890, remove unused sed dep, dodoc the changelog too
(Portage version: 2.2_rc17/cvs/Linux 2.6.27.10 x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/rexima/ChangeLog8
-rw-r--r--media-sound/rexima/rexima-1.4.ebuild26
2 files changed, 19 insertions, 15 deletions
diff --git a/media-sound/rexima/ChangeLog b/media-sound/rexima/ChangeLog
index 5c7a8f6f29a3..11f262ad5d3b 100644
--- a/media-sound/rexima/ChangeLog
+++ b/media-sound/rexima/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/rexima
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rexima/ChangeLog,v 1.12 2007/02/03 20:12:29 flameeyes Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rexima/ChangeLog,v 1.13 2008/12/20 03:38:42 aballier Exp $
+
+ 20 Dec 2008; Alexis Ballier <aballier@gentoo.org> rexima-1.4.ebuild:
+ Honour CC and LDLFAGS; dont prestrip files, bug #239890, remove unused sed
+ dep, dodoc the changelog too
03 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/media-sound/rexima/rexima-1.4.ebuild b/media-sound/rexima/rexima-1.4.ebuild
index 9b8fdec89f30..750fa2c98658 100644
--- a/media-sound/rexima/rexima-1.4.ebuild
+++ b/media-sound/rexima/rexima-1.4.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rexima/rexima-1.4.ebuild,v 1.13 2004/12/19 06:23:54 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rexima/rexima-1.4.ebuild,v 1.14 2008/12/20 03:38:42 aballier Exp $
-IUSE=""
+
+inherit toolchain-funcs
DESCRIPTION="A curses-based interactive mixer which can also be used from the command-line."
HOMEPAGE="http://rus.members.beeb.net/rexima.html"
@@ -11,21 +12,20 @@ SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/apps/sound/mixers/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
RDEPEND="sys-libs/ncurses"
-
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
+DEPEND="${RDEPEND}"
src_compile() {
- emake CFLAGS="${CFLAGS}" || die "emake failed"
+ tc-export CC
+ echo "LDLIBS=-lncurses" > Makefile
+ echo "all: rexima" >> Makefile
+ emake || die "emake failed"
}
src_install () {
- make \
- PREFIX="${D}/usr" \
- BINDIR="${D}/usr/bin" \
- MANDIR="${D}/usr/share/man" \
- install || die "make install failed"
- dodoc NEWS README
+ dobin rexima || die
+ doman rexima.1 || die
+ dodoc NEWS README ChangeLog
}