summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-04-19 15:45:54 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-04-19 15:45:54 +0000
commit972d86465b82354d1824bc54a9c8d44db0cdde92 (patch)
tree0cc85581bd272431bfec232762ca82994e7638f5 /media-sound
parentForce RUBY_TARGETS=ruby18 for dev-ruby/rubygems with USE=ruby (diff)
downloadgentoo-2-972d86465b82354d1824bc54a9c8d44db0cdde92.tar.gz
gentoo-2-972d86465b82354d1824bc54a9c8d44db0cdde92.tar.bz2
gentoo-2-972d86465b82354d1824bc54a9c8d44db0cdde92.zip
Remove alsaconf utility; doesn't work with depmod from sys-apps/kmod because it doesn't generate "modules.pcimap" and "modules.usbmap" files anymore like sys-apps/module-init-tools used to wrt #456214
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/alsa-utils/ChangeLog10
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.26-r3.ebuild75
2 files changed, 84 insertions, 1 deletions
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index 916d02697e56..cdc6e76c13fc 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.342 2013/04/12 17:27:48 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.343 2013/04/19 15:45:54 ssuominen Exp $
+
+*alsa-utils-1.0.26-r3 (19 Apr 2013)
+
+ 19 Apr 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +alsa-utils-1.0.26-r3.ebuild:
+ Remove alsaconf utility; doesn't work with depmod from sys-apps/kmod because
+ it doesn't generate "modules.pcimap" and "modules.usbmap" files anymore like
+ sys-apps/module-init-tools used to wrt #456214
12 Apr 2013; Agostino Sarubbo <ago@gentoo.org> alsa-utils-1.0.26-r2.ebuild:
Stable for ia64, wrt bug #463451
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.26-r3.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.26-r3.ebuild
new file mode 100644
index 000000000000..179df22cc234
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.26-r3.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.26-r3.ebuild,v 1.1 2013/04/19 15:45:54 ssuominen Exp $
+
+EAPI=5
+inherit eutils systemd udev
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${P}.tar.bz2
+ mirror://alsaproject/driver/alsa-driver-1.0.25.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc +libsamplerate +ncurses nls selinux"
+
+RDEPEND=">=media-libs/alsa-lib-${PV}
+ libsamplerate? ( media-libs/libsamplerate )
+ ncurses? ( >=sys-libs/ncurses-5.7-r7 )
+ selinux? ( sec-policy/selinux-alsa )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-text/xmlto )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.0.23-modprobe.d.patch \
+ "${FILESDIR}"/${PN}-1.0.25-separate-usr-var-fs.patch
+}
+
+src_configure() {
+ local myconf
+ use doc || myconf='--disable-xmlto'
+
+ # --disable-alsaconf because it doesn't work with sys-apps/kmod wrt #456214
+ econf \
+ $(use_enable libsamplerate alsaloop) \
+ $(use_enable nls) \
+ $(use_enable ncurses alsamixer) \
+ --disable-alsaconf \
+ "$(systemd_with_unitdir)" \
+ --with-udev-rules-dir="$(get_udevdir)"/rules.d \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc ChangeLog README TODO seq/*/README.*
+
+ newbin "${WORKDIR}"/alsa-driver-*/utils/alsa-info.sh alsa-info
+
+ newinitd "${FILESDIR}"/alsasound.initd-r5 alsasound
+ newconfd "${FILESDIR}"/alsasound.confd-r4 alsasound
+
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}"/alsa-modules.conf-rc alsa.conf
+
+ keepdir /var/lib/alsa
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "To take advantage of the init script, and automate the process of"
+ elog "saving and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog "# rc-update add alsasound boot"
+ ewarn
+ ewarn "The ALSA core should be built into the kernel or loaded through other"
+ ewarn "means. There is no longer any modular auto(un)loading in alsa-utils."
+ fi
+}