summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-06-30 21:33:39 +0000
committerJohannes Huber <johu@gentoo.org>2012-06-30 21:33:39 +0000
commit6b14fde5d7d359ad633aa698813d1b2b3c960ee3 (patch)
tree9f895c1c6de19a17fe6ca23539dfb29afd04aba3 /media-sound
parentVersion bump. (diff)
downloadgentoo-2-6b14fde5d7d359ad633aa698813d1b2b3c960ee3.tar.gz
gentoo-2-6b14fde5d7d359ad633aa698813d1b2b3c960ee3.tar.bz2
gentoo-2-6b14fde5d7d359ad633aa698813d1b2b3c960ee3.zip
Version bump, remove old.
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/tomahawk/ChangeLog8
-rw-r--r--media-sound/tomahawk/tomahawk-0.5.0.ebuild (renamed from media-sound/tomahawk/tomahawk-0.4.1.ebuild)36
2 files changed, 17 insertions, 27 deletions
diff --git a/media-sound/tomahawk/ChangeLog b/media-sound/tomahawk/ChangeLog
index eeaabae3b90e..18d6c2dbb6b8 100644
--- a/media-sound/tomahawk/ChangeLog
+++ b/media-sound/tomahawk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/tomahawk
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/ChangeLog,v 1.12 2012/06/30 20:46:17 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/ChangeLog,v 1.13 2012/06/30 21:33:39 johu Exp $
+
+*tomahawk-0.5.0 (30 Jun 2012)
+
+ 30 Jun 2012; Johannes Huber <johu@gentoo.org> +tomahawk-0.5.0.ebuild,
+ -tomahawk-0.4.1.ebuild:
+ Version bump, remove old.
30 Jun 2012; Johannes Huber <johu@gentoo.org> tomahawk-9999.ebuild:
Sync live ebuild with dev overlay. Updates dependencies and build options.
diff --git a/media-sound/tomahawk/tomahawk-0.4.1.ebuild b/media-sound/tomahawk/tomahawk-0.5.0.ebuild
index 29cd0a81875b..83b4e81a5f6a 100644
--- a/media-sound/tomahawk/tomahawk-0.4.1.ebuild
+++ b/media-sound/tomahawk/tomahawk-0.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/tomahawk-0.4.1.ebuild,v 1.1 2012/04/06 22:32:13 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tomahawk/tomahawk-0.5.0.ebuild,v 1.1 2012/06/30 21:33:39 johu Exp $
EAPI=4
@@ -22,49 +22,42 @@ HOMEPAGE="http://tomahawk-player.org/"
LICENSE="GPL-3 BSD"
SLOT="0"
-IUSE="debug fftw jabber libsamplerate +resolver twitter"
+IUSE="debug fftw jabber libsamplerate twitter"
DEPEND="
app-crypt/qca
>=dev-cpp/clucene-2.3.3.4
>=dev-libs/boost-1.41
- >=dev-libs/qjson-0.7.1
- >=media-libs/libechonest-1.1.10
+ >=dev-libs/libattica-0.4.0
+ dev-libs/qjson
+ dev-libs/quazip
+ >=media-libs/liblastfm-1.0.1
+ media-libs/libechonest
>=media-libs/phonon-4.5.0
media-libs/taglib
+ x11-libs/libX11
>=x11-libs/qt-core-${QT_MINIMAL}:4
+ >=x11-libs/qt-dbus-${QT_MINIMAL}:4
>=x11-libs/qt-gui-${QT_MINIMAL}:4
>=x11-libs/qt-sql-${QT_MINIMAL}:4[sqlite]
>=x11-libs/qt-webkit-${QT_MINIMAL}:4
- >=x11-libs/qt-xmlpatterns-${QT_MINIMAL}:4
fftw? ( sci-libs/fftw:3.0 )
jabber? ( net-libs/jreen )
libsamplerate? ( media-libs/libsamplerate )
- resolver? (
- dev-libs/libattica
- >=dev-libs/quazip-0.4.3
- )
twitter? ( net-libs/qtweetlib )
"
RDEPEND="${DEPEND}
app-crypt/qca-ossl
"
-PATCHES=(
- "${FILESDIR}/${PN}-0.3.2-remove-quazip.patch"
-)
-
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_with jabber Jreen)
- $(cmake-utils_use_with resolver LibAttica)
- $(cmake-utils_use_with resolver QuaZip)
$(cmake-utils_use_with twitter QTweetLib)
- -DINTERNAL_JREEN=OFF
)
if [[ ${PV} != *9999* ]]; then
- mycmakeargs+=( -DBUILD_RELEASE=ON )
+ mycmakeargs+=( -DBUILD_RELEASE=ON )
fi
cmake-utils_src_configure
@@ -77,12 +70,3 @@ src_compile() {
src_install() {
cmake-utils_src_install
}
-
-pkg_postinst() {
- if ! use resolver; then
- echo
- elog "Information on how to get more resolvers for ${PN}"
- elog "is available at ${HOMEPAGE}resolvers"
- echo
- fi
-}