summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-10-31 19:44:39 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-10-31 19:44:39 +0000
commit3309f61a10d719827d016063cdb3707bf5a5992f (patch)
treebe99a12f08f70ccb54501e7bde1d69c5d651a8f1 /media-sound
parentAdd patch for KDE bug #136566. (diff)
downloadgentoo-2-3309f61a10d719827d016063cdb3707bf5a5992f.tar.gz
gentoo-2-3309f61a10d719827d016063cdb3707bf5a5992f.tar.bz2
gentoo-2-3309f61a10d719827d016063cdb3707bf5a5992f.zip
Make oss output work as should
(Portage version: 2.1.2_pre3-r8)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/sexypsf/ChangeLog17
-rw-r--r--media-sound/sexypsf/sexypsf-0.4.7.ebuild33
2 files changed, 21 insertions, 29 deletions
diff --git a/media-sound/sexypsf/ChangeLog b/media-sound/sexypsf/ChangeLog
index 166de21eb6e7..213722467601 100644
--- a/media-sound/sexypsf/ChangeLog
+++ b/media-sound/sexypsf/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-sound/sexypsf
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sexypsf/ChangeLog,v 1.17 2006/08/07 11:56:54 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sexypsf/ChangeLog,v 1.18 2006/10/31 19:44:39 lu_zero Exp $
+
+ 31 Oct 2006; Luca Barbato <lu_zero@gentoo.org> sexypsf-0.4.7.ebuild:
+ Bigendian fix for oss and cleanup, goodbye xmms
07 Aug 2006; Luca Barbato <lu_zero@gentoo.org> sexypsf-0.4.7.ebuild:
Make it properly work on bigendian
@@ -9,32 +12,32 @@
files/digest-sexypsf-0.4.6, files/digest-sexypsf-0.4.7, Manifest:
Fixing SHA256 digest, pass four
- 19 Feb 2006; Harald van Dijk <truedfx@gentoo.org>
+ 19 Feb 2006; Harald van Dijk <truedfx@gentoo.org>
files/sexypsf-0.4.7-misc.patch, sexypsf-0.4.7.ebuild:
Remove bmp support as beep-media-player is going away
Get rid of a bunch of warnings
- 26 Jan 2006; Harald van Dijk <truedfx@gentoo.org> sexypsf-0.4.7.ebuild:
+ 26 Jan 2006; Harald van Dijk <truedfx@gentoo.org> sexypsf-0.4.7.ebuild:
Fix parallel build issue (bug #119240)
15 Nov 2005; Danny van Dyk <kugelfang@gentoo.org> sexypsf-0.4.7.ebuild:
This works on amd64 as of version 0.4.7, marked accordingly.
- 12 Nov 2005; Harald van Dijk <truedfx@gentoo.org>
+ 12 Nov 2005; Harald van Dijk <truedfx@gentoo.org>
files/sexypsf-0.4.7-misc.patch:
Even more potential 64-bit issues
- 06 Nov 2005; Harald van Dijk <truedfx@gentoo.org>
+ 06 Nov 2005; Harald van Dijk <truedfx@gentoo.org>
files/sexypsf-0.4.7-misc.patch, sexypsf-0.4.7.ebuild:
Add bmp support
- 02 Nov 2005; Harald van Dijk <truedfx@gentoo.org>
+ 02 Nov 2005; Harald van Dijk <truedfx@gentoo.org>
files/sexypsf-0.4.7-misc.patch:
Some more 64-bit problems
*sexypsf-0.4.7 (26 Oct 2005)
- 26 Oct 2005; Harald van Dijk <truedfx@gentoo.org>
+ 26 Oct 2005; Harald van Dijk <truedfx@gentoo.org>
+files/sexypsf-0.4.7-misc.patch, metadata.xml, +sexypsf-0.4.7.ebuild:
Version bump plus gcc4 and 64bit fixes
And marking myself as maintainer
diff --git a/media-sound/sexypsf/sexypsf-0.4.7.ebuild b/media-sound/sexypsf/sexypsf-0.4.7.ebuild
index 4ff6d07dfd9a..e52c9a57aba0 100644
--- a/media-sound/sexypsf/sexypsf-0.4.7.ebuild
+++ b/media-sound/sexypsf/sexypsf-0.4.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sexypsf/sexypsf-0.4.7.ebuild,v 1.6 2006/08/07 11:56:54 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sexypsf/sexypsf-0.4.7.ebuild,v 1.7 2006/10/31 19:44:39 lu_zero Exp $
inherit eutils flag-o-matic
@@ -13,10 +13,9 @@ SLOT="0"
#-sparc: 0.4.5: Couldn't load minispf
KEYWORDS="~amd64 ~ppc -sparc ~x86"
-IUSE="xmms"
+IUSE=""
-DEPEND="sys-libs/zlib
- xmms? ( media-sound/xmms )"
+DEPEND="sys-libs/zlib"
S=${WORKDIR}/${PN}
@@ -24,32 +23,22 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-misc.patch
+
+ # ppc and sparc are big-endian while all other keywords are
+ # little-endian (as far as I know)
+ use ppc64 || use ppc || use sparc &&
+ sed -i -e "s:-D__LINUX__:& -DMSB_FIRST:" "${S}"/Linux/Makefile
+ # what about using the correct macro and avoid to cause severe damages to
+ # innocent ears?
+ sed -i -e "s:AFMT_S16_LE:AFMT_S16_NE:" "${S}"/Linux/oss.c
}
src_compile() {
cd "${S}"/Linux
-
- # ppc and sparc are big-endian while all other keywords are
- # little-endian (as far as I know)
- use ppc64 || use ppc || use sparc && append-flags -DMSBFIRST
emake || die "emake failed"
-
- if use xmms; then
- cd "${S}"
- # do make clean to force rebuild with -fPIC
- make clean || die "make clean failed"
- # don't generate separate xmms and bmp plugins; they're compatible
- emake sexypsf || die "building plugin failed"
- fi
}
src_install() {
dobin Linux/sexypsf
-
- if use xmms; then
- exeinto "$(xmms-config --input-plugin-dir)"
- doexe libsexypsf.so
- fi
-
dodoc Docs/*
}