summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-08-30 19:48:34 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-08-30 19:48:34 +0000
commit1221e044eafcc12e7d6085be2bb067071f16edc9 (patch)
tree358ab84587298b1cfbd20fede7296df109cfffbf /media-sound
parentVersion bump. (diff)
downloadgentoo-2-1221e044eafcc12e7d6085be2bb067071f16edc9.tar.gz
gentoo-2-1221e044eafcc12e7d6085be2bb067071f16edc9.tar.bz2
gentoo-2-1221e044eafcc12e7d6085be2bb067071f16edc9.zip
Version bump to 1.4.7 as per bug 189236.
(Portage version: 2.1.3.7)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/amarok/ChangeLog7
-rw-r--r--media-sound/amarok/amarok-1.4.7.ebuild105
-rw-r--r--media-sound/amarok/files/digest-amarok-1.4.73
3 files changed, 114 insertions, 1 deletions
diff --git a/media-sound/amarok/ChangeLog b/media-sound/amarok/ChangeLog
index 8b0452cd68ec..d8998667e005 100644
--- a/media-sound/amarok/ChangeLog
+++ b/media-sound/amarok/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/amarok
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.228 2007/08/13 21:13:58 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/ChangeLog,v 1.229 2007/08/30 19:48:34 philantrop Exp $
+
+*amarok-1.4.7 (30 Aug 2007)
+
+ 30 Aug 2007; Wulf C. Krueger <philantrop@gentoo.org> +amarok-1.4.7.ebuild:
+ Version bump to 1.4.7 as per bug 189236.
13 Aug 2007; Tobias Scherbaum <dertobi123@gentoo.org>
amarok-1.4.6-r1.ebuild:
diff --git a/media-sound/amarok/amarok-1.4.7.ebuild b/media-sound/amarok/amarok-1.4.7.ebuild
new file mode 100644
index 000000000000..990000cdbb91
--- /dev/null
+++ b/media-sound/amarok/amarok-1.4.7.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amarok/amarok-1.4.7.ebuild,v 1.1 2007/08/30 19:48:34 philantrop Exp $
+
+LANGS="af ar az be bg bn br ca cs cy da de el en_GB eo es et eu fa fi
+fr ga gl he hi hu id is it ja km ko ku lo lt mk ms nb nds ne nl nn pa pl
+pt pt_BR ro ru rw se sk sl sq sr sr@Latn ss sv ta tg th tr uk uz zh_CN
+zh_TW"
+LANGS_DOC="da de es et fr it nl pl pt pt_BR ru sv"
+
+USE_KEG_PACKAGING=1
+
+inherit kde eutils flag-o-matic
+
+PKG_SUFFIX=""
+
+if [[ ${P/_pre} == ${P} ]]; then
+ MY_P="${P/_/-}"
+
+ if [[ ${P/_rc} == ${P} ]]; then
+ SRC_URI="mirror://kde/stable/amarok/${PV}/src/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${P/_/-}"
+ else
+ SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${P/_rc*}"
+ fi
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+fi
+
+DESCRIPTION="Advanced audio player based on KDE framework."
+HOMEPAGE="http://amarok.kde.org/"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="mp4 kde mysql noamazon opengl postgres
+visualization ipod ifp real njb mtp musicbrainz daap
+python"
+# kde: enables compilation of the konqueror sidebar plugin
+
+RDEPEND="kde? ( || ( kde-base/konqueror kde-base/kdebase ) )
+ >=media-libs/xine-lib-1.1.2_pre20060328-r8
+ >=media-libs/taglib-1.4
+ mysql? ( >=virtual/mysql-4.0 )
+ postgres? ( dev-db/libpq )
+ opengl? ( virtual/opengl )
+ visualization? ( media-libs/libsdl
+ =media-plugins/libvisual-plugins-0.4* )
+ ipod? ( >=media-libs/libgpod-0.4.2 )
+ mp4? ( media-libs/libmp4v2 )
+ ifp? ( media-libs/libifp )
+ real? ( media-video/realplayer )
+ njb? ( >=media-libs/libnjb-2.2.4 )
+ mtp? ( >=media-libs/libmtp-0.1.1 )
+ musicbrainz? ( media-libs/tunepimp )
+ =dev-lang/ruby-1.8*"
+
+DEPEND="${RDEPEND}"
+
+RDEPEND="${RDEPEND}
+ app-arch/unzip
+ python? ( dev-python/PyQt )
+ daap? ( www-servers/mongrel )"
+
+need-kde 3.3
+
+src_compile() {
+ # Extra, unsupported engines are forcefully disabled.
+ local myconf="$(use_enable mysql) $(use_enable postgres postgresql)
+ $(use_with opengl) --without-xmms
+ $(use_with visualization libvisual)
+ $(use_enable !noamazon amazon)
+ $(use_with ipod libgpod)
+ $(use_with mp4 mp4v2)
+ $(use_with ifp)
+ $(use_with real helix)
+ $(use_with njb libnjb)
+ $(use_with mtp libmtp)
+ $(use_with musicbrainz)
+ $(use_with daap)
+ --with-xine
+ --without-mas
+ --without-nmm"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ # As much as I respect Ian, I'd rather leave Amarok to use mongrel
+ # from Portage, for security and policy reasons.
+ rm -rf "${D}"/usr/share/apps/amarok/ruby_lib/rbconfig \
+ "${D}"/usr/share/apps/amarok/ruby_lib/mongrel* \
+ "${D}"/usr/share/apps/amarok/ruby_lib/rubygems* \
+ "${D}"/usr/share/apps/amarok/ruby_lib/gem* \
+ "${D}"/usr/$(get_libdir)/ruby_lib
+
+ if ! use python; then
+ rm -r "${D}"/usr/share/apps/amarok/scripts/webcontrol \
+ || die "Unable to remove webcontrol."
+ fi
+}
diff --git a/media-sound/amarok/files/digest-amarok-1.4.7 b/media-sound/amarok/files/digest-amarok-1.4.7
new file mode 100644
index 000000000000..10d913cf761b
--- /dev/null
+++ b/media-sound/amarok/files/digest-amarok-1.4.7
@@ -0,0 +1,3 @@
+MD5 f1299e142da8a69bc3cff5d585e38d43 amarok-1.4.7.tar.bz2 12723499
+RMD160 fc5f5182b488f629cc608aee16aa84a0c4978dcd amarok-1.4.7.tar.bz2 12723499
+SHA256 7ef2691d0cda238696e021421052a04b3cfb068ea0d9854e0c617b33216340f8 amarok-1.4.7.tar.bz2 12723499