summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-05-26 21:44:45 +0000
committerChristoph Junghans <ottxor@gentoo.org>2014-05-26 21:44:45 +0000
commit0eb201f270f3abc0c5f71762417d1841900c1fb9 (patch)
tree37d987eaeaa8900b8dfba832ba640805a6973425 /media-sound
parentHandle kimgio generator under jpeg USE flag. Fixes bug 511416 (diff)
downloadgentoo-2-0eb201f270f3abc0c5f71762417d1841900c1fb9.tar.gz
gentoo-2-0eb201f270f3abc0c5f71762417d1841900c1fb9.tar.bz2
gentoo-2-0eb201f270f3abc0c5f71762417d1841900c1fb9.zip
version bump (bug #511486)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/google-musicmanager/ChangeLog9
-rw-r--r--media-sound/google-musicmanager/google-musicmanager-1.0.113.5623_beta.ebuild4
-rw-r--r--media-sound/google-musicmanager/google-musicmanager-1.0.117.4968_beta.ebuild82
3 files changed, 92 insertions, 3 deletions
diff --git a/media-sound/google-musicmanager/ChangeLog b/media-sound/google-musicmanager/ChangeLog
index 476c513efb5b..3fb902bb4bb9 100644
--- a/media-sound/google-musicmanager/ChangeLog
+++ b/media-sound/google-musicmanager/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/google-musicmanager
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/google-musicmanager/ChangeLog,v 1.38 2014/05/12 02:03:35 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/google-musicmanager/ChangeLog,v 1.39 2014/05/26 21:44:45 ottxor Exp $
+
+*google-musicmanager-1.0.117.4968_beta (26 May 2014)
+
+ 26 May 2014; Christoph Junghans <ottxor@gentoo.org>
+ +google-musicmanager-1.0.117.4968_beta.ebuild,
+ google-musicmanager-1.0.113.5623_beta.ebuild:
+ version bump (bug #511486)
*google-musicmanager-1.0.113.5623_beta (12 May 2014)
diff --git a/media-sound/google-musicmanager/google-musicmanager-1.0.113.5623_beta.ebuild b/media-sound/google-musicmanager/google-musicmanager-1.0.113.5623_beta.ebuild
index 86df703c5ef1..9856fc7218a7 100644
--- a/media-sound/google-musicmanager/google-musicmanager-1.0.113.5623_beta.ebuild
+++ b/media-sound/google-musicmanager/google-musicmanager-1.0.113.5623_beta.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/google-musicmanager/google-musicmanager-1.0.113.5623_beta.ebuild,v 1.1 2014/05/12 02:03:35 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/google-musicmanager/google-musicmanager-1.0.113.5623_beta.ebuild,v 1.2 2014/05/26 21:44:45 ottxor Exp $
EAPI=5
@@ -19,7 +19,7 @@ SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE="log"
-OBSOLETE="no"
+OBSOLETE="yes"
[[ $OBSOLETE = yes ]] && RESTRICT="fetch strip" || RESTRICT="strip mirror"
RDEPEND="
diff --git a/media-sound/google-musicmanager/google-musicmanager-1.0.117.4968_beta.ebuild b/media-sound/google-musicmanager/google-musicmanager-1.0.117.4968_beta.ebuild
new file mode 100644
index 000000000000..d9056571f2f6
--- /dev/null
+++ b/media-sound/google-musicmanager/google-musicmanager-1.0.117.4968_beta.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/google-musicmanager/google-musicmanager-1.0.117.4968_beta.ebuild,v 1.1 2014/05/26 21:44:45 ottxor Exp $
+
+EAPI=5
+
+inherit eutils unpacker
+
+MY_URL="http://dl.google.com/linux/musicmanager/deb/pool/main/${P:0:1}/${PN}-beta"
+MY_PKG="${PN}-beta_${PV/_beta}-r0_i386.deb"
+
+DESCRIPTION="Google Music Manager is a application for adding music to your Google Music library."
+HOMEPAGE="http://music.google.com"
+SRC_URI="x86? ( ${MY_URL}/${MY_PKG} )
+ amd64? ( ${MY_URL}/${MY_PKG/i386/amd64} )"
+
+LICENSE="Google-TOS Apache-2.0 MIT LGPL-2.1 gSOAP BSD FDL-1.2 MPL-1.1 openssl ZLIB libtiff"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="log"
+
+OBSOLETE="no"
+[[ $OBSOLETE = yes ]] && RESTRICT="fetch strip" || RESTRICT="strip mirror"
+
+RDEPEND="
+ dev-libs/expat
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtwebkit:4
+ media-libs/flac
+ media-libs/libvorbis
+ net-dns/libidn
+ sys-libs/glibc
+ log? ( dev-libs/log4cxx )
+ "
+
+DEPEND="app-arch/xz-utils
+ app-admin/chrpath"
+
+INSTALL_BASE="opt/google/musicmanager"
+
+QA_TEXTRELS="${INSTALL_BASE}/libmpgdec.so.0"
+
+QA_FLAGS_IGNORED="${INSTALL_BASE}/.*"
+
+S="${WORKDIR}/${INSTALL_BASE}"
+
+pkg_nofetch() {
+ if [[ ${OBSOLETE} = yes ]]; then
+ elog "This version is no longer available from Google and the license prevents mirroring."
+ elog "This ebuild is intended for users who already downloaded it previously and have problems"
+ elog "with ${PV}+. If you can get the distfile from e.g. another computer of yours, or search"
+ use amd64 && MY_PKG="${MY_PKG/i386/amd64}"
+ elog "it with google: http://www.google.com/search?q=intitle:%22index+of%22+${MY_PKG}"
+ elog "and copy the file ${MY_PKG} to ${DISTDIR}."
+ else
+ einfo "This version is no longer available from Google."
+ einfo "Note that Gentoo cannot mirror the distfiles due to license reasons, so we have to follow the bump."
+ einfo "Please file a version bump bug on http://bugs.gentoo.org (search existing bugs for ${PN} first!)."
+ fi
+}
+
+src_install() {
+ insinto "/${INSTALL_BASE}"
+ doins config.json product_logo* lang.*.qm
+
+ exeinto "/${INSTALL_BASE}"
+ chrpath -d MusicManager || die
+ doexe MusicManager google-musicmanager minidump_upload
+ #TODO unbundle this
+ doexe libaacdec.so libaudioenc.so.0 libmpgdec.so.0 libid3tag.so
+
+ dosym /"${INSTALL_BASE}"/google-musicmanager /opt/bin/google-musicmanager
+
+ local icon size
+ for icon in product_logo_*.png; do
+ size=${icon#product_logo_}
+ size=${size%.png}
+ newicon -s "${size}" "${icon}" ${PN}.png
+ done
+ domenu ${PN}.desktop
+}