summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-05-07 13:46:14 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-05-07 13:46:14 +0000
commitf587501960cdd592cbd8183eb6140e4e099fcbd2 (patch)
treee7a84fa513a2b47e3debdca60728e9a9b17c1d04 /media-sound/synaesthesia/synaesthesia-2.3.ebuild
parentMove distfile to mirror://gentoo/. (diff)
downloadgentoo-2-f587501960cdd592cbd8183eb6140e4e099fcbd2.tar.gz
gentoo-2-f587501960cdd592cbd8183eb6140e4e099fcbd2.tar.bz2
gentoo-2-f587501960cdd592cbd8183eb6140e4e099fcbd2.zip
new upstream version
(Portage version: 2.0.51.21)
Diffstat (limited to 'media-sound/synaesthesia/synaesthesia-2.3.ebuild')
-rw-r--r--media-sound/synaesthesia/synaesthesia-2.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-sound/synaesthesia/synaesthesia-2.3.ebuild b/media-sound/synaesthesia/synaesthesia-2.3.ebuild
new file mode 100644
index 000000000000..29e8424d08d3
--- /dev/null
+++ b/media-sound/synaesthesia/synaesthesia-2.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/synaesthesia/synaesthesia-2.3.ebuild,v 1.1 2005/05/07 13:46:14 luckyduck Exp $
+
+inherit eutils
+
+DESCRIPTION="a nice graphical accompaniment to music"
+HOMEPAGE="http://www.logarithmic.net/pfh/synaesthesia"
+SRC_URI="http://www.logarithmic.net/pfh-files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="sdl svga esd"
+
+DEPEND="virtual/x11
+ esd? ( >=media-sound/esound-0.2.22 )
+ sdl? ( >=media-libs/libsdl-1.2.0 )
+ svga? ( >=media-libs/svgalib-1.4.3 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "/CFLAGS=/s:-O4:${CFLAGS}:" \
+ -e "/CXXFLAGS=/s:-O4:${CXXFLAGS}:" \
+ configure
+ sed -i 's:void inline:inline void:' syna.h
+}
+
+src_install() {
+ dobin synaesthesia || die
+ dodoc README
+}