summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-29 12:43:51 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-29 12:43:51 +0000
commit0a422aa16378b214162cac8de7e028ad5e8b3631 (patch)
tree92f6c906ba004c02426001fdcd0cf8ef879bed61 /media-sound/sox
parentStable for HPPA (bug #357765). (diff)
downloadgentoo-2-0a422aa16378b214162cac8de7e028ad5e8b3631.tar.gz
gentoo-2-0a422aa16378b214162cac8de7e028ad5e8b3631.tar.bz2
gentoo-2-0a422aa16378b214162cac8de7e028ad5e8b3631.zip
Fix compability with uClibc wrt #336123 by Erasmo Zubillaga.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/sox')
-rw-r--r--media-sound/sox/ChangeLog6
-rw-r--r--media-sound/sox/files/sox-14.3.2-uclibc.patch21
-rw-r--r--media-sound/sox/sox-14.3.2.ebuild8
3 files changed, 32 insertions, 3 deletions
diff --git a/media-sound/sox/ChangeLog b/media-sound/sox/ChangeLog
index 183c83f5cfbf..0d39bc099778 100644
--- a/media-sound/sox/ChangeLog
+++ b/media-sound/sox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/sox
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/ChangeLog,v 1.122 2011/02/28 10:48:23 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/ChangeLog,v 1.123 2011/03/29 12:43:51 ssuominen Exp $
+
+ 29 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> sox-14.3.2.ebuild,
+ +files/sox-14.3.2-uclibc.patch:
+ Fix compability with uClibc wrt #336123 by Erasmo Zubillaga.
*sox-14.3.2 (28 Feb 2011)
diff --git a/media-sound/sox/files/sox-14.3.2-uclibc.patch b/media-sound/sox/files/sox-14.3.2-uclibc.patch
new file mode 100644
index 000000000000..cc07fc012530
--- /dev/null
+++ b/media-sound/sox/files/sox-14.3.2-uclibc.patch
@@ -0,0 +1,21 @@
+http://bugs.gentoo.org/show_bug.cgi?id=336123
+
+--- src/formats.c
++++ src/formats.c
+@@ -399,7 +399,7 @@
+ #if defined _FSTDIO || defined _NEWLIB_VERSION || defined __APPLE__
+ fp->_p -= AUTO_DETECT_SIZE;
+ fp->_r += AUTO_DETECT_SIZE;
+-#elif defined __GLIBC__
++#elif defined __GLIBC__ && ! defined __UCLIBC__
+ fp->_IO_read_ptr = fp->_IO_read_base;
+ #elif defined _MSC_VER || defined __MINGW_H || defined _ISO_STDIO_ISO_H
+ fp->_ptr = fp->_base;
+@@ -407,7 +407,6 @@
+ /* To fix this #error, either simply remove the #error line and live without
+ * file-type detection with pipes, or add support for your compiler in the
+ * lines above. Test with cat monkey.au | ./sox --info - */
+- #error FIX NEEDED HERE
+ #define NO_REWIND_PIPE
+ (void)fp;
+ #endif
diff --git a/media-sound/sox/sox-14.3.2.ebuild b/media-sound/sox/sox-14.3.2.ebuild
index b752c47bff89..3ce74de27034 100644
--- a/media-sound/sox/sox-14.3.2.ebuild
+++ b/media-sound/sox/sox-14.3.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.3.2.ebuild,v 1.1 2011/02/28 10:48:23 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sox/sox-14.3.2.ebuild,v 1.2 2011/03/29 12:43:51 ssuominen Exp $
EAPI=2
-inherit flag-o-matic
+inherit eutils flag-o-matic
DESCRIPTION="The swiss army knife of sound processing programs"
HOMEPAGE="http://sox.sourceforge.net"
@@ -34,6 +34,10 @@ RDEPEND="sys-devel/libtool
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-uclibc.patch
+}
+
src_configure() {
# Fixes wav segfaults. See Bug #35745.
append-flags -fsigned-char