summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2011-01-27 22:16:55 +0000
committerHanno Böck <hanno@gentoo.org>2011-01-27 22:16:55 +0000
commit1e259b6cc0bc3795cd3b1dccdfd1c78f572bf7c7 (patch)
tree1a412cd106b16b2d4b5064a0abce459c41031695 /media-sound/soundconverter
parentstable ppc, bug 352473 (diff)
downloadgentoo-2-1e259b6cc0bc3795cd3b1dccdfd1c78f572bf7c7.tar.gz
gentoo-2-1e259b6cc0bc3795cd3b1dccdfd1c78f572bf7c7.tar.bz2
gentoo-2-1e259b6cc0bc3795cd3b1dccdfd1c78f572bf7c7.zip
soundconverter bump
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/soundconverter')
-rw-r--r--media-sound/soundconverter/ChangeLog9
-rw-r--r--media-sound/soundconverter/soundconverter-1.5.4.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/media-sound/soundconverter/ChangeLog b/media-sound/soundconverter/ChangeLog
index 323c96fffd8a..be78d1a1fd76 100644
--- a/media-sound/soundconverter/ChangeLog
+++ b/media-sound/soundconverter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/soundconverter
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/soundconverter/ChangeLog,v 1.17 2010/11/21 18:05:01 hanno Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/soundconverter/ChangeLog,v 1.18 2011/01/27 22:16:55 hanno Exp $
+
+*soundconverter-1.5.4 (27 Jan 2011)
+
+ 27 Jan 2011; Hanno Boeck <hanno@gentoo.org> +soundconverter-1.5.4.ebuild:
+ Version bump, set python active version, split gnome-python deps.
*soundconverter-1.5.3 (21 Nov 2010)
diff --git a/media-sound/soundconverter/soundconverter-1.5.4.ebuild b/media-sound/soundconverter/soundconverter-1.5.4.ebuild
new file mode 100644
index 000000000000..caa0a17e1d45
--- /dev/null
+++ b/media-sound/soundconverter/soundconverter-1.5.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/soundconverter/soundconverter-1.5.4.ebuild,v 1.1 2011/01/27 22:16:55 hanno Exp $
+
+PYTHON_DEPEND="2"
+
+inherit gnome2 python
+
+DESCRIPTION="A simple sound converter application for the GNOME environment."
+HOMEPAGE="http://soundconverter.berlios.de"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aac flac mp3 vorbis"
+
+# upstream reported, please remove as soon as it's fixed
+# http://developer.berlios.de/bugs/?func=detailbug&bug_id=17726&group_id=3213
+RESTRICT="test"
+
+RDEPEND=">=dev-python/pygtk-2.12
+ dev-python/pygobject
+ dev-python/gconf-python
+ dev-python/libgnome-python
+ dev-python/gnome-vfs-python
+ gnome-base/libglade
+ gnome-base/gconf
+ =dev-python/gst-python-0.10*
+ =media-plugins/gst-plugins-gnomevfs-0.10*
+ vorbis? (
+ =media-plugins/gst-plugins-vorbis-0.10*
+ =media-plugins/gst-plugins-ogg-0.10*
+ )
+ mp3? (
+ =media-plugins/gst-plugins-lame-0.10*
+ =media-plugins/gst-plugins-mad-0.10*
+ =media-plugins/gst-plugins-taglib-0.10*
+ )
+ flac? ( =media-plugins/gst-plugins-flac-0.10* )
+ aac? ( =media-plugins/gst-plugins-faac-0.10* )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext
+ dev-util/intltool"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog README TODO"
+ python_set_active_version 2
+}