summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-06-13 18:26:10 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-06-13 18:26:10 +0000
commitdbb2153405f6a8155508c771b92c6e023bd3fb91 (patch)
tree0e255affe6a394b4b83ba3815cb753983b5ef748 /media-sound/snd
parention3 is no longer intree, remove license (diff)
downloadgentoo-2-dbb2153405f6a8155508c771b92c6e023bd3fb91.tar.gz
gentoo-2-dbb2153405f6a8155508c771b92c6e023bd3fb91.tar.bz2
gentoo-2-dbb2153405f6a8155508c771b92c6e023bd3fb91.zip
version bump
(Portage version: 2.1.2.9)
Diffstat (limited to 'media-sound/snd')
-rw-r--r--media-sound/snd/ChangeLog7
-rw-r--r--media-sound/snd/files/digest-snd-9.13
-rw-r--r--media-sound/snd/snd-9.1.ebuild113
3 files changed, 122 insertions, 1 deletions
diff --git a/media-sound/snd/ChangeLog b/media-sound/snd/ChangeLog
index de6c57f9cf88..137e4defaa1d 100644
--- a/media-sound/snd/ChangeLog
+++ b/media-sound/snd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/snd
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/ChangeLog,v 1.33 2007/03/14 20:09:02 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/ChangeLog,v 1.34 2007/06/13 18:26:10 aballier Exp $
+
+*snd-9.1 (13 Jun 2007)
+
+ 13 Jun 2007; Alexis Ballier <aballier@gentoo.org> +snd-9.1.ebuild:
+ version bump
14 Mar 2007; Michael Sterrett <mr_bones_@gentoo.org> -snd-7.10.ebuild:
clean out non-modX ebuild
diff --git a/media-sound/snd/files/digest-snd-9.1 b/media-sound/snd/files/digest-snd-9.1
new file mode 100644
index 000000000000..f5e5668aaa90
--- /dev/null
+++ b/media-sound/snd/files/digest-snd-9.1
@@ -0,0 +1,3 @@
+MD5 5612ad0196048d12cb73827209c53e72 snd-9.1.tar.gz 8561354
+RMD160 cd5ae0b740534da87a0f300c2e25d2403f5628dd snd-9.1.tar.gz 8561354
+SHA256 2de0332afcaeba9ad2e078cbc149bfce2e3e29ef6c35aae112c6d23c2124dbee snd-9.1.tar.gz 8561354
diff --git a/media-sound/snd/snd-9.1.ebuild b/media-sound/snd/snd-9.1.ebuild
new file mode 100644
index 000000000000..bf3a40a3fb8f
--- /dev/null
+++ b/media-sound/snd/snd-9.1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/snd/snd-9.1.ebuild,v 1.1 2007/06/13 18:26:10 aballier Exp $
+
+inherit multilib eutils
+
+S="${WORKDIR}/${P/\.*//}"
+DESCRIPTION="Snd is a sound editor"
+HOMEPAGE="http://ccrma.stanford.edu/software/snd/"
+SRC_URI="ftp://ccrma-ftp.stanford.edu/pub/Lisp/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa cairo esd fam fftw gsl gtk guile jack ladspa motif nls opengl oss ruby"
+
+RDEPEND="media-libs/audiofile
+ motif? ( x11-libs/openmotif )
+ alsa? ( media-libs/alsa-lib )
+ esd? ( media-sound/esound )
+ fam? ( virtual/fam )
+ fftw? ( sci-libs/fftw )
+ gsl? ( >=sci-libs/gsl-0.8 )
+ gtk? ( >=x11-libs/gtk+-2
+ opengl? ( x11-libs/gtkglext )
+ cairo? ( x11-libs/cairo ) )
+ guile? ( >=dev-scheme/guile-1.3.4 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ ladspa? ( media-libs/ladspa-sdk )
+ nls? ( sys-devel/gettext )
+ opengl? ( virtual/opengl )
+ ruby? ( virtual/ruby )"
+
+pkg_setup() {
+ if ! use gtk && ! use motif; then
+ ewarn "Warning: no graphic toolkit selected (gtk or motif)."
+ ewarn "Upstream suggests to enable one of the toolkits (or both)"
+ ewarn "or only the command line utilities will be helpful."
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ if use opengl; then
+ if use guile; then
+ myconf="${myconf} --with-gl"
+ else
+ myconf="${myconf} --with-just-gl"
+ fi
+ else
+ myconf="${myconf} --without-gl"
+ fi
+
+ econf \
+ $(use_with alsa) \
+ $(use_with oss) \
+ $(use_with esd) \
+ $(use_with fam) \
+ $(use_with fftw) \
+ $(use_with gsl) \
+ $(use_with gtk) \
+ $(use_with guile) \
+ $(use_with jack) \
+ $(use_with ladspa) \
+ $(use_with motif) \
+ $(use_enable nls) \
+ $(use_with ruby) \
+ $(use_with cairo) \
+ --with-float-samples \
+ ${myconf} || die
+
+ emake snd || die "emake snd failed"
+
+ # compiling command-line programs. See bug #112695
+ # do not compile ruby extensions for command line programs
+ # those fail to compile
+ if use ruby; then
+ econf \
+ $(use_with alsa) \
+ $(use_with esd) \
+ $(use_with fam) \
+ $(use_with fftw) \
+ $(use_with gsl) \
+ $(use_with gtk) \
+ $(use_with guile) \
+ $(use_with jack) \
+ $(use_with ladspa) \
+ $(use_with motif) \
+ $(use_enable nls) \
+ --without-ruby \
+ --with-float-samples \
+ ${myconf} || die
+ fi
+
+ for i in sndrecord sndinfo audinfo sndplay; do
+ emake ${i} || die "make ${i} failed"
+ done
+}
+
+src_install () {
+ dobin snd
+ dobin sndplay
+ dobin sndrecord
+ dobin sndinfo
+ dobin audinfo
+
+ insinto /usr/$(get_libdir)/snd/scheme
+ doins *.scm
+
+ dodoc README.Snd HISTORY.Snd TODO.Snd Snd.ad
+ dohtml -r *.html *.png tutorial
+}