summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-23 16:05:27 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-23 16:05:27 +0000
commitb64fed66faae2bac415a431665e5ce29e799cb58 (patch)
tree718bd595aef2b18d4cb46329f37653b2b653da14 /media-sound/shell-fm
parentPatch to prevent (double free) crash wrt #392413 by "nzqr" (diff)
downloadgentoo-2-b64fed66faae2bac415a431665e5ce29e799cb58.tar.gz
gentoo-2-b64fed66faae2bac415a431665e5ce29e799cb58.tar.bz2
gentoo-2-b64fed66faae2bac415a431665e5ce29e799cb58.zip
old
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/shell-fm')
-rw-r--r--media-sound/shell-fm/ChangeLog6
-rw-r--r--media-sound/shell-fm/files/shell-fm-0.7-asneeded.patch39
-rw-r--r--media-sound/shell-fm/shell-fm-0.7.ebuild43
-rw-r--r--media-sound/shell-fm/shell-fm-0.8.ebuild43
4 files changed, 5 insertions, 126 deletions
diff --git a/media-sound/shell-fm/ChangeLog b/media-sound/shell-fm/ChangeLog
index cfd8bd2438d9..a930e84e6576 100644
--- a/media-sound/shell-fm/ChangeLog
+++ b/media-sound/shell-fm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/shell-fm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/ChangeLog,v 1.16 2012/01/23 16:04:21 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/ChangeLog,v 1.17 2012/01/23 16:05:27 ssuominen Exp $
+
+ 23 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> -shell-fm-0.7.ebuild,
+ -files/shell-fm-0.7-asneeded.patch, -shell-fm-0.8.ebuild:
+ old
*shell-fm-0.8-r1 (23 Jan 2012)
diff --git a/media-sound/shell-fm/files/shell-fm-0.7-asneeded.patch b/media-sound/shell-fm/files/shell-fm-0.7-asneeded.patch
deleted file mode 100644
index fd0de6dbe040..000000000000
--- a/media-sound/shell-fm/files/shell-fm-0.7-asneeded.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- a/source/Makefile
-+++ b/source/Makefile
-@@ -6,10 +6,10 @@ LIB := libshellfm.so
- STATIC := libshellfm.a
-
- ifeq ($(shell uname -s), OpenBSD)
-- LDFLAGS += -lossaudio
-+ LDLIBS += -lossaudio
- endif
- ifeq ($(shell uname -s), NetBSD)
-- LDFLAGS += -lossaudio
-+ LDLIBS += -lossaudio
- endif
- ifeq ($(shell uname -s), Darwin)
- CFLAGS += -D__darwin__
-@@ -18,12 +18,12 @@ endif
- CFLAGS += -Os -Wall -W -I./include/ -DLIBAO \
- $(shell pkg-config --cflags mad) \
- $(shell pkg-config --cflags ao)
--LDFLAGS += $(shell pkg-config --libs mad) \
-+LDLIBS += $(shell pkg-config --libs mad) \
- $(shell pkg-config --libs ao)
-
- ifeq ($(shell pkg-config --exists taglib_c && echo 1), 1)
- CFLAGS += $(shell pkg-config --cflags taglib_c) -DTAGLIB
-- LDFLAGS += $(shell pkg-config --libs taglib_c)
-+ LDLIBS += $(shell pkg-config --libs taglib_c)
- endif
-
- .PHONY: clean tags cscope
-@@ -40,7 +40,7 @@ $(STATIC) : $(OBJECT)
- $(AR) -cvq $(STATIC) $(OBJECT)
-
- $(BINARY) : $(STATIC)
-- $(CC) -o $(BINARY) $(CFLAGS) $(MAIN) $(LDFLAGS) $(STATIC)
-+ $(CC) $(CFLAGS) $(LDFLAGS) $(MAIN) $(STATIC) $(LDLIBS) -o $(BINARY)
-
- clean :
- rm -f $(OBJECT) $(BINARY) $(LIB) $(STATIC)
diff --git a/media-sound/shell-fm/shell-fm-0.7.ebuild b/media-sound/shell-fm/shell-fm-0.7.ebuild
deleted file mode 100644
index 1bd4ce6bf060..000000000000
--- a/media-sound/shell-fm/shell-fm-0.7.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/shell-fm-0.7.ebuild,v 1.4 2010/08/18 21:05:26 darkside Exp $
-
-EAPI=2
-inherit flag-o-matic toolchain-funcs eutils
-
-DESCRIPTION="A lightweight console based player for Last.FM radio streams"
-HOMEPAGE="http://nex.scrapping.cc/shell-fm/"
-# I couldn't get constant tarball from github so I've tarballed this myself.
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux"
-IUSE=""
-
-RDEPEND="media-libs/libmad
- media-libs/libao
- media-libs/taglib"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- sys-apps/sed"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-asneeded.patch"
- sed -i -e "s:-Os::" source/Makefile || die "sed failed"
-}
-
-src_compile() {
- tc-export CC
- if use ppc; then
- append-flags -DWORDS_BIGENDIAN=1
- fi
- emake || die "emake failed"
-}
-
-src_install() {
- dobin source/${PN} || die "dobin failed"
- doman manual/${PN}.1 || die
- exeinto /usr/share/${PN}/scripts
- doexe scripts/{*.sh,*.pl,zcontrol} || die "doexe failed"
-}
diff --git a/media-sound/shell-fm/shell-fm-0.8.ebuild b/media-sound/shell-fm/shell-fm-0.8.ebuild
deleted file mode 100644
index 0e30b08f31ee..000000000000
--- a/media-sound/shell-fm/shell-fm-0.8.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/shell-fm-0.8.ebuild,v 1.1 2011/05/24 21:12:43 radhermit Exp $
-
-EAPI=4
-inherit flag-o-matic toolchain-funcs eutils
-
-DESCRIPTION="A lightweight console based player for Last.FM radio streams"
-HOMEPAGE="http://nex.scrapping.cc/shell-fm/"
-SRC_URI="https://github.com/jkramer/${PN}/tarball/v${PV} -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux"
-IUSE=""
-
-RDEPEND="media-libs/libmad
- media-libs/libao
- media-libs/taglib"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- sys-apps/sed"
-
-src_unpack() {
- unpack ${A}
- mv *-${PN}-* "${S}"
-}
-
-src_prepare() {
- sed -i -e "s:-Os::" source/Makefile || die "sed failed"
-
- tc-export CC AR
- if use ppc; then
- append-flags -DWORDS_BIGENDIAN=1
- fi
-}
-
-src_install() {
- dobin source/${PN}
- doman manual/${PN}.1
- exeinto /usr/share/${PN}/scripts
- doexe scripts/{*.sh,*.pl,zcontrol}
-}