summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-08-06 11:24:53 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-08-06 11:24:53 +0000
commit885781e65ac81ba150d5e56a6246c612cc01978e (patch)
tree65f2cbc995d0b9bea2ef5dd3ae56e9c03e6a8a20 /media-sound/sbconf
parentNew package. Closes #24838. ~x86 masked. (diff)
downloadgentoo-2-885781e65ac81ba150d5e56a6246c612cc01978e.tar.gz
gentoo-2-885781e65ac81ba150d5e56a6246c612cc01978e.tar.bz2
gentoo-2-885781e65ac81ba150d5e56a6246c612cc01978e.zip
New package. Closes #24838. ~x86 masked.
Diffstat (limited to 'media-sound/sbconf')
-rw-r--r--media-sound/sbconf/ChangeLog12
-rw-r--r--media-sound/sbconf/Manifest4
-rw-r--r--media-sound/sbconf/files/digest-sbconf-1.01
-rw-r--r--media-sound/sbconf/files/sbconf-gentoo-path.diff14
-rw-r--r--media-sound/sbconf/sbconf-1.0.ebuild40
5 files changed, 70 insertions, 1 deletions
diff --git a/media-sound/sbconf/ChangeLog b/media-sound/sbconf/ChangeLog
new file mode 100644
index 000000000000..d5b6df1bef3c
--- /dev/null
+++ b/media-sound/sbconf/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for media-sound/sbconf
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sbconf/ChangeLog,v 1.1 2003/08/06 11:24:46 jje Exp $
+
+*sbconf-1.0 (06 Aug 2003)
+
+ 06 Aug 2003; jje <jje@gentoo.org> sbconf-1.0.ebuild,
+ files/sbconf-gentoo-path.diff:
+ Initial revision.
+
+ Submitted by: Park Ji-in <mithrandir@electrang.net>
+
diff --git a/media-sound/sbconf/Manifest b/media-sound/sbconf/Manifest
index a208c143439e..969a871e8dd3 100644
--- a/media-sound/sbconf/Manifest
+++ b/media-sound/sbconf/Manifest
@@ -1,2 +1,4 @@
-MD5 d37a4aad2bd3851df49fc90ace1f8fb6 sbconf-1.0.ebuild 830
+MD5 180479cffda5dbb47cad0e2028fc8b67 sbconf-1.0.ebuild 936
+MD5 b7c382e0fa6549ab49410531153a1e34 ChangeLog 408
MD5 8a13cff427ab7b0899c9ca90fe114154 files/digest-sbconf-1.0 59
+MD5 ce92f9f4e6f5b9c8c0e6a2d0070bd49c files/sbconf-gentoo-path.diff 566
diff --git a/media-sound/sbconf/files/digest-sbconf-1.0 b/media-sound/sbconf/files/digest-sbconf-1.0
new file mode 100644
index 000000000000..2a6876edd6b0
--- /dev/null
+++ b/media-sound/sbconf/files/digest-sbconf-1.0
@@ -0,0 +1 @@
+MD5 2a704851b77f367634828cee020e7b0b sbconf.tar.bz2 221119
diff --git a/media-sound/sbconf/files/sbconf-gentoo-path.diff b/media-sound/sbconf/files/sbconf-gentoo-path.diff
new file mode 100644
index 000000000000..fa85188d2ae1
--- /dev/null
+++ b/media-sound/sbconf/files/sbconf-gentoo-path.diff
@@ -0,0 +1,14 @@
+--- main.cc 2003-07-20 08:38:56.000000000 +0900
++++ main.cc.modified 2003-07-20 08:39:05.000000000 +0900
+@@ -1019,8 +1019,8 @@
+ window = glade_xml_get_widget (xml, "MainWindow");
+
+ gnome_config_push_prefix("=.sbconf=/General/");
+- emupath = gnome_config_get_string("emupath=/usr/local/bin/");
+- dsppath = gnome_config_get_string("effectsdir=/usr/local/share/emu10k1/");
++ emupath = gnome_config_get_string("emupath=/usr/bin/");
++ dsppath = gnome_config_get_string("effectsdir=/usr/share/emu10k1/");
+
+ // configue the about box
+ gchar** command=new char*[3];
+
diff --git a/media-sound/sbconf/sbconf-1.0.ebuild b/media-sound/sbconf/sbconf-1.0.ebuild
new file mode 100644
index 000000000000..0fa538938bb1
--- /dev/null
+++ b/media-sound/sbconf/sbconf-1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/sbconf/sbconf-1.0.ebuild,v 1.1 2003/08/06 11:24:46 jje Exp $
+
+inherit gnome2
+
+DESCRIPTION="Sbconf is a GUI of emu-tools which is a tools to configure your soundblaster card"
+HOMEPAGE="http://w3.enternet.hu/televeny/sbconf/sbconf.html"
+SRC_URI="http://w3.enternet.hu/televeny/sbconf/${PN}.tar.bz2"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+
+S=${WORKDIR}/${PN}
+IUSE=""
+DEPEND="
+ >=x11-libs/gtk+-2.0.0
+ media-sound/emu10k1
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libglade-2.0.0"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+ epatch ${FILESDIR}/sbconf-gentoo-path.diff
+}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ einstall || die
+}
+