summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe McCann <joem@gentoo.org>2005-11-29 05:54:46 +0000
committerJoe McCann <joem@gentoo.org>2005-11-29 05:54:46 +0000
commit903b47bb70e48f20aa458ce001e0109061b52830 (patch)
tree9391438342927827831b894a5624aa1140e7c92d /media-sound/rhythmbox
parentAdded ~sparc keyword. (diff)
downloadgentoo-2-903b47bb70e48f20aa458ce001e0109061b52830.tar.gz
gentoo-2-903b47bb70e48f20aa458ce001e0109061b52830.tar.bz2
gentoo-2-903b47bb70e48f20aa458ce001e0109061b52830.zip
add ewarn to describe use of daap useflag
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'media-sound/rhythmbox')
-rw-r--r--media-sound/rhythmbox/Manifest2
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.9.2.ebuild11
2 files changed, 10 insertions, 3 deletions
diff --git a/media-sound/rhythmbox/Manifest b/media-sound/rhythmbox/Manifest
index e8b49639e4af..20ec4f904a9f 100644
--- a/media-sound/rhythmbox/Manifest
+++ b/media-sound/rhythmbox/Manifest
@@ -6,4 +6,4 @@ MD5 a3ff016aec5eec7277e2598ad013b80a files/rhythmbox-0.8.8-empty-xlib.patch 496
MD5 9f5bc9bf255b78cc67342f9fc9423ef6 files/rhythmbox-0.8.8-ipod.patch 809
MD5 e854b7f54a4de6256186cbdcaabbc1ec metadata.xml 200
MD5 ff60c2d320a8e0e8e55bfac395f77eb3 rhythmbox-0.8.8-r1.ebuild 2636
-MD5 7ee09b772786acff56e5c2ccbfe09360 rhythmbox-0.9.2.ebuild 2255
+MD5 365ca47a06fc569d6f65550726de3a02 rhythmbox-0.9.2.ebuild 2461
diff --git a/media-sound/rhythmbox/rhythmbox-0.9.2.ebuild b/media-sound/rhythmbox/rhythmbox-0.9.2.ebuild
index d7a2d03b43ab..6d81d8d07b7e 100644
--- a/media-sound/rhythmbox/rhythmbox-0.9.2.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-0.9.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.9.2.ebuild,v 1.2 2005/11/29 05:18:55 joem Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.9.2.ebuild,v 1.3 2005/11/29 05:54:46 joem Exp $
inherit gnome2 eutils
@@ -28,7 +28,7 @@ RDEPEND=">=x11-libs/gtk+-2.5.4
pda? ( >=media-libs/libgpod-0.2.0
>=sys-apps/hal-0.5 )
avahi? ( >=net-dns/avahi-0.5 )
- !avahi ( howl? ( >=net-misc/howl-0.9.8 ) )
+ !avahi? ( howl? ( >=net-misc/howl-0.9.8 ) )
dbus? ( >=sys-apps/dbus-0.35 )
>=media-libs/gst-plugins-0.8.2
>=media-plugins/gst-plugins-gnomevfs-0.8.2
@@ -47,6 +47,13 @@ MAKEOPTS="${MAKEOPTS} -j1"
pkg_setup() {
+ if ! use avahi && ! use howl; then
+ if use daap ; then
+ ewarn "Daap support requires either howl or avahi"
+ ewarn "to be installed. Please remerge with either"
+ ewarn "USE=avahi or USE=howl"
+ fi
+ fi
if use howl || use avahi ; then
G2CONF="${G2CONF} $(use_enable daap)"
fi