summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2009-10-31 16:48:11 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2009-10-31 16:48:11 +0000
commit5f92b2e57531053a66b6dcf8dd0b79d688f45d12 (patch)
tree5a7e7dabca19a86bafba2a989d3bb9305677baa9 /media-sound/rhythmbox
parentMarking mysql-python-1.2.3_rc1 ppc64 for bug 284574 (diff)
downloadgentoo-2-5f92b2e57531053a66b6dcf8dd0b79d688f45d12.tar.gz
gentoo-2-5f92b2e57531053a66b6dcf8dd0b79d688f45d12.tar.bz2
gentoo-2-5f92b2e57531053a66b6dcf8dd0b79d688f45d12.zip
Fix bug 291315 -- daap plugin load failure & bug 287604 -- wrong ewarn with USE=-cdr
(Portage version: 2.1.7.2/cvs/Linux i686)
Diffstat (limited to 'media-sound/rhythmbox')
-rw-r--r--media-sound/rhythmbox/ChangeLog10
-rw-r--r--media-sound/rhythmbox/files/rhythmbox-0.12.5-fix-daap-plugin-linking.patch22
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.12.5-r1.ebuild (renamed from media-sound/rhythmbox/rhythmbox-0.12.5.ebuild)8
3 files changed, 37 insertions, 3 deletions
diff --git a/media-sound/rhythmbox/ChangeLog b/media-sound/rhythmbox/ChangeLog
index 336b36e6dd00..6e8e745adb53 100644
--- a/media-sound/rhythmbox/ChangeLog
+++ b/media-sound/rhythmbox/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/rhythmbox
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.160 2009/09/28 20:40:09 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.161 2009/10/31 16:48:10 nirbheek Exp $
+
+*rhythmbox-0.12.5-r1 (31 Oct 2009)
+
+ 31 Oct 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
+ -rhythmbox-0.12.5.ebuild, +rhythmbox-0.12.5-r1.ebuild,
+ +files/rhythmbox-0.12.5-fix-daap-plugin-linking.patch:
+ Fix bug 291315 -- daap plugin load failure & bug 287604 -- wrong ewarn
+ with USE=-cdr
*rhythmbox-0.12.5 (28 Sep 2009)
diff --git a/media-sound/rhythmbox/files/rhythmbox-0.12.5-fix-daap-plugin-linking.patch b/media-sound/rhythmbox/files/rhythmbox-0.12.5-fix-daap-plugin-linking.patch
new file mode 100644
index 000000000000..644615c3b35b
--- /dev/null
+++ b/media-sound/rhythmbox/files/rhythmbox-0.12.5-fix-daap-plugin-linking.patch
@@ -0,0 +1,22 @@
+From 3bf2e8b95d5a2c8000a7e46b73f0b92c5319e927 Mon Sep 17 00:00:00 2001
+From: Christophe Fergeau <cfergeau@mandriva.com>
+Date: Sat, 10 Oct 2009 12:16:35 +0000
+Subject: link daap plugin with RHYTHMBOX_LIBS (bug #597899)
+
+The DAAP plugin uses libsoup, so it needs to link with libsoup which is
+part of RHYTHMBOX_LIBS.
+---
+diff --git a/plugins/daap/Makefile.am b/plugins/daap/Makefile.am
+index 90935ee..dfc1058 100644
+--- a/plugins/daap/Makefile.am
++++ b/plugins/daap/Makefile.am
+@@ -35,6 +35,7 @@ libdaap_la_LIBTOOLFLAGS = --tag=disable-static
+ libdaap_la_LIBADD = \
+ $(top_builddir)/shell/librhythmbox-core.la \
+ $(DBUS_LIBS) \
++ $(RHYTHMBOX_LIBS) \
+ $(MDNS_LIBS)
+
+ INCLUDES = \
+--
+cgit v0.8.2
diff --git a/media-sound/rhythmbox/rhythmbox-0.12.5.ebuild b/media-sound/rhythmbox/rhythmbox-0.12.5-r1.ebuild
index 88cb16e44dfd..66b4534a7c88 100644
--- a/media-sound/rhythmbox/rhythmbox-0.12.5.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-0.12.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.12.5.ebuild,v 1.1 2009/09/28 20:40:09 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.12.5-r1.ebuild,v 1.1 2009/10/31 16:48:10 nirbheek Exp $
EAPI="2"
WANT_AUTOMAKE="1.10"
@@ -104,7 +104,7 @@ pkg_setup() {
if ! use cdr ; then
ewarn "You have cdr USE flag disabled."
- ewarn "You will not be able to play audio CDs."
+ ewarn "You will not be able to burn CDs."
fi
if use brasero; then
@@ -139,6 +139,10 @@ pkg_setup() {
src_prepare() {
gnome2_src_prepare
+ # Fix bug 291315 (patch taken from upstream repo)
+ # DAAP plugin load failure when built with --as-needed
+ epatch "${FILESDIR}/${P}-fix-daap-plugin-linking.patch"
+
# disable pyc compiling
mv py-compile py-compile.orig
ln -s $(type -P true) py-compile