summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2008-09-14 18:52:27 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2008-09-14 18:52:27 +0000
commit4fb2eebbf5fb5dd147de90d4d59a687a26b3a228 (patch)
tree1c7e33ad542c60b3b8c65c7e906fea0b99a0ef1d /media-sound/rhythmbox
parentPicking up maintainership as current maintainer is inactive. (diff)
downloadgentoo-2-4fb2eebbf5fb5dd147de90d4d59a687a26b3a228.tar.gz
gentoo-2-4fb2eebbf5fb5dd147de90d4d59a687a26b3a228.tar.bz2
gentoo-2-4fb2eebbf5fb5dd147de90d4d59a687a26b3a228.zip
Depend on gnome-python components (gconf, gnome-vfs, libgnome), rather than all of gnome-python. Thanks to Nirbheek Chauhan (bheekling) for the work on this.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.2 i686)
Diffstat (limited to 'media-sound/rhythmbox')
-rw-r--r--media-sound/rhythmbox/ChangeLog10
-rw-r--r--media-sound/rhythmbox/rhythmbox-0.11.6-r1.ebuild161
2 files changed, 170 insertions, 1 deletions
diff --git a/media-sound/rhythmbox/ChangeLog b/media-sound/rhythmbox/ChangeLog
index 42274a42ede2..04c6668bf8cd 100644
--- a/media-sound/rhythmbox/ChangeLog
+++ b/media-sound/rhythmbox/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/rhythmbox
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.132 2008/07/23 22:48:50 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/ChangeLog,v 1.133 2008/09/14 18:52:27 ford_prefect Exp $
+
+*rhythmbox-0.11.6-r1 (14 Sep 2008)
+
+ 14 Sep 2008; Arun Raghavan <ford_prefect@gentoo.org>
+ +rhythmbox-0.11.6-r1.ebuild:
+ Depend on gnome-python components (gconf, gnome-vfs, libgnome), rather
+ than all of gnome-python. Thanks to Nirbheek Chauhan (bheekling) for the
+ work on this.
23 Jul 2008; Gilles Dartiguelongue <eva@gentoo.org>
rhythmbox-0.11.6.ebuild:
diff --git a/media-sound/rhythmbox/rhythmbox-0.11.6-r1.ebuild b/media-sound/rhythmbox/rhythmbox-0.11.6-r1.ebuild
new file mode 100644
index 000000000000..0aae9679a533
--- /dev/null
+++ b/media-sound/rhythmbox/rhythmbox-0.11.6-r1.ebuild
@@ -0,0 +1,161 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/rhythmbox/rhythmbox-0.11.6-r1.ebuild,v 1.1 2008/09/14 18:52:27 ford_prefect Exp $
+
+EAPI="1"
+
+inherit gnome2 eutils python virtualx
+
+DESCRIPTION="Music management and playback software for GNOME"
+HOMEPAGE="http://www.rhythmbox.org/"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE="cdr daap dbus doc hal ipod gnome-keyring libnotify lirc musicbrainz mtp python tagwriting"
+
+# I want tagwriting to be on by default in the future. It is just a local flag
+# now because it is still considered experimental by upstream and doesn't work
+# well with all formats due to gstreamer limitation.
+
+# FIXME: double check what to do with fm-radio plugin an itunes browser
+
+SLOT="0"
+
+RDEPEND=">=x11-libs/gtk+-2.8
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libglade-2
+ >=gnome-base/gnome-vfs-2.8
+ >=dev-libs/totem-pl-parser-2.22.0
+ cdr? ( >=gnome-extra/nautilus-cd-burner-2.13 )
+ >=x11-libs/libsexy-0.1.5
+ >=gnome-extra/gnome-media-2.14.0
+ gnome-keyring? ( >=gnome-base/gnome-keyring-0.4.9 )
+ musicbrainz? ( >=media-libs/musicbrainz-2.1:1 )
+ >=net-libs/libsoup-2.4:2.4
+ lirc? ( app-misc/lirc )
+ hal? (
+ ipod? ( >=media-libs/libgpod-0.6 )
+ mtp? ( >=media-libs/libmtp-0.3.0 )
+ >=sys-apps/hal-0.5
+ )
+ daap? ( >=net-dns/avahi-0.6 )
+ dbus? ( >=dev-libs/dbus-glib-0.71 )
+ >=media-libs/gst-plugins-base-0.10.12
+ >=media-plugins/gst-plugins-gnomevfs-0.10
+ || (
+ >=media-plugins/gst-plugins-cdparanoia-0.10
+ >=media-plugins/gst-plugins-cdio-0.10
+ )
+ >=media-plugins/gst-plugins-meta-0.10-r2:0.10
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )
+ tagwriting? ( >=media-plugins/gst-plugins-taglib-0.10.6 )
+ python? (
+ >=dev-lang/python-2.4.2
+ || (
+ >=dev-lang/python-2.5
+ dev-python/celementtree
+ )
+ >=dev-python/pygtk-2.8
+ >=dev-python/gnome-vfs-python-2.22.0
+ >=dev-python/gconf-python-2.22.0
+ >=dev-python/libgnome-python-2.22.0
+ >=dev-python/gst-python-0.10.8
+ )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35
+ app-text/scrollkeeper
+ app-text/gnome-doc-utils
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+DOCS="AUTHORS ChangeLog DOCUMENTERS INTERNALS \
+ MAINTAINERS NEWS README README.iPod THANKS TODO"
+
+pkg_setup() {
+
+ if ! use hal && use ipod; then
+ ewarn "ipod support requires hal support. Please"
+ ewarn "re-emerge with USE=hal to enable ipod support"
+ fi
+
+ if ! use hal && use mtp; then
+ ewarn "MTP support requires hal support. Please"
+ ewarn "re-emerge with USE=hal to enable MTP support"
+ fi
+
+ if ! use cdr ; then
+ ewarn "You have cdr USE flag disabled."
+ ewarn "You will not be able to play audio CDs."
+ fi
+
+ if use daap ; then
+ G2CONF="${G2CONF} --enable-daap --with-mdns=avahi"
+ else
+ G2CONF="${G2CONF} --disable-daap"
+ fi
+
+ G2CONF="${G2CONF}
+ $(use_with cdr libnautilus-burn)
+ $(use_with cdr cd-burning)
+ $(use_with dbus)
+ $(use_with gnome-keyring)
+ $(use_with ipod)
+ $(use_enable ipod ipod-writing)
+ $(use_enable libnotify)
+ $(use_enable lirc)
+ $(use_enable musicbrainz)
+ $(use_with mtp)
+ $(use_enable python)
+ $(use_enable tagwriting tag-writing)
+ --with-playback=gstreamer-0-10
+ --enable-mmkeys
+ --enable-audioscrobbler
+ --enable-track-transfer
+ --with-metadata-helper
+ --disable-scrollkeeper
+ --disable-schemas-install
+ --disable-vala"
+
+ export GST_INSPECT=/bin/true
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix for libmtp-0.3.0 API change
+ epatch "${FILESDIR}/${PN}-0.11.5-libmtp-0.3.0-API.patch"
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+src_compile() {
+ addpredict "$(unset HOME; echo ~)/.gconf"
+ addpredict "$(unset HOME; echo ~)/.gconfd"
+ gnome2_src_compile
+}
+
+src_test() {
+ Xemake check || die "test failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ use python && python_mod_optimize /usr/$(get_libdir)/rhythmbox/plugins
+
+ ewarn
+ ewarn "If ${PN} doesn't play some music format, please check your"
+ ewarn "USE flags on media-plugins/gst-plugins-meta"
+ ewarn
+
+ elog "The aac flag has been removed from rhythmbox."
+ elog "This is due to stabilization issues with any gst-bad plugins."
+ elog "Please emerge gst-plugins-bad and gst-plugins-faad to be able to play m4a files"
+ elog "See bug #159538 for more information"
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ use python && python_mod_cleanup /usr/$(get_libdir)/rhythmbox/plugins
+}