summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-05-10 19:01:23 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-05-10 19:01:23 +0000
commit8777dd5c5eda37c0c70e1ee8f46e33cf0cdde6fa (patch)
tree68c1f6ef626cd6325b73eaf2c298b2e55d64c544 /media-sound/qsynth
parentRemoving vulnerable versions (#268515), fixing license (#233747). (diff)
downloadgentoo-2-8777dd5c5eda37c0c70e1ee8f46e33cf0cdde6fa.tar.gz
gentoo-2-8777dd5c5eda37c0c70e1ee8f46e33cf0cdde6fa.tar.bz2
gentoo-2-8777dd5c5eda37c0c70e1ee8f46e33cf0cdde6fa.zip
version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/qsynth')
-rw-r--r--media-sound/qsynth/ChangeLog9
-rw-r--r--media-sound/qsynth/qsynth-0.3.4.ebuild62
2 files changed, 69 insertions, 2 deletions
diff --git a/media-sound/qsynth/ChangeLog b/media-sound/qsynth/ChangeLog
index d09b3c3c88ae..5539bed56077 100644
--- a/media-sound/qsynth/ChangeLog
+++ b/media-sound/qsynth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/qsynth
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/ChangeLog,v 1.46 2009/05/08 22:06:40 gentoofan23 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/ChangeLog,v 1.47 2009/05/10 19:01:23 aballier Exp $
+
+*qsynth-0.3.4 (10 May 2009)
+
+ 10 May 2009; Alexis Ballier <aballier@gentoo.org> +qsynth-0.3.4.ebuild:
+ version bump
08 May 2009; Thomas Anderson <gentoofan23@gentoo.org>
-qsynth-0.3.1-r1.ebuild:
diff --git a/media-sound/qsynth/qsynth-0.3.4.ebuild b/media-sound/qsynth/qsynth-0.3.4.ebuild
new file mode 100644
index 000000000000..67a1afb037d4
--- /dev/null
+++ b/media-sound/qsynth/qsynth-0.3.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qsynth/qsynth-0.3.4.ebuild,v 1.1 2009/05/10 19:01:23 aballier Exp $
+
+EAPI=2
+
+inherit qt4 eutils flag-o-matic
+
+DESCRIPTION="A Qt application to control FluidSynth"
+HOMEPAGE="http://qsynth.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+IUSE="debug jack alsa pulseaudio"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="
+ || ( (
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ ) =x11-libs/qt-4.3*:4 )
+ >=media-sound/fluidsynth-1.0.7a[jack?,alsa?,pulseaudio?]
+ !pulseaudio? ( !jack? ( !alsa? ( >=media-sound/fluidsynth-1.0.7a[oss] ) ) )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # Stupidly, qsynth's configure does *not* use pkg-config to
+ # discover the presence of Qt4, but uses fixed paths; as they
+ # don't really work that well for our case, let's just use this
+ # nasty hack and be done with it. *NOTE*: this hinders
+ # cross-compile.
+ append-flags -I/usr/include/qt4
+ append-ldflags -L/usr/$(get_libdir)/qt4
+
+ econf \
+ $(use_enable debug) \
+ || die "econf failed"
+ eqmake4 "${PN}.pro" -o "${PN}.mak"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README TODO
+
+ # The desktop file is invalid, and we also change the command
+ # depending on useflags
+ rm -rf "${D}/usr/share/applications/qsynth.desktop"
+
+ local cmd
+ if use jack; then
+ cmd="qsynth"
+ elif use pulseaudio; then
+ cmd="qsynth -a pulseaudio"
+ elif use alsa; then
+ cmd="qsynth -a alsa"
+ else
+ cmd="qsynth -a oss"
+ fi
+
+ make_desktop_entry "${cmd}" Qsynth qsynth
+}