summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-10 12:28:39 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-10-10 12:28:39 +0000
commitb235144070ec60e04a1036c0c563557b5a318082 (patch)
treea902639dd38657207d03fabcc50d4c732aa86a6b /media-sound/qjackctl
parentUpdate to EAPI=2 and USE deps. (diff)
downloadgentoo-2-b235144070ec60e04a1036c0c563557b5a318082.tar.gz
gentoo-2-b235144070ec60e04a1036c0c563557b5a318082.tar.bz2
gentoo-2-b235144070ec60e04a1036c0c563557b5a318082.zip
Update to EAPI=2 and USE deps.
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'media-sound/qjackctl')
-rw-r--r--media-sound/qjackctl/ChangeLog8
-rw-r--r--media-sound/qjackctl/qjackctl-0.3.3-r1.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/media-sound/qjackctl/ChangeLog b/media-sound/qjackctl/ChangeLog
index 1dfde0688a9c..53753cfe2073 100644
--- a/media-sound/qjackctl/ChangeLog
+++ b/media-sound/qjackctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/qjackctl
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/ChangeLog,v 1.57 2008/07/27 01:08:05 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/ChangeLog,v 1.58 2008/10/10 12:28:39 flameeyes Exp $
+
+*qjackctl-0.3.3-r1 (10 Oct 2008)
+
+ 10 Oct 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +qjackctl-0.3.3-r1.ebuild:
+ Update to EAPI=2 and USE deps.
27 Jul 2008; Carsten Lohrke <carlo@gentoo.org> qjackctl-0.3.2.ebuild,
qjackctl-0.3.3.ebuild:
diff --git a/media-sound/qjackctl/qjackctl-0.3.3-r1.ebuild b/media-sound/qjackctl/qjackctl-0.3.3-r1.ebuild
new file mode 100644
index 000000000000..49f81fc574c1
--- /dev/null
+++ b/media-sound/qjackctl/qjackctl-0.3.3-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/qjackctl/qjackctl-0.3.3-r1.ebuild,v 1.1 2008/10/10 12:28:39 flameeyes Exp $
+
+EAPI=2
+
+inherit eutils qt4
+
+DESCRIPTION="A Qt application to control the JACK Audio Connection Kit and ALSA sequencer connections."
+HOMEPAGE="http://qjackctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+IUSE="alsa debug"
+
+DEPEND="alsa? ( media-libs/alsa-lib[midi] )
+ || ( (
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ ) =x11-libs/qt-4.3*:4 )
+ media-sound/jack-audio-connection-kit"
+
+src_configure() {
+ econf \
+ $(use_enable alsa alsa-seq) \
+ $(use_enable debug) \
+ || die "econf failed"
+
+ # Emulate what the Makefile does, so that we can get the correct
+ # compiler used.
+ eqmake4 ${PN}.pro -o ${PN}.mak || die "eqmake4 failed"
+}
+
+src_compile() {
+ emake -f ${PN}.mak || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ rm "${D}/usr/share/applications/qjackctl.desktop"
+
+ # Upstream desktop file is invalid, better stick with our for now.
+ make_desktop_entry "${PN}" "QjackCtl" "${PN}"
+
+ dodoc README ChangeLog TODO AUTHORS
+}